aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2017-02-24 20:42:18 -0800
committerSteve Arnold <stephen.arnold42@gmail.com>2017-02-24 20:42:18 -0800
commit7c4cf44e81122cd13336be08dd2012f67ed4f262 (patch)
treee023954cf90005850152a0b769a92ad40bf696a3
parentextra-cmake-modules: remove crufty/old version (diff)
downloadarm-7c4cf44e81122cd13336be08dd2012f67ed4f262.tar.gz
arm-7c4cf44e81122cd13336be08dd2012f67ed4f262.tar.bz2
arm-7c4cf44e81122cd13336be08dd2012f67ed4f262.zip
www-client/firefox: remove stale beta
Signed-off-by: Steve Arnold <stephen.arnold42@gmail.com>
-rw-r--r--eclass/mozconfig-v6.44.eclass285
-rw-r--r--www-client/firefox/firefox-44.0_beta4.ebuild410
2 files changed, 0 insertions, 695 deletions
diff --git a/eclass/mozconfig-v6.44.eclass b/eclass/mozconfig-v6.44.eclass
deleted file mode 100644
index fce86f0..0000000
--- a/eclass/mozconfig-v6.44.eclass
+++ /dev/null
@@ -1,285 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-#
-# @ECLASS: mozconfig-v6.40.eclass
-# @MAINTAINER:
-# mozilla team <mozilla@gentoo.org>
-# @BLURB: the new mozilla common configuration eclass for FF33 and newer, v6
-# @DESCRIPTION:
-# This eclass is used in mozilla ebuilds (firefox, thunderbird, seamonkey)
-# to provide a single common place for the common mozilla engine compoments.
-#
-# The eclass provides all common dependencies as well as common use flags.
-#
-# Some use flags which may be optional in particular mozilla packages can be
-# supported through setting eclass variables.
-#
-# This eclass inherits mozconfig helper functions as defined in mozcoreconf-v3,
-# and so ebuilds inheriting this eclass do not need to inherit that.
-
-inherit multilib flag-o-matic toolchain-funcs mozcoreconf-v3
-
-case ${EAPI} in
- 0|1|2|3|4) die "EAPI=${EAPI} not supported"
-esac
-
-# @ECLASS-VARIABLE: MOZCONFIG_OPTIONAL_WIFI
-# @DESCRIPTION:
-# Set this variable before the inherit line, when an ebuild needs to provide
-# optional necko-wifi support via IUSE="wifi". Currently this would include
-# ebuilds for firefox, and potentially seamonkey.
-#
-# Leave the variable UNSET if necko-wifi support should not be available.
-# Set the variable to "enabled" if the use flag should be enabled by default.
-# Set the variable to any value if the use flag should exist but not be default-enabled.
-
-# @ECLASS-VARIABLE: MOZCONFIG_OPTIONAL_JIT
-# @DESCRIPTION:
-# Set this variable before the inherit line, when an ebuild needs to provide
-# optional necko-wifi support via IUSE="jit". Currently this would include
-# ebuilds for firefox, and potentially seamonkey.
-#
-# Leave the variable UNSET if optional jit support should not be available.
-# Set the variable to "enabled" if the use flag should be enabled by default.
-# Set the variable to any value if the use flag should exist but not be default-enabled.
-
-# @ECLASS-VARIABLE: MOZCONFIG_OPTIONAL_GTK3
-# @DESCRIPTION:
-# Set this variable before the inherit line, when an ebuild can provide
-# optional gtk3 support via IUSE="gtk3". Currently this would include
-# ebuilds for firefox, but thunderbird and seamonkey could follow in the future.
-#
-# Leave the variable UNSET if gtk3 support should not be available.
-# Set the variable to "enabled" if the use flag should be enabled by default.
-# Set the variable to any value if the use flag should exist but not be default-enabled.
-
-# use-flags common among all mozilla ebuilds
-IUSE="${IUSE} dbus debug +gstreamer gstreamer-0 +jemalloc3 neon pulseaudio selinux startup-notification system-cairo
- system-icu system-jpeg system-libevent system-sqlite system-libvpx"
-
-# some notes on deps:
-# gtk:2 minimum is technically 2.10 but gio support (enabled by default) needs 2.14
-# media-libs/mesa needs to be 10.2 or above due to a bug with flash+vdpau
-
-RDEPEND=">=app-text/hunspell-1.2
- dev-libs/atk
- dev-libs/expat
- >=dev-libs/libevent-1.4.7
- >=x11-libs/cairo-1.10[X]
- >=x11-libs/gtk+-2.18:2
- x11-libs/gdk-pixbuf
- >=x11-libs/pango-1.22.0
- >=media-libs/libpng-1.6.17:0=[apng]
- >=media-libs/mesa-10.2:*
- media-libs/fontconfig
- >=media-libs/freetype-2.4.10
- kernel_linux? ( media-libs/alsa-lib )
- pulseaudio? ( media-sound/pulseaudio )
- virtual/freedesktop-icon-theme
- dbus? ( >=sys-apps/dbus-0.60
- >=dev-libs/dbus-glib-0.72 )
- startup-notification? ( >=x11-libs/startup-notification-0.8 )
- >=dev-libs/glib-2.26:2
- >=sys-libs/zlib-1.2.3
- >=virtual/libffi-3.0.10
- gstreamer? (
- >=media-libs/gstreamer-1.4.5:1.0
- >=media-libs/gst-plugins-base-1.4.5:1.0
- >=media-libs/gst-plugins-good-1.4.5:1.0
- >=media-plugins/gst-plugins-libav-1.4.5:1.0
- )
- gstreamer-0? (
- >=media-libs/gstreamer-0.10.25:0.10
- media-plugins/gst-plugins-meta:0.10[ffmpeg]
- )
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrender
- x11-libs/libXt
- system-cairo? ( >=x11-libs/cairo-1.12[X,xcb] >=x11-libs/pixman-0.19.2 )
- system-icu? ( >=dev-libs/icu-51.1:= )
- system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
- system-libevent? ( =dev-libs/libevent-2.0* )
- system-sqlite? ( >=dev-db/sqlite-3.9.1:3[secure-delete,debug=] )
- system-libvpx? ( >=media-libs/libvpx-1.3.0:0=[postproc] )
-"
-
-if [[ -n ${MOZCONFIG_OPTIONAL_GTK3} ]]; then
- if [[ ${MOZCONFIG_OPTIONAL_GTK3} = "enabled" ]]; then
- IUSE+=" +gtk3"
- else
- IUSE+=" gtk3"
- fi
- RDEPEND+="
- gtk3? ( >=x11-libs/gtk+-3.4.0:3 )"
-fi
-if [[ -n ${MOZCONFIG_OPTIONAL_WIFI} ]]; then
- if [[ ${MOZCONFIG_OPTIONAL_WIFI} = "enabled" ]]; then
- IUSE+=" +wifi"
- else
- IUSE+=" wifi"
- fi
- RDEPEND+="
- wifi? (
- kernel_linux? ( >=sys-apps/dbus-0.60
- >=dev-libs/dbus-glib-0.72
- net-misc/networkmanager )
- )"
-fi
-if [[ -n ${MOZCONFIG_OPTIONAL_JIT} ]]; then
- if [[ ${MOZCONFIG_OPTIONAL_JIT} = "enabled" ]]; then
- IUSE+=" +jit"
- else
- IUSE+=" jit"
- fi
-fi
-
-DEPEND="app-arch/zip
- app-arch/unzip
- >=sys-devel/binutils-2.16.1
- ${RDEPEND}"
-
-RDEPEND+="
- selinux? ( sec-policy/selinux-mozilla )"
-
-# only one of gstreamer and gstreamer-0 can be enabled at a time, so set REQUIRED_USE to signify this
-REQUIRED_USE="?? ( gstreamer gstreamer-0 )"
-
-# @FUNCTION: mozconfig_config
-# @DESCRIPTION:
-# Set common configure options for mozilla packages.
-# Call this within src_configure() phase, after mozconfig_init
-#
-# Example:
-#
-# inherit mozconfig-v5.33
-#
-# src_configure() {
-# mozconfig_init
-# mozconfig_config
-# # ... misc ebuild-unique settings via calls to
-# # ... mozconfig_{annotate,use_with,use_enable}
-# mozconfig_final
-# }
-
-mozconfig_config() {
- # Migrated from mozcoreconf-2
- mozconfig_annotate 'system_libs' \
- --with-system-zlib \
- --enable-pango \
- --enable-svg \
- --with-system-bz2
-
- if [[ -n ${MOZCONFIG_OPTIONAL_GTK3} ]]; then
- mozconfig_annotate 'gtk3 use flag' --enable-default-toolkit=$(usex gtk3 cairo-gtk3 cairo-gtk2)
- else
- mozconfig_annotate '' --enable-default-toolkit=cairo-gtk2
- fi
-
- if has bindist ${IUSE}; then
- mozconfig_use_enable !bindist official-branding
- if [[ ${PN} == firefox ]] && use bindist ; then
- mozconfig_annotate '' --with-branding=browser/branding/aurora
- fi
- fi
-
- mozconfig_use_enable debug
- mozconfig_use_enable debug tests
-
- if ! use debug ; then
- mozconfig_annotate 'disabled by Gentoo' --disable-debug-symbols
- else
- mozconfig_annotate 'enabled by Gentoo' --enable-debug-symbols
- fi
-
- mozconfig_use_enable startup-notification
-
- if [[ -n ${MOZCONFIG_OPTIONAL_WIFI} ]] ; then
- # wifi pulls in dbus so manage both here
- mozconfig_use_enable wifi necko-wifi
- if use kernel_linux && use wifi && ! use dbus; then
- echo "Enabling dbus support due to wifi request"
- mozconfig_annotate 'dbus required by necko-wifi on linux' --enable-dbus
- else
- mozconfig_use_enable dbus
- fi
- else
- mozconfig_use_enable dbus
- mozconfig_annotate 'disabled' --disable-necko-wifi
- fi
-
- # These are forced-on for webm support
- mozconfig_annotate 'required' --enable-ogg
- mozconfig_annotate 'required' --enable-wave
-
- if [[ -n ${MOZCONFIG_OPTIONAL_JIT} ]]; then
- mozconfig_use_enable jit ion
- fi
-
- # These are enabled by default in all mozilla applications
- mozconfig_annotate '' --with-system-nspr --with-nspr-prefix="${EPREFIX}"/usr
- mozconfig_annotate '' --with-system-nss --with-nss-prefix="${EPREFIX}"/usr
- mozconfig_annotate '' --x-includes="${EPREFIX}"/usr/include --x-libraries="${EPREFIX}"/usr/$(get_libdir)
- if use system-libevent; then
- mozconfig_annotate '' --with-system-libevent="${EPREFIX}"/usr
- fi
- mozconfig_annotate '' --prefix="${EPREFIX}"/usr
- mozconfig_annotate '' --libdir="${EPREFIX}"/usr/$(get_libdir)
- mozconfig_annotate 'Gentoo default' --enable-system-hunspell
- mozconfig_annotate '' --disable-gnomeui
- mozconfig_annotate '' --enable-gio
- mozconfig_annotate '' --disable-crashreporter
- mozconfig_annotate 'Gentoo default' --with-system-png
- mozconfig_annotate '' --enable-system-ffi
- mozconfig_annotate 'Gentoo default to honor system linker' --disable-gold
- mozconfig_annotate 'Gentoo default' --disable-skia
- mozconfig_annotate '' --disable-gconf
-
- # Use jemalloc unless libc is not glibc >= 2.4
- # at this time the minimum glibc in the tree is 2.9 so we should be safe.
- if use elibc_glibc && use jemalloc3; then
- # We must force-enable jemalloc 3 via .mozconfig
- echo "export MOZ_JEMALLOC3=1" >> "${S}"/.mozconfig || die
- mozconfig_annotate '' --enable-jemalloc
- mozconfig_annotate '' --enable-replace-malloc
- fi
-
- mozconfig_annotate '' --target="${CTARGET:-${CHOST}}"
- mozconfig_annotate '' --build="${CTARGET:-${CHOST}}"
-
- if use gstreamer ; then
- mozconfig_annotate '+gstreamer' --enable-gstreamer=1.0
- elif use gstreamer-0 ; then
- mozconfig_annotate '+gstreamer-0' --enable-gstreamer=0.10
- else
- mozconfig_annotate '' --disable-gstreamer
- fi
- mozconfig_use_enable pulseaudio
-
- mozconfig_use_enable system-cairo
- mozconfig_use_enable system-sqlite
- mozconfig_use_with system-jpeg
- mozconfig_use_with system-icu
- mozconfig_use_with system-icu intl-api
- mozconfig_use_with system-libvpx
-
- # Modifications to better support ARM, bug 553364
- if use neon ; then
- mozconfig_annotate '' --with-fpu=neon
- mozconfig_annotate '' --with-thumb=yes
- mozconfig_annotate '' --with-thumb-interwork=no
- fi
- if [[ ${CHOST} == armv* ]] ; then
- mozconfig_annotate '' --with-float-abi=hard
- mozconfig_annotate '' --enable-skia
-
- if ! use system-libvpx ; then
- sed -i -e "s|softfp|hard|" \
- "${S}"/media/libvpx/moz.build
- fi
- fi
-}
diff --git a/www-client/firefox/firefox-44.0_beta4.ebuild b/www-client/firefox/firefox-44.0_beta4.ebuild
deleted file mode 100644
index 324c325..0000000
--- a/www-client/firefox/firefox-44.0_beta4.ebuild
+++ /dev/null
@@ -1,410 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-VIRTUALX_REQUIRED="pgo"
-WANT_AUTOCONF="2.1"
-MOZ_ESR=""
-
-# This list can be updated with scripts/get_langs.sh from the mozilla overlay
-# No official support as of fetch time
-# csb
-MOZ_LANGS=( af ar as ast be bg bn-BD bn-IN br bs ca cs cy da de el en
-en-GB en-US en-ZA eo es-AR es-CL es-ES es-MX et eu fa fi fr fy-NL ga-IE gd
-gl gu-IN he hi-IN hr hu hy-AM id is it ja kk km kn ko lt lv mai mk ml mr
-nb-NO nl nn-NO or pa-IN pl pt-BR pt-PT rm ro ru si sk sl son sq sr sv-SE ta te
-th tr uk vi xh zh-CN zh-TW )
-
-# Convert the ebuild version to the upstream mozilla version, used by mozlinguas
-MOZ_PV="${PV/_alpha/a}" # Handle alpha for SRC_URI
-MOZ_PV="${MOZ_PV/_beta/b}" # Handle beta for SRC_URI
-MOZ_PV="${MOZ_PV/_rc/rc}" # Handle rc for SRC_URI
-
-if [[ ${MOZ_ESR} == 1 ]]; then
- # ESR releases have slightly version numbers
- MOZ_PV="${MOZ_PV}esr"
-fi
-
-# Patch version
-PATCH="${PN}-44.0-patches-0.1"
-MOZ_HTTP_URI="http://archive.mozilla.org/pub/${PN}/releases"
-
-MOZCONFIG_OPTIONAL_GTK3=1
-MOZCONFIG_OPTIONAL_WIFI=1
-MOZCONFIG_OPTIONAL_JIT="enabled"
-
-inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils mozconfig-v6.44 multilib pax-utils fdo-mime autotools virtualx mozlinguas
-
-DESCRIPTION="Firefox Web Browser"
-HOMEPAGE="http://www.mozilla.com/firefox"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-SLOT="0"
-LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="bindist egl hardened +hwaccel +minimal neon pgo selinux +gmp-autoupdate test"
-RESTRICT="!bindist? ( bindist )"
-
-# More URIs appended below...
-SRC_URI="${SRC_URI}
- https://dev.gentoo.org/~anarchy/mozilla/patchsets/${PATCH}.tar.xz
- https://dev.gentoo.org/~axs/mozilla/patchsets/${PATCH}.tar.xz
- https://dev.gentoo.org/~polynomial-c/mozilla/patchsets/${PATCH}.tar.xz"
-
-ASM_DEPEND=">=dev-lang/yasm-1.1"
-
-# Mesa 7.10 needed for WebGL + bugfixes
-RDEPEND="
- >=dev-libs/nss-3.20.1
- >=dev-libs/nspr-4.10.10-r1
- selinux? ( sec-policy/selinux-mozilla )"
-
-DEPEND="${RDEPEND}
- pgo? (
- >=sys-devel/gcc-4.5 )
- amd64? ( ${ASM_DEPEND}
- virtual/opengl )
- x86? ( ${ASM_DEPEND}
- virtual/opengl )"
-
-# No source releases for alpha|beta
-if [[ ${PV} =~ alpha ]]; then
- CHANGESET="8a3042764de7"
- SRC_URI="${SRC_URI}
- https://dev.gentoo.org/~nirbheek/mozilla/firefox/firefox-${MOZ_PV}_${CHANGESET}.source.tar.xz"
- S="${WORKDIR}/mozilla-aurora-${CHANGESET}"
-else
- S="${WORKDIR}/firefox-${MOZ_PV}"
- SRC_URI="${SRC_URI}
- ${MOZ_HTTP_URI}/${MOZ_PV}/source/firefox-${MOZ_PV}.source.tar.xz"
-fi
-
-QA_PRESTRIPPED="usr/$(get_libdir)/${PN}/firefox"
-
-BUILD_OBJ_DIR="${S}/ff"
-
-pkg_setup() {
- moz_pkgsetup
-
- # Avoid PGO profiling problems due to enviroment leakage
- # These should *always* be cleaned up anyway
- unset DBUS_SESSION_BUS_ADDRESS \
- DISPLAY \
- ORBIT_SOCKETDIR \
- SESSION_MANAGER \
- XDG_SESSION_COOKIE \
- XAUTHORITY
-
- if ! use bindist; then
- einfo
- elog "You are enabling official branding. You may not redistribute this build"
- elog "to any users on your network or the internet. Doing so puts yourself into"
- elog "a legal problem with Mozilla Foundation"
- elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag"
- fi
-
- if use pgo; then
- einfo
- ewarn "You will do a double build for profile guided optimization."
- ewarn "This will result in your build taking at least twice as long as before."
- fi
-}
-
-pkg_pretend() {
- # Ensure we have enough disk space to compile
- if use pgo || use debug || use test ; then
- CHECKREQS_DISK_BUILD="8G"
- else
- CHECKREQS_DISK_BUILD="4G"
- fi
- check-reqs_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
-
- # Unpack language packs
- mozlinguas_src_unpack
-}
-
-src_prepare() {
- # Apply our patches
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}/firefox"
-
- # Allow user to apply any additional patches without modifing ebuild
- epatch_user
-
- # Enable gnomebreakpad
- if use debug ; then
- sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \
- "${S}"/build/unix/run-mozilla.sh || die "sed failed!"
- fi
-
- # Ensure that our plugins dir is enabled as default
- sed -i -e "s:/usr/lib/mozilla/plugins:/usr/lib/nsbrowser/plugins:" \
- "${S}"/xpcom/io/nsAppFileLocationProvider.cpp || die "sed failed to replace plugin path for 32bit!"
- sed -i -e "s:/usr/lib64/mozilla/plugins:/usr/lib64/nsbrowser/plugins:" \
- "${S}"/xpcom/io/nsAppFileLocationProvider.cpp || die "sed failed to replace plugin path for 64bit!"
-
- # Fix sandbox violations during make clean, bug 372817
- sed -e "s:\(/no-such-file\):${T}\1:g" \
- -i "${S}"/config/rules.mk \
- -i "${S}"/nsprpub/configure{.in,} \
- || die
-
- # Don't exit with error when some libs are missing which we have in
- # system.
- sed '/^MOZ_PKG_FATAL_WARNINGS/s@= 1@= 0@' \
- -i "${S}"/browser/installer/Makefile.in || die
-
- # Don't error out when there's no files to be removed:
- sed 's@\(xargs rm\)$@\1 -f@' \
- -i "${S}"/toolkit/mozapps/installer/packager.mk || die
-
- # Keep codebase the same even if not using official branding
- sed '/^MOZ_DEV_EDITION=1/d' \
- -i "${S}"/browser/branding/aurora/configure.sh || die
-
- eautoreconf
-
- # Must run autoconf in js/src
- cd "${S}"/js/src || die
- eautoconf
-
- # Need to update jemalloc's configure
- cd "${S}"/memory/jemalloc/src || die
- WANT_AUTOCONF= eautoconf
-}
-
-src_configure() {
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
- MEXTENSIONS="default"
- # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
- # Note: These are for Gentoo Linux use ONLY. For your own distribution, please
- # get your own set of keys.
- _google_api_key=AIzaSyDEAOvatFo0eTgsV_ZlEzx0ObmepsMzfAc
-
- ####################################
- #
- # mozconfig, CFLAGS and CXXFLAGS setup
- #
- ####################################
-
- mozconfig_init
- mozconfig_config
-
- # We want rpath support to prevent unneeded hacks on different libc variants
- append-ldflags -Wl,-rpath-link="${MOZILLA_FIVE_HOME}"
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- # Add full relro support for hardened
- use hardened && append-ldflags "-Wl,-z,relro,-z,now"
-
- if use neon ; then
- mozconfig_annotate '' --with-fpu=neon
- mozconfig_annotate '' --with-thumb=yes
- mozconfig_annotate '' --with-thumb-interwork=no
- fi
-
- if [[ ${CHOST} == armv* ]] ; then
- mozconfig_annotate '' --with-float-abi=hard
- if ! use system-libvpx ; then
- sed -i -e "s|softfp|hard|" \
- "${S}"/media/libvpx/moz.build
- fi
- fi
-
- # workaround for arm config missing graphics
- use arm && mozconfig_annotate '' --enable-skia
-
-# use egl && mozconfig_annotate 'Enable EGL as GL provider' --with-gl-provider=EGL
-
- # Setup api key for location services
- echo -n "${_google_api_key}" > "${S}"/google-api-key
- mozconfig_annotate '' --with-google-api-keyfile="${S}/google-api-key"
-
- mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
- mozconfig_annotate '' --disable-mailnews
-
- # Other ff-specific settings
- mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
-
- # Allow for a proper pgo build
- if use pgo; then
- echo "mk_add_options PROFILE_GEN_SCRIPT='\$(PYTHON) \$(OBJDIR)/_profile/pgo/profileserver.py'" >> "${S}"/.mozconfig
- fi
-
- echo "mk_add_options MOZ_OBJDIR=${BUILD_OBJ_DIR}" >> "${S}"/.mozconfig
-
- # Finalize and report settings
- mozconfig_final
-
- if [[ $(gcc-major-version) -lt 4 ]]; then
- append-cxxflags -fno-stack-protector
- fi
-
- # workaround for funky/broken upstream configure...
- emake -f client.mk configure
-}
-
-src_compile() {
- if use pgo; then
- addpredict /root
- addpredict /etc/gconf
- # Reset and cleanup environment variables used by GNOME/XDG
- gnome2_environment_reset
-
- # Firefox tries to use dri stuff when it's run, see bug 380283
- shopt -s nullglob
- cards=$(echo -n /dev/dri/card* | sed 's/ /:/g')
- if test -z "${cards}"; then
- cards=$(echo -n /dev/ati/card* /dev/nvidiactl* | sed 's/ /:/g')
- if test -n "${cards}"; then
- # Binary drivers seem to cause access violations anyway, so
- # let's use indirect rendering so that the device files aren't
- # touched at all. See bug 394715.
- export LIBGL_ALWAYS_INDIRECT=1
- fi
- fi
- shopt -u nullglob
- addpredict "${cards}"
-
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX%/}/bin/bash}" \
- Xemake -f client.mk profiledbuild || die "Xemake failed"
- else
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX%/}/bin/bash}" \
- emake -f client.mk realbuild
- fi
-
-}
-
-src_install() {
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
- DICTPATH="\"${EPREFIX}/usr/share/myspell\""
-
- cd "${BUILD_OBJ_DIR}" || die
-
- # Pax mark xpcshell for hardened support, only used for startupcache creation.
- pax-mark m "${BUILD_OBJ_DIR}"/dist/bin/xpcshell
-
- # Add our default prefs for firefox
- cp "${FILESDIR}"/gentoo-default-prefs.js-1 \
- "${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
- || die
-
- # Augment this with hwaccel prefs
- if use hwaccel ; then
- cat "${FILESDIR}"/gentoo-hwaccel-prefs.js-1 >> \
- "${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
- || die
- fi
-
- # Set default path to search for dictionaries.
- echo "pref(\"spellchecker.dictionary_path\", ${DICTPATH});" \
- >> "${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
- || die
-
- echo "pref(\"extensions.autoDisableScopes\", 3);" >> \
- "${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
- || die
-
- local plugin
- use gmp-autoupdate || for plugin in \
- gmp-gmpopenh264 ; do
- echo "pref(\"media.${plugin}.autoupdate\", false);" >> \
- "${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
- || die
- done
-
- MOZ_MAKE_FLAGS="${MAKEOPTS}" \
- emake DESTDIR="${D}" install
-
- # Install language packs
- mozlinguas_src_install
-
- local size sizes icon_path icon name
- if use bindist; then
- sizes="16 32 48"
- icon_path="${S}/browser/branding/aurora"
- # Firefox's new rapid release cycle means no more codenames
- # Let's just stick with this one...
- icon="aurora"
- name="Aurora"
-
- # Override preferences to set the MOZ_DEV_EDITION defaults, since we
- # don't define MOZ_DEV_EDITION to avoid profile debaucles.
- # (source: browser/app/profile/firefox.js)
- cat >>"${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" <<PROFILE_EOF
-pref("app.feedback.baseURL", "https://input.mozilla.org/%LOCALE%/feedback/firefoxdev/%VERSION%/");
-sticky_pref("lightweightThemes.selectedThemeID", "firefox-devedition@mozilla.org");
-sticky_pref("browser.devedition.theme.enabled", true);
-sticky_pref("devtools.theme", "dark");
-PROFILE_EOF
-
- else
- sizes="16 22 24 32 256"
- icon_path="${S}/browser/branding/official"
- icon="${PN}"
- name="Mozilla Firefox"
- fi
-
- # Install icons and .desktop for menu entry
- for size in ${sizes}; do
- insinto "/usr/share/icons/hicolor/${size}x${size}/apps"
- newins "${icon_path}/default${size}.png" "${icon}.png"
- done
- # The 128x128 icon has a different name
- insinto "/usr/share/icons/hicolor/128x128/apps"
- newins "${icon_path}/mozicon128.png" "${icon}.png"
- # Install a 48x48 icon into /usr/share/pixmaps for legacy DEs
- newicon "${icon_path}/content/icon48.png" "${icon}.png"
- newmenu "${FILESDIR}/icon/${PN}.desktop" "${PN}.desktop"
- sed -i -e "s:@NAME@:${name}:" -e "s:@ICON@:${icon}:" \
- "${ED}/usr/share/applications/${PN}.desktop" || die
-
- # Add StartupNotify=true bug 237317
- if use startup-notification ; then
- echo "StartupNotify=true"\
- >> "${ED}/usr/share/applications/${PN}.desktop" \
- || die
- fi
-
- # Required in order to use plugins and even run firefox on hardened.
- if use jit; then
- pax-mark m "${ED}"${MOZILLA_FIVE_HOME}/{firefox,firefox-bin,plugin-container}
- else
- pax-mark m "${ED}"${MOZILLA_FIVE_HOME}/plugin-container
- fi
-
- if use minimal; then
- rm -r "${ED}"/usr/include "${ED}${MOZILLA_FIVE_HOME}"/{idl,include,lib,sdk} \
- || die "Failed to remove sdk and headers"
- fi
-
- # very ugly hack to make firefox not sigbus on sparc
- # FIXME: is this still needed??
- use sparc && { sed -e 's/Firefox/FirefoxGentoo/g' \
- -i "${ED}/${MOZILLA_FIVE_HOME}/application.ini" \
- || die "sparc sed failed"; }
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- # Update mimedb for the new .desktop file
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}