aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:49:41 -0700
committerSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:49:41 -0700
commit7f6af41a275f98c83ee76de2cb763afc1b2e2bd7 (patch)
tree77c5c6324692b0e8825dd3aa2bdf85df7171077a
parentx11-drivers/xf86-video-armada: add "version" to build against libetnaviv (diff)
downloadarm-7f6af41a275f98c83ee76de2cb763afc1b2e2bd7.tar.gz
arm-7f6af41a275f98c83ee76de2cb763afc1b2e2bd7.tar.bz2
arm-7f6af41a275f98c83ee76de2cb763afc1b2e2bd7.zip
x11-libs/libdrm: update latest versions for foss graphics
* add some release versions * switch git build to tegra-specific upstream Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
-rw-r--r--x11-libs/libdrm/files/libdrm-update_default_perms.patch12
-rw-r--r--x11-libs/libdrm/libdrm-2.4.70.ebuild67
-rw-r--r--x11-libs/libdrm/libdrm-2.4.79.ebuild64
-rw-r--r--x11-libs/libdrm/libdrm-9999.ebuild10
4 files changed, 151 insertions, 2 deletions
diff --git a/x11-libs/libdrm/files/libdrm-update_default_perms.patch b/x11-libs/libdrm/files/libdrm-update_default_perms.patch
new file mode 100644
index 0000000..e469822
--- /dev/null
+++ b/x11-libs/libdrm/files/libdrm-update_default_perms.patch
@@ -0,0 +1,12 @@
+--- a/xf86drm.h
++++ b/xf86drm.h
+@@ -74,7 +74,7 @@ extern "C" {
+ /* Default /dev/dri directory permissions 0755 */
+ #define DRM_DEV_DIRMODE \
+ (S_IRUSR|S_IWUSR|S_IXUSR|S_IRGRP|S_IXGRP|S_IROTH|S_IXOTH)
+-#define DRM_DEV_MODE (S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP)
++#define DRM_DEV_MODE (S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH)
+
+ #ifdef __OpenBSD__
+ #define DRM_DIR_NAME "/dev"
+
diff --git a/x11-libs/libdrm/libdrm-2.4.70.ebuild b/x11-libs/libdrm/libdrm-2.4.70.ebuild
new file mode 100644
index 0000000..9d83920
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.70.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+else
+ SRC_URI="https://dri.freedesktop.org/${PN}/${P}.tar.bz2"
+fi
+
+KEYWORDS=""
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-arm-update.patch
+)
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ # tests are restricted, no point in building them
+ sed -ie 's/tests //' "${S}"/Makefile.am
+ fi
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ # Udev is only used by tests now.
+ --disable-udev
+ --disable-cairo-tests
+ $(use_enable video_cards_amdgpu amdgpu)
+ $(use_enable video_cards_exynos exynos-experimental-api)
+ $(use_enable video_cards_freedreno freedreno)
+ $(use_enable video_cards_intel intel)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable video_cards_omap omap-experimental-api)
+ $(use_enable video_cards_radeon radeon)
+ $(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vc4 vc4)
+ $(use_enable video_cards_vivante etnaviv-experimental-api)
+ $(use_enable video_cards_vmware vmwgfx)
+ $(use_enable libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ --enable-valgrind=$(usex valgrind auto no)
+ )
+
+ xorg-2_src_configure
+}
diff --git a/x11-libs/libdrm/libdrm-2.4.79.ebuild b/x11-libs/libdrm/libdrm-2.4.79.ebuild
new file mode 100644
index 0000000..c053e05
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.79.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+else
+ SRC_URI="https://dri.freedesktop.org/${PN}/${P}.tar.bz2"
+fi
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+PATCHES=( "${FILESDIR}/${PN}-update_default_perms.patch" )
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ # tests are restricted, no point in building them
+ sed -ie 's/tests //' "${S}"/Makefile.am
+ fi
+ xorg-2_src_prepare
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ # Udev is only used by tests now.
+ --disable-udev
+ --disable-cairo-tests
+ $(use_enable video_cards_amdgpu amdgpu)
+ $(use_enable video_cards_exynos exynos-experimental-api)
+ $(use_enable video_cards_freedreno freedreno)
+ $(use_enable video_cards_intel intel)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable video_cards_omap omap-experimental-api)
+ $(use_enable video_cards_radeon radeon)
+ $(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vc4 vc4)
+ $(use_enable video_cards_vivante etnaviv-experimental-api)
+ $(use_enable video_cards_vmware vmwgfx)
+ $(use_enable libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ --enable-valgrind=$(usex valgrind auto no)
+ )
+
+ xorg-2_src_configure
+}
diff --git a/x11-libs/libdrm/libdrm-9999.ebuild b/x11-libs/libdrm/libdrm-9999.ebuild
index c197f70..0396cdb 100644
--- a/x11-libs/libdrm/libdrm-9999.ebuild
+++ b/x11-libs/libdrm/libdrm-9999.ebuild
@@ -10,13 +10,15 @@ inherit xorg-2
DESCRIPTION="X.Org libdrm library"
HOMEPAGE="http://dri.freedesktop.org/"
if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+ #EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+ EGIT_REPO_URI="https://github.com/Gnurou/drm.git"
+ EGIT_BRANCH="fb_modifiers"
else
SRC_URI="http://dri.freedesktop.org/${PN}/${P}.tar.bz2"
fi
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
-VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vmware"
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -39,6 +41,8 @@ src_prepare() {
if [[ ${PV} = 9999* ]]; then
# tests are restricted, no point in building them
sed -ie 's/tests //' "${S}"/Makefile.am
+ # update version string so mesa is happy
+ sed -ie 's/2.4.74/2.4.75/' "${S}"/configure.ac
fi
xorg-2_src_prepare
}
@@ -49,6 +53,7 @@ src_configure() {
--disable-udev
--disable-cairo-tests
$(use_enable video_cards_amdgpu amdgpu)
+ $(use_enable video_cards_vivante etnaviv-experimental-api)
$(use_enable video_cards_exynos exynos-experimental-api)
$(use_enable video_cards_freedreno freedreno)
$(use_enable video_cards_intel intel)
@@ -56,6 +61,7 @@ src_configure() {
$(use_enable video_cards_omap omap-experimental-api)
$(use_enable video_cards_radeon radeon)
$(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vc4 vc4)
$(use_enable video_cards_vmware vmwgfx)
$(use_enable libkms)
# valgrind installs its .pc file to the pkgconfig for the primary arch