aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2016-11-27 15:02:11 -0800
committerSteve Arnold <stephen.arnold42@gmail.com>2016-11-27 15:02:11 -0800
commitbb68bdef39b703c7e50e239cdf8b856c4e6ab967 (patch)
tree6db246776c05cc4cee162b563879c23328add7cc
parentsys-devel/gcc: add stack-alignment patch to EPATCH_EXCLUDE (diff)
downloadarm-bb68bdef39b703c7e50e239cdf8b856c4e6ab967.tar.gz
arm-bb68bdef39b703c7e50e239cdf8b856c4e6ab967.tar.bz2
arm-bb68bdef39b703c7e50e239cdf8b856c4e6ab967.zip
sunxi-tools-9999.ebuild: add latest with option for C.H.I.P. branch
Signed-off-by: Steve Arnold <stephen.arnold42@gmail.com>
-rw-r--r--dev-embedded/sunxi-tools/metadata.xml15
-rw-r--r--dev-embedded/sunxi-tools/sunxi-tools-9999.ebuild42
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-embedded/sunxi-tools/metadata.xml b/dev-embedded/sunxi-tools/metadata.xml
new file mode 100644
index 0000000..c52cd11
--- /dev/null
+++ b/dev-embedded/sunxi-tools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sarnold/sunxi-tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-embedded/sunxi-tools/sunxi-tools-9999.ebuild b/dev-embedded/sunxi-tools/sunxi-tools-9999.ebuild
new file mode 100644
index 0000000..088d19d
--- /dev/null
+++ b/dev-embedded/sunxi-tools/sunxi-tools-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit eutils toolchain-funcs
+
+MY_PV="v${PV}"
+
+DESCRIPTION="Tools for C.H.I.P. and Allwinner A10 devices."
+HOMEPAGE="https://github.com/NextThingCo"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/sunxi-tools.git"
+ EGIT_BRANCH="master"
+ ## switch to branch below to build NextThing fork
+ #EGIT_BRANCH="chip-master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sarnold/sunxi-tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND="virtual/libusb"
+
+src_compile() {
+ emake CC="$(tc-getCC)" all misc
+}
+
+src_install() {
+ dobin bin2fex fex2bin phoenix_info
+ newbin sunxi-bootinfo bootinfo
+ newbin sunxi-fel fel
+ newbin sunxi-fexc fexc
+ newbin sunxi-nand-part nand-part
+ newbin sunxi-pio pio
+}