aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/cairo/cairo-9999.ebuild')
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild51
1 files changed, 15 insertions, 36 deletions
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
index 342ed08..4a5f2bd 100644
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ b/x11-libs/cairo/cairo-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils flag-o-matic autotools multilib-minimal
@@ -12,14 +12,14 @@ if [[ ${PV} == *9999* ]]; then
SRC_URI=""
else
SRC_URI="http://cairographics.org/releases/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="http://cairographics.org/"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="X aqua debug -directfb -drm egl -gallium -gles2 +glib -glx -opengl qt4 static-libs +svg valgrind xcb -xlib-xcb"
+IUSE="X aqua debug directfb gles2 +glib opengl static-libs +svg valgrind xcb xlib-xcb"
# gtk-doc regeneration doesn't seem to work with out-of-source builds
#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
@@ -34,19 +34,13 @@ RDEPEND=">=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
>=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
directfb? ( dev-libs/DirectFB )
- egl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
opengl? ( || ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] media-libs/opengl-apple ) )
- qt4? ( >=dev-qt/qtgui-4.8:4 )
X? (
>=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- drm? (
- >=virtual/libudev-208:=[${MULTILIB_USEDEP}]
- gallium? ( >=media-libs/mesa-9.1.6[gallium,${MULTILIB_USEDEP}] )
- )
)
xcb? (
>=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
@@ -60,10 +54,6 @@ DEPEND="${RDEPEND}
>=sys-devel/libtool-2
X? (
>=x11-proto/renderproto-0.11.1-r1[${MULTILIB_USEDEP}]
- drm? (
- >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
- >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
- )
)"
#[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
# doc? (
@@ -72,31 +62,27 @@ DEPEND="${RDEPEND}
# )"
REQUIRED_USE="
- drm? ( X )
- gallium? ( drm )
- egl? ( !glx !drm )
- gles2? ( !glx !drm )
- glx? ( !gles2 opengl )
+ gles2? ( !opengl )
xlib-xcb? ( xcb )
"
MULTILIB_WRAPPED_HEADERS=(
- /usr/include/cairo/cairo-features.h
/usr/include/cairo/cairo-directfb.h
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
+ "${FILESDIR}"/${PN}-respect-fontconfig.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
- epatch "${FILESDIR}"/${PN}-respect-fontconfig.patch
- epatch "${FILESDIR}"/${PN}-drm_missing_include.patch
+ default
# tests and perf tools require X, bug #483574
if ! use X; then
sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
fi
- epatch_user
-
# Slightly messed build system YAY
if [[ ${PV} == *9999* ]]; then
touch boilerplate/Makefile.am.features
@@ -110,10 +96,7 @@ src_prepare() {
multilib_src_configure() {
local myopts
- [[ ${CHOST} == *-interix* ]] && append-cppflags -D_REENTRANT
-
- strip-flags "-D*_SOURCE"
- append-cppflags -D_DEFAULT_SOURCE
+ [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
@@ -140,28 +123,24 @@ multilib_src_configure() {
$(use_enable aqua quartz) \
$(use_enable aqua quartz-image) \
$(use_enable debug test-surfaces) \
- $(use_enable drm) \
$(use_enable directfb) \
- $(use_enable egl) \
- $(use_enable gallium) \
$(use_enable gles2 glesv2) \
$(use_enable glib gobject) \
- $(use_enable glx) \
$(use_enable opengl gl) \
$(use_enable static-libs static) \
$(use_enable svg) \
$(use_enable valgrind) \
- $(use_enable qt4 qt) \
$(use_enable xcb) \
$(use_enable xcb xcb-shm) \
$(use_enable xlib-xcb) \
--enable-ft \
- --enable-fc
--enable-pdf \
--enable-png \
--enable-ps \
+ --disable-drm \
+ --disable-gallium \
+ --disable-qt \
--disable-vg \
- --disable-wgl \
${myopts}
}