summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2011-04-18 19:32:03 +1200
committerAlistair Bush <ali_bush@gentoo.org>2011-04-18 19:32:03 +1200
commit18ec490ed03db0afd110dc9f2b8c445a7e4b89e2 (patch)
treef0ca8e47408c76f6b76d032c77625d68abf3a574
parentNew package commonservicelocator. (diff)
downloaddotnet-2010.tar.gz
dotnet-2010.tar.bz2
dotnet-2010.zip
Add initial msbuildtasks ebuild.dotnet-2010
-rw-r--r--dev-dotnet/msbuildtasks/ChangeLog11
-rw-r--r--dev-dotnet/msbuildtasks/Manifest4
-rw-r--r--dev-dotnet/msbuildtasks/files/msbuildtasks-1.2.0.306-build.patch56
-rw-r--r--dev-dotnet/msbuildtasks/metadata.xml6
-rw-r--r--dev-dotnet/msbuildtasks/msbuildtasks-1.2.0.306.ebuild53
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-dotnet/msbuildtasks/ChangeLog b/dev-dotnet/msbuildtasks/ChangeLog
new file mode 100644
index 0000000..7dba519
--- /dev/null
+++ b/dev-dotnet/msbuildtasks/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-dotnet/msbuildtasks
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*msbuildtasks-1.2.0.306 (18 Apr 2011)
+
+ 18 Apr 2011; Alistair Bush <ali_bush@gentoo.org>
+ +msbuildtasks-1.2.0.306.ebuild, +files/msbuildtasks-1.2.0.306-build.patch,
+ +metadata.xml:
+ Add msbuildtasks.
+
diff --git a/dev-dotnet/msbuildtasks/Manifest b/dev-dotnet/msbuildtasks/Manifest
new file mode 100644
index 0000000..49fbe7e
--- /dev/null
+++ b/dev-dotnet/msbuildtasks/Manifest
@@ -0,0 +1,4 @@
+AUX msbuildtasks-1.2.0.306-build.patch 2471 RMD160 118cfb71bc196939ff2184a6b004551f4af6180c SHA1 b81ad33f027baf380389e4a8a41d0eecf5858419 SHA256 54320d4764239364dbdca30c546cf91cfddb276dc7da80b4217a533aa02fe7f0
+DIST MSBuild.Community.Tasks.v1.2.0.306.zip 2161848 RMD160 5b6bb21cfd1fe227bf7ec3ea7cb5c04d204ccecb SHA1 c460d019e1ddc1d1c0848549c87337cc0aa326e9 SHA256 07d60999d0de993fbecec2227c8b5348292900dcac2ca678e11a558d77c66349
+EBUILD msbuildtasks-1.2.0.306.ebuild 1181 RMD160 4c9747e0b8f0543f7450f010140d9d077152e41b SHA1 198dd12cdc054d400f66f681ac6647798bc59f38 SHA256 e1cad95a680518e4f896e25d05f96695546398ea8a670787cd98ffff556237dc
+MISC metadata.xml 160 RMD160 b3200df31a67b0fbf9111cdcf65bfa92f595fe3e SHA1 312d3afaed4ac266d3acb2062165cb84e505e514 SHA256 33e91e95e42924742e35f2a2026ba78de62da3f74e541a8b6a5fb14f485e5a69
diff --git a/dev-dotnet/msbuildtasks/files/msbuildtasks-1.2.0.306-build.patch b/dev-dotnet/msbuildtasks/files/msbuildtasks-1.2.0.306-build.patch
new file mode 100644
index 0000000..ae743d0
--- /dev/null
+++ b/dev-dotnet/msbuildtasks/files/msbuildtasks-1.2.0.306-build.patch
@@ -0,0 +1,56 @@
+--- MSBuildTasks.proj.bak 2011-04-10 13:48:38.000000000 +1200
++++ MSBuildTasks.proj 2011-04-15 05:59:09.000000000 +1200
+@@ -4,7 +4,7 @@
+
+ <PropertyGroup>
+ <project>MSBuildCommunityTasks</project>
+-
++ <TargetFrameworkVersion>v2.0</TargetFrameworkVersion>
+ <!-- ===================================================== -->
+ <!-- Versioning -->
+ <!-- ===================================================== -->
+@@ -50,7 +50,8 @@
+ <!-- NUnit report xsl transformation file -->
+ <nunitReportXsl>NUnitReport.xsl</nunitReportXsl>
+
+-
++ <debugExtension Condition=" '$(OS)' == 'Windows_NT' ">pdb</debugExtension>
++ <debugExtension Confition=" '$(OS)' != 'Windows_NT' ">dll.mdb</debugExtension>
+ <!-- ===================================================== -->
+ <!-- Importing -->
+ <!-- ===================================================== -->
+@@ -65,6 +66,7 @@
+ <devel Condition="'$(devel)'==''">false</devel>
+
+ <MSBuildCommunityTasksPath Condition="$(devel)">$(binDir)</MSBuildCommunityTasksPath>
++
+ <importTargets Condition="$(devel)">$(binDir)\MSBuild.Community.Tasks.Targets</importTargets>
+ <importTargets Condition="!$(devel)">$(MSBuildExtensionsPath)\MSBuildCommunityTasks\MSBuild.Community.Tasks.Targets</importTargets>
+ </PropertyGroup>
+@@ -72,7 +74,7 @@
+ <!-- ===================================================== -->
+ <!-- Importing -->
+ <!-- ===================================================== -->
+- <Import Condition="Exists($(importTargets))" Project="$(importTargets)"/>
++ <Import Condition="Exists('$(importTargets)')" Project="$(importTargets)"/>
+
+ <!-- ===================================================== -->
+ <!-- Item groups -->
+@@ -181,7 +183,7 @@
+ </Target>
+
+ <Target Name="assemblyinfo"
+- Condition="Exists($(importTargets))"
++ Condition="Exists('$(importTargets)')"
+ Inputs="@(vsprojects)"
+ Outputs="%(rootdir)%(directory)\Properties\AssemblyInfoCommon.cs">
+ <!-- For each VS project, create the AssemblyInfoCommon.cs file -->
+@@ -222,7 +224,7 @@
+ </MSBuild>
+
+ <Copy SourceFiles="@(targetOutputs)" DestinationFolder="$(binDir)" SkipUnchangedFiles="true" />
+- <Copy SourceFiles="@(targetOutputs -> '%(rootdir)%(directory)%(filename).pdb')"
++ <Copy SourceFiles="@(targetOutputs -> '%(rootdir)%(directory)%(filename).$(debugExtension)')"
+ DestinationFolder="$(binDir)"
+ Condition="'$(configuration)'=='Debug'"
+ SkipUnchangedFiles="true" />
diff --git a/dev-dotnet/msbuildtasks/metadata.xml b/dev-dotnet/msbuildtasks/metadata.xml
new file mode 100644
index 0000000..64e3ed1
--- /dev/null
+++ b/dev-dotnet/msbuildtasks/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dotnet</herd>
+</pkgmetadata>
+
diff --git a/dev-dotnet/msbuildtasks/msbuildtasks-1.2.0.306.ebuild b/dev-dotnet/msbuildtasks/msbuildtasks-1.2.0.306.ebuild
new file mode 100644
index 0000000..08eb942
--- /dev/null
+++ b/dev-dotnet/msbuildtasks/msbuildtasks-1.2.0.306.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit base mono
+
+MY_PN="MSBuild.Community.Tasks"
+
+DESCRIPTION="A collection of open source tasks for MSBuild."
+HOMEPAGE="http://msbuildtasks.tigris.org/"
+SRC_URI="http://${PN}.tigris.org/files/documents/3383/36642/${MY_PN}.v${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/mono"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+#/usr/lib/mono/xbuild
+
+PATCHES=( "${FILESDIR}/${P}-build.patch" )
+
+src_prepare() {
+ #rm -v Libraries/nunit.framework.dll || die
+ rm -R *uild
+ #Maybe one day
+ #ln -s "/usr/$(get_libdir)/mono/2.0/nunit.framework.dll" \
+ # Libraries/nunit.framework.dll || die
+
+ base_src_prepare
+}
+
+src_compile() {
+ xbuild /p:withILMerge=false /p:withIIS=false /p:withSqlServer=false \
+ /p:admin=false /p:nunitPath=/usr/lib64/mono/2.0/ \
+ /t:Build MSBuildTasks.proj
+}
+
+src_install() {
+ local ins_dir="/usr/$(get_libdir)/mono/xbuild/"
+ dodir "${ins_dir}"
+ insinto "${ins_dir}"
+ doins build/Debug/bin/MSBuild.Community.Tasks.dll
+ newins build/Debug/bin/MSBuild.Community.Tasks.Targets \
+ MSBuild.Community.Tasks.targets
+}
+
+