aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcyborgyn <cyborgyn@gmail.com>2021-05-30 00:41:57 +0200
committerGergely Nagy <ngg@ngg.hu>2021-06-04 16:17:01 +0200
commit7af7f63ca3ea99d3538bfbb05d17736cb1986887 (patch)
treec528764a0c14e186ca270a3b07ea3fa6959c822f
parentmono/linux-packaging-msbuild master branch was renamed to main (diff)
downloaddotnet-7af7f63ca3ea99d3538bfbb05d17736cb1986887.tar.gz
dotnet-7af7f63ca3ea99d3538bfbb05d17736cb1986887.tar.bz2
dotnet-7af7f63ca3ea99d3538bfbb05d17736cb1986887.zip
dev-dotnet/msbuild-roslyn-csc: Add patch to fix roslyn build
Closes: https://github.com/gentoo/dotnet/issues/501 Closes: https://github.com/gentoo/dotnet/pull/503 Signed-off-by: Gergely Nagy <ngg@ngg.hu>
-rw-r--r--dev-dotnet/msbuild-roslyn-csc/files/Initialize_Guid.patch11
-rw-r--r--dev-dotnet/msbuild-roslyn-csc/msbuild-roslyn-csc-15.3-r1.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-dotnet/msbuild-roslyn-csc/files/Initialize_Guid.patch b/dev-dotnet/msbuild-roslyn-csc/files/Initialize_Guid.patch
new file mode 100644
index 0000000..1cd81e1
--- /dev/null
+++ b/dev-dotnet/msbuild-roslyn-csc/files/Initialize_Guid.patch
@@ -0,0 +1,11 @@
+--- roslyn-ec1cde8b77c7bca654888681037f55aa0e62dd19/src/Compilers/Core/MSBuildTask/CopyRefAssembly.cs.old 2021-05-28 11:58:08.767635621 +0200
++++ roslyn-ec1cde8b77c7bca654888681037f55aa0e62dd19/src/Compilers/Core/MSBuildTask/CopyRefAssembly.cs 2021-05-28 11:59:03.840933543 +0200
+@@ -40,7 +40,7 @@
+
+ if (File.Exists(DestinationPath))
+ {
+- Guid source;
++ Guid source = Guid.Empty;
+ try
+ {
+ source = ExtractMvid(SourcePath);
diff --git a/dev-dotnet/msbuild-roslyn-csc/msbuild-roslyn-csc-15.3-r1.ebuild b/dev-dotnet/msbuild-roslyn-csc/msbuild-roslyn-csc-15.3-r1.ebuild
index 3a725be..f18818b 100644
--- a/dev-dotnet/msbuild-roslyn-csc/msbuild-roslyn-csc-15.3-r1.ebuild
+++ b/dev-dotnet/msbuild-roslyn-csc/msbuild-roslyn-csc-15.3-r1.ebuild
@@ -49,6 +49,7 @@ function output_filename ( ) {
src_prepare() {
cp "${FILESDIR}/mono-MSBuildTask.csproj" "${METAFILE_FO_BUILD}" || die
+ eapply "${FILESDIR}/Initialize_Guid.patch"
eapply_user
}