aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-19 17:40:11 +0000
committerSam James <sam@gentoo.org>2022-07-19 17:40:24 +0000
commitf31696cd457f82f81719a015c73958271977789c (patch)
tree5c0abcdc0cf9032f689ce44cc80ad4068b39a64a
parentremove some old ebuilds of year 2010 (diff)
downloaddotnet-f31696cd457f82f81719a015c73958271977789c.tar.gz
dotnet-f31696cd457f82f81719a015c73958271977789c.tar.bz2
dotnet-f31696cd457f82f81719a015c73958271977789c.zip
dev-lang/mono: treeclean (outdated live ebuild)
Use version from ::gentoo instead. Bug: https://bugs.gentoo.org/858938 Closes: https://github.com/gentoo/dotnet/issues/509 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-lang/mono/files/add_missing_vb_portable_targets.patch20
-rw-r--r--dev-lang/mono/files/autofac.patch24
-rw-r--r--dev-lang/mono/files/fix-for-GitExtensions-issue-2710-another-resolution.patch48
-rw-r--r--dev-lang/mono/files/fix-for-GitExtensions-issue-2710.patch28
-rw-r--r--dev-lang/mono/files/fix-for-bug36724.patch13
-rw-r--r--dev-lang/mono/files/mono-3.2.1-mdoc-fix.patch12
-rw-r--r--dev-lang/mono/files/mono-4.0.2.5-fix-decimal-ms-on-big-endian.patch22
-rw-r--r--dev-lang/mono/files/mono-4.0.2.5-fix-mono-dis-makefile-am-when-without-sgen.patch15
-rw-r--r--dev-lang/mono/files/mono-4.0.2.5-fix-ppc-atomic-add-i4.patch79
-rw-r--r--dev-lang/mono/files/mono-5.0.1.1-x86_32.patch21
-rw-r--r--dev-lang/mono/files/mono-5.10.0.179-ncurses61.patch106
-rw-r--r--dev-lang/mono/files/systemweb3.patch22
-rw-r--r--dev-lang/mono/files/try-catch.patch31
-rw-r--r--dev-lang/mono/metadata.xml22
-rw-r--r--dev-lang/mono/mono-9999.ebuild113
15 files changed, 0 insertions, 576 deletions
diff --git a/dev-lang/mono/files/add_missing_vb_portable_targets.patch b/dev-lang/mono/files/add_missing_vb_portable_targets.patch
deleted file mode 100644
index ece90a5..0000000
--- a/dev-lang/mono/files/add_missing_vb_portable_targets.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: mcs/tools/xbuild/targets/Microsoft.Portable.VisualBasic_4.0.targets
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ mcs/tools/xbuild/targets/Microsoft.Portable.VisualBasic_4.0.targets 2015-05-15 15:55:12.074775985 +0100
-@@ -0,0 +1,5 @@
-+<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
-+ <Import Project="..\Microsoft.Portable.Core.props" />
-+ <Import Project="$(MSBuildToolsPath)\Microsoft.VisualBasic.targets" />
-+ <Import Project="..\Microsoft.Portable.Core.targets" />
-+</Project>
-Index: mcs/tools/xbuild/targets/Microsoft.Portable.VisualBasic_4.5.targets
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ mcs/tools/xbuild/targets/Microsoft.Portable.VisualBasic_4.5.targets 2015-05-15 15:55:19.194775876 +0100
-@@ -0,0 +1,5 @@
-+<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
-+ <Import Project="..\Microsoft.Portable.Core.props" />
-+ <Import Project="$(MSBuildToolsPath)\Microsoft.VisualBasic.targets" />
-+ <Import Project="..\Microsoft.Portable.Core.targets" />
-+</Project>
diff --git a/dev-lang/mono/files/autofac.patch b/dev-lang/mono/files/autofac.patch
deleted file mode 100644
index 1983c1d..0000000
--- a/dev-lang/mono/files/autofac.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/mcs/class/System.Web/System.Web.Hosting/HostingEnvironment.cs
-+++ b/mcs/class/System.Web/System.Web.Hosting/HostingEnvironment.cs
-@@ -156,9 +156,18 @@
-
- HttpContext context = HttpContext.Current;
- HttpRequest req = context == null ? null : context.Request;
-- if (req == null)
-- return null;
--
-+ if (req == null) // ADDED for Orchard
-+ {
-+ var pp = HostingEnvironment.ApplicationPhysicalPath;
-+ String vp=virtualPath;
-+ if (vp.IndexOf("~/") == 0)
-+ {
-+ vp = pp + virtualPath.Substring(2);
-+ }
-+ // TODO: if not "~/" ???? then what?
-+ return vp;
-+ } // END added for Orchard
-+ else
- return req.MapPath (virtualPath);
- }
-
diff --git a/dev-lang/mono/files/fix-for-GitExtensions-issue-2710-another-resolution.patch b/dev-lang/mono/files/fix-for-GitExtensions-issue-2710-another-resolution.patch
deleted file mode 100644
index b306b69..0000000
--- a/dev-lang/mono/files/fix-for-GitExtensions-issue-2710-another-resolution.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/mcs/class/System/System.Configuration/CustomizableFileSettingsProvider.cs b/mcs/class/System/System.Configuration/CustomizableFileSettingsProvider.cs
-index 4b69010..1bb6195 100644
---- a/mcs/class/System/System.Configuration/CustomizableFileSettingsProvider.cs
-+++ b/mcs/class/System/System.Configuration/CustomizableFileSettingsProvider.cs
-@@ -578,6 +578,34 @@ namespace System.Configuration
- private ExeConfigurationFileMap exeMapPrev = null;
- private SettingsPropertyValueCollection values = null;
-
-+ /// <remarks>
-+ /// Hack to remove the XmlDeclaration that the XmlSerializer adds.
-+ /// <br />
-+ /// see <a href="https://github.com/mono/mono/pull/2273">Issue 2273</a> for details
-+ /// </remarks>
-+ private string StripXmlHeader(string serializedValue)
-+ {
-+ if (serializedValue == null)
-+ {
-+ return string.Empty;
-+ }
-+
-+ XmlDocument doc = new XmlDocument();
-+ XmlElement valueXml = doc.CreateElement("value");
-+ valueXml.InnerXml = serializedValue;
-+
-+ foreach (XmlNode child in valueXml.ChildNodes) {
-+ if (child.NodeType == XmlNodeType.XmlDeclaration) {
-+ valueXml.RemoveChild(child);
-+ break;
-+ }
-+ }
-+
-+ // InnerXml will give you well-formed XML that you could save as a separate document, and
-+ // InnerText will immediately give you a pure-text representation of this inner XML.
-+ return valueXml.InnerXml;
-+ }
-+
- private void SaveProperties (ExeConfigurationFileMap exeMap, SettingsPropertyValueCollection collection, ConfigurationUserLevel level, SettingsContext context, bool checkUserLevel)
- {
- Configuration config = ConfigurationManager.OpenMappedExeConfiguration (exeMap, level);
-@@ -623,7 +651,7 @@ namespace System.Configuration
- element.Value.ValueXml = new XmlDocument ().CreateElement ("value");
- switch (value.Property.SerializeAs) {
- case SettingsSerializeAs.Xml:
-- element.Value.ValueXml.InnerXml = (value.SerializedValue as string) ?? string.Empty;
-+ element.Value.ValueXml.InnerXml = StripXmlHeader(value.SerializedValue as string);
- break;
- case SettingsSerializeAs.String:
- element.Value.ValueXml.InnerText = value.SerializedValue as string;
diff --git a/dev-lang/mono/files/fix-for-GitExtensions-issue-2710.patch b/dev-lang/mono/files/fix-for-GitExtensions-issue-2710.patch
deleted file mode 100644
index 3d60923..0000000
--- a/dev-lang/mono/files/fix-for-GitExtensions-issue-2710.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/mcs/class/System/System.Configuration/SettingsPropertyValue.cs b/mcs/class/System/System.Configuration/SettingsPropertyValue.cs
-index 9bf62c0..9f026461 100644
---- a/mcs/class/System/System.Configuration/SettingsPropertyValue.cs
-+++ b/mcs/class/System/System.Configuration/SettingsPropertyValue.cs
-@@ -118,11 +118,18 @@ namespace System.Configuration
- #if (XML_DEP)
- case SettingsSerializeAs.Xml:
- if (propertyValue != null) {
-- XmlSerializer serializer = new XmlSerializer (propertyValue.GetType ());
-- StringWriter w = new StringWriter(CultureInfo.InvariantCulture);
--
-- serializer.Serialize (w, propertyValue);
-- serializedValue = w.ToString();
-+ using (StringWriter w = new StringWriter(CultureInfo.InvariantCulture))
-+ {
-+ var xmlSettings = new XmlWriterSettings();
-+ xmlSettings.OmitXmlDeclaration = true;
-+ using (var writer = XmlWriter.Create(w, xmlSettings))
-+ {
-+ XmlSerializer serializer = new XmlSerializer(propertyValue.GetType ());
-+ var emptyNamespaces = new XmlSerializerNamespaces(new[] { XmlQualifiedName.Empty });
-+ serializer.Serialize(writer, propertyValue, emptyNamespaces);
-+ } // writer.Flush happens here
-+ serializedValue = w.ToString();
-+ }
- }
- else
- serializedValue = null;
diff --git a/dev-lang/mono/files/fix-for-bug36724.patch b/dev-lang/mono/files/fix-for-bug36724.patch
deleted file mode 100644
index 187b4ba..0000000
--- a/dev-lang/mono/files/fix-for-bug36724.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/mcs/class/System.Web/System.Web.Util/UrlUtils.cs b/mcs/class/System.Web/System.Web.Util/UrlUtils.cs
-index 4f07e83..e229a91 100644
---- a/mcs/class/System.Web/System.Web.Util/UrlUtils.cs
-+++ b/mcs/class/System.Web/System.Web.Util/UrlUtils.cs
-@@ -54,7 +54,7 @@ namespace System.Web.Util {
- if (path.StartsWith (appvpath))
- path = path.Substring (appvpath.Length);
-
-- if (path [0] == '/')
-+ if (path.StartsWith("/"))
- path = path.Length > 1 ? path.Substring (1) : "";
-
- return Canonic (appvpath + "(" + id + ")/" + path);
diff --git a/dev-lang/mono/files/mono-3.2.1-mdoc-fix.patch b/dev-lang/mono/files/mono-3.2.1-mdoc-fix.patch
deleted file mode 100644
index b8fcea9..0000000
--- a/dev-lang/mono/files/mono-3.2.1-mdoc-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur mono-3.2.1.orig/mcs/tools/mdoc/Resources/monodoc-ecma.xsd mono-3.2.1/mcs/tools/mdoc/Resources/monodoc-ecma.xsd
---- mono-3.2.1.orig/mcs/tools/mdoc/Resources/monodoc-ecma.xsd 2013-08-26 09:33:59.410610438 +0200
-+++ mono-3.2.1/mcs/tools/mdoc/Resources/monodoc-ecma.xsd 2013-08-26 09:34:54.057804438 +0200
-@@ -351,7 +351,7 @@
- <xs:element name="format">
- <xs:complexType>
- <xs:sequence>
-- <xs:any minOccurs="0" processContents="lax" />
-+ <xs:any minOccurs="0" maxOccurs="unbounded" processContents="lax" />
- </xs:sequence>
- <xs:attribute ref="type" />
- </xs:complexType>
diff --git a/dev-lang/mono/files/mono-4.0.2.5-fix-decimal-ms-on-big-endian.patch b/dev-lang/mono/files/mono-4.0.2.5-fix-decimal-ms-on-big-endian.patch
deleted file mode 100644
index c6349fe..0000000
--- a/dev-lang/mono/files/mono-4.0.2.5-fix-decimal-ms-on-big-endian.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -up mono/metadata/decimal-ms.c.than
-mono/metadata/decimal-ms.c
---- mono/metadata/decimal-ms.c.than 2015-07-06 08:21:27.524461795
--0400
-+++ mono/metadata/decimal-ms.c 2015-07-06 08:30:26.954461795
--0400
-@@ -55,8 +55,13 @@ static const uint32_t ten_to_ten_div_4 =
- #define DECIMAL_LO32(dec) ((dec).v.v.Lo32)
- #define DECIMAL_MID32(dec) ((dec).v.v.Mid32)
- #define DECIMAL_HI32(dec) ((dec).Hi32)
--#define DECIMAL_LO64_GET(dec) ((dec).v.Lo64)
--#define DECIMAL_LO64_SET(dec,value) {(dec).v.Lo64 = value; }
-+#if G_BYTE_ORDER != G_LITTLE_ENDIAN
-+# define DECIMAL_LO64_GET(dec) (((uint64_t)((dec).v.v.Mid32) << 32) | (dec).v.v.Lo32)
-+# define DECIMAL_LO64_SET(dec,value) {(dec).v.v.Lo32 = (value); (dec).v.v.Mid32 = ((value) >> 32); }
-+#else
-+# define DECIMAL_LO64_GET(dec) ((dec).v.Lo64)
-+# define DECIMAL_LO64_SET(dec,value) {(dec).v.Lo64 = value; }
-+#endif
-
- #define DECIMAL_SETZERO(dec) {DECIMAL_LO32(dec) = 0; DECIMAL_MID32(dec) = 0; DECIMAL_HI32(dec) = 0; DECIMAL_SIGNSCALE(dec) = 0;}
- #define COPYDEC(dest, src) {DECIMAL_SIGNSCALE(dest) = DECIMAL_SIGNSCALE(src); DECIMAL_HI32(dest) = DECIMAL_HI32(src); \
diff --git a/dev-lang/mono/files/mono-4.0.2.5-fix-mono-dis-makefile-am-when-without-sgen.patch b/dev-lang/mono/files/mono-4.0.2.5-fix-mono-dis-makefile-am-when-without-sgen.patch
deleted file mode 100644
index bbf4c6f..0000000
--- a/dev-lang/mono/files/mono-4.0.2.5-fix-mono-dis-makefile-am-when-without-sgen.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-===================================================================
-RCS file: mono/dis/RCS/Makefile.am,v
-retrieving revision 1.1
-diff -up -r1.1 mono/dis/Makefile.am
---- mono/dis/Makefile.am 2015/05/08 15:00:22 1.1
-+++ mono/dis/Makefile.am 2015/07/14 11:20:29
-@@ -7,7 +7,7 @@ endif
- if SUPPORT_SGEN
- metadata_lib=$(top_builddir)/mono/metadata/libmonoruntimesgen-static.la
- else
--metadata_lib=$(top_builddir)/mono/metadata/libmonoruntime-static.a
-+metadata_lib=$(top_builddir)/mono/metadata/libmonoruntime-static.la
- gc_lib=$(LIBGC_STATIC_LIBS)
- endif
-
diff --git a/dev-lang/mono/files/mono-4.0.2.5-fix-ppc-atomic-add-i4.patch b/dev-lang/mono/files/mono-4.0.2.5-fix-ppc-atomic-add-i4.patch
deleted file mode 100644
index fd5de72..0000000
--- a/dev-lang/mono/files/mono-4.0.2.5-fix-ppc-atomic-add-i4.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From f967c79926900343f399c75624deedaba460e544 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Alex=20R=C3=B8nne=20Petersen?= <alexrp@xamarin.com>
-Date: Mon, 3 Aug 2015 17:32:07 +0200
-Subject: [PATCH 1/2] [ppc] Instruction length of atomic_add_i4 is 28.
-
----
- mono/mini/cpu-ppc.md | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mono/mini/cpu-ppc.md b/mono/mini/cpu-ppc.md
-index ba2ec60..e6baf91 100644
---- a/mono/mini/cpu-ppc.md
-+++ b/mono/mini/cpu-ppc.md
-@@ -314,5 +314,5 @@ vcall2_membase: src1:b len:16 clob:c
-
- jump_table: dest:i len:8
-
--atomic_add_i4: src1:b src2:i dest:i len:20
-+atomic_add_i4: src1:b src2:i dest:i len:28
- atomic_cas_i4: src1:b src2:i src3:i dest:i len:38
-
-From 8f379f0c8f98493180b508b9e68b9aa76c0c5bdf Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Alex=20R=C3=B8nne=20Petersen?= <alexrp@xamarin.com>
-Date: Mon, 3 Aug 2015 17:32:31 +0200
-Subject: [PATCH 2/2] [ppc] Fix atomic_add_i4 support for 32-bit PPC.
-
----
- mono/mini/mini-ppc.c | 31 ++++++++++++++++---------------
- 1 file changed, 16 insertions(+), 15 deletions(-)
-
-diff --git a/mono/mini/mini-ppc.c b/mono/mini/mini-ppc.c
-index 758a63f..06528bd 100644
---- a/mono/mini/mini-ppc.c
-+++ b/mono/mini/mini-ppc.c
-@@ -4420,6 +4420,22 @@ mono_arch_output_basic_block (MonoCompile *cfg, MonoBasicBlock *bb)
- else
- ppc_mr (code, ins->dreg, ins->sreg1);
- break;
-+#else
-+ case OP_ICONV_TO_R4:
-+ case OP_ICONV_TO_R8: {
-+ if (cpu_hw_caps & PPC_ISA_64) {
-+ ppc_srawi(code, ppc_r0, ins->sreg1, 31);
-+ ppc_stw (code, ppc_r0, -8, ppc_r1);
-+ ppc_stw (code, ins->sreg1, -4, ppc_r1);
-+ ppc_lfd (code, ins->dreg, -8, ppc_r1);
-+ ppc_fcfid (code, ins->dreg, ins->dreg);
-+ if (ins->opcode == OP_ICONV_TO_R4)
-+ ppc_frsp (code, ins->dreg, ins->dreg);
-+ }
-+ break;
-+ }
-+#endif
-+
- case OP_ATOMIC_ADD_I4:
- CASE_PPC64 (OP_ATOMIC_ADD_I8) {
- int location = ins->inst_basereg;
-@@ -4453,21 +4469,6 @@ mono_arch_output_basic_block (MonoCompile *cfg, MonoBasicBlock *bb)
- ppc_mr (code, ins->dreg, ppc_r0);
- break;
- }
--#else
-- case OP_ICONV_TO_R4:
-- case OP_ICONV_TO_R8: {
-- if (cpu_hw_caps & PPC_ISA_64) {
-- ppc_srawi(code, ppc_r0, ins->sreg1, 31);
-- ppc_stw (code, ppc_r0, -8, ppc_r1);
-- ppc_stw (code, ins->sreg1, -4, ppc_r1);
-- ppc_lfd (code, ins->dreg, -8, ppc_r1);
-- ppc_fcfid (code, ins->dreg, ins->dreg);
-- if (ins->opcode == OP_ICONV_TO_R4)
-- ppc_frsp (code, ins->dreg, ins->dreg);
-- }
-- break;
-- }
--#endif
- case OP_ATOMIC_CAS_I4:
- CASE_PPC64 (OP_ATOMIC_CAS_I8) {
- int location = ins->sreg1;
diff --git a/dev-lang/mono/files/mono-5.0.1.1-x86_32.patch b/dev-lang/mono/files/mono-5.0.1.1-x86_32.patch
deleted file mode 100644
index 08d443a..0000000
--- a/dev-lang/mono/files/mono-5.0.1.1-x86_32.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Native toolchain can default to different ABI (amd64 in bug case).
-Set target to i386.
-https://bugs.gentoo.org/600664
-diff --git a/mono/mini/aot-compiler.c b/mono/mini/aot-compiler.c
-index 0656a57..690c96b 100644
---- a/mono/mini/aot-compiler.c
-+++ b/mono/mini/aot-compiler.c
-@@ -9926,4 +9926,6 @@ compile_asm (MonoAotCompile *acfg)
- #ifdef TARGET_WIN32_MSVC
- #define AS_OPTIONS "-c -x assembler"
-+#elif defined(TARGET_X86) && !defined(TARGET_MACH)
-+#define AS_OPTIONS "--32"
- #elif defined(TARGET_AMD64) && !defined(TARGET_MACH)
- #define AS_OPTIONS "--64"
-@@ -9981,4 +9983,6 @@ compile_asm (MonoAotCompile *acfg)
- #elif defined(TARGET_POWERPC64)
- #define LD_OPTIONS "-m elf64ppc"
-+#elif defined(TARGET_X86)
-+#define LD_OPTIONS "-m elf_i386"
- #endif
-
diff --git a/dev-lang/mono/files/mono-5.10.0.179-ncurses61.patch b/dev-lang/mono/files/mono-5.10.0.179-ncurses61.patch
deleted file mode 100644
index 93a1f8f..0000000
--- a/dev-lang/mono/files/mono-5.10.0.179-ncurses61.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-diff -Naur mono-5.10.0.179.orig/mcs/class/corlib/System/TermInfoReader.cs mono-5.10.0.179/mcs/class/corlib/System/TermInfoReader.cs
---- mono-5.10.0.179.orig/mcs/class/corlib/System/TermInfoReader.cs 2018-03-19 07:46:31.000000000 +0000
-+++ mono-5.10.0.179/mcs/class/corlib/System/TermInfoReader.cs 2018-03-25 20:57:57.721279733 +0100
-@@ -72,16 +72,16 @@
- //
-
- class TermInfoReader {
-- //short nameSize;
-- short boolSize;
-- short numSize;
-- short strOffsets;
-- //short strSize;
-+ int boolSize;
-+ int numSize;
-+ int strOffsets;
-
- //string [] names; // Last one is the description
- byte [] buffer;
- int booleansOffset;
- //string term;
-+
-+ int intOffset;
-
- public TermInfoReader (string term, string filename)
- {
-@@ -114,12 +114,21 @@
- // get { return term; }
- // }
-
-+ void DetermineVersion (short magic)
-+ {
-+ if (magic == 0x11a)
-+ intOffset = 2;
-+ else if (magic == 0x21e)
-+ intOffset = 4;
-+ else
-+ throw new Exception (String.Format ("Magic number is unexpected: {0}", magic));
-+ }
-+
- void ReadHeader (byte [] buffer, ref int position)
- {
- short magic = GetInt16 (buffer, position);
- position += 2;
-- if (magic != 282)
-- throw new Exception (String.Format ("Magic number is wrong: {0}", magic));
-+ DetermineVersion (magic);
-
- /*nameSize =*/ GetInt16 (buffer, position);
- position += 2;
-@@ -161,8 +170,8 @@
- if ((offset % 2) == 1)
- offset++;
-
-- offset += ((int) number) * 2;
-- return GetInt16 (buffer, offset);
-+ offset += ((int) number) * intOffset;
-+ return GetInteger (buffer, offset);
- }
-
- public string Get (TermInfoStrings tstr)
-@@ -175,7 +184,7 @@
- if ((offset % 2) == 1)
- offset++;
-
-- offset += numSize * 2;
-+ offset += numSize * intOffset;
- int off2 = GetInt16 (buffer, offset + (int) tstr * 2);
- if (off2 == -1)
- return null;
-@@ -193,7 +202,7 @@
- if ((offset % 2) == 1)
- offset++;
-
-- offset += numSize * 2;
-+ offset += numSize * intOffset;
- int off2 = GetInt16 (buffer, offset + (int) tstr * 2);
- if (off2 == -1)
- return null;
-@@ -211,6 +220,27 @@
- return (short) (uno + dos * 256);
- }
-
-+ int GetInt32 (byte [] buffer, int offset)
-+ {
-+ int b1 = (int) buffer [offset];
-+ int b2 = (int) buffer [offset + 1];
-+ int b3 = (int) buffer [offset + 2];
-+ int b4 = (int) buffer [offset + 3];
-+ if (b1 == 255 && b2 == 255 && b3 == 255 && b4 == 255)
-+ return -1;
-+
-+ return b1 + b2 << 8 + b3 << 16 + b4 << 24;
-+ }
-+
-+ int GetInteger (byte [] buffer, int offset)
-+ {
-+ if (intOffset == 2)
-+ return GetInt16 (buffer, offset);
-+ else
-+ // intOffset == 4
-+ return GetInt32 (buffer, offset);
-+ }
-+
- string GetString (byte [] buffer, int offset)
- {
- int length = 0;
diff --git a/dev-lang/mono/files/systemweb3.patch b/dev-lang/mono/files/systemweb3.patch
deleted file mode 100644
index 5ccb63a..0000000
--- a/dev-lang/mono/files/systemweb3.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/mcs/class/System.Web.Routing/System.Web.Routing/RouteBase.cs 2015-05-08 18:00:15.000000000 +0300
-+++ b/mcs/class/System.Web.Routing/System.Web.Routing/RouteBase.cs 2015-07-20 14:13:09.215784924 +0300
-@@ -41,5 +41,19 @@
- {
- public abstract RouteData GetRouteData (HttpContextBase httpContext);
- public abstract VirtualPathData GetVirtualPath (RequestContext requestContext, RouteValueDictionary values);
-+
-+ // Default needs to be true to avoid breaking change
-+ private bool _routeExistingFiles = true;
-+ public bool RouteExistingFiles
-+ {
-+ get
-+ {
-+ return _routeExistingFiles;
-+ }
-+ set
-+ {
-+ _routeExistingFiles = value;
-+ }
-+ }
- }
- }
diff --git a/dev-lang/mono/files/try-catch.patch b/dev-lang/mono/files/try-catch.patch
deleted file mode 100644
index 051c72b..0000000
--- a/dev-lang/mono/files/try-catch.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -ur mono-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs mono-patched-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs
---- mono-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2017-11-17 18:12:57.000000000 +0300
-+++ mono-patched-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2017-12-06 06:24:45.067519852 +0300
-@@ -2810,14 +2810,21 @@
-
- internal override object ClipboardRetrieve(IntPtr handle, int type, XplatUI.ClipboardToObject converter)
- {
-- XConvertSelection(DisplayHandle, handle, (IntPtr)type, (IntPtr)type, FosterParent, IntPtr.Zero);
-+ try
-+ {
-+ XConvertSelection(DisplayHandle, handle, (IntPtr)type, (IntPtr)type, FosterParent, IntPtr.Zero);
-
-- Clipboard.Retrieving = true;
-- while (Clipboard.Retrieving) {
-- UpdateMessageQueue(null, false);
-- }
-+ Clipboard.Retrieving = true;
-+ while (Clipboard.Retrieving) {
-+ UpdateMessageQueue(null, false);
-+ }
-
-- return Clipboard.Item;
-+ return Clipboard.Item;
-+ }
-+ catch (Exception ex)
-+ {
-+ return null;
-+ }
- }
-
- internal override void ClipboardStore (IntPtr handle, object obj, int type, XplatUI.ObjectToClipboard converter, bool copy)
diff --git a/dev-lang/mono/metadata.xml b/dev-lang/mono/metadata.xml
deleted file mode 100644
index 375e4b8..0000000
--- a/dev-lang/mono/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>dotnet@gentoo.org</email>
- <description>Gentoo Dotnet Project</description>
- </maintainer>
- <upstream>
- <bugs-to>https://github.com/mono/mono/issues</bugs-to>
- <remote-id type="github">mono/mono</remote-id>
- </upstream>
- <use>
- <flag name='pax_kernel'>Enable if the user plans to run the package under a pax enabled hardened kernel</flag>
- <flag name='xen'>Make mono generate code that is considerably faster on xen VMs but slightly slower on for normal systems.</flag>
- </use>
- <longdescription lang="en">
- Xamarin's opensource implementation of Common Language Runtime (ECMA-335, ISO/IEC 23271)
- </longdescription>
- <longdescription lang="ru">
- Общеязыковая исполняющая среда (ECMA-335, ISO/IEC 23271), от компании Xamarin
- </longdescription>
-</pkgmetadata>
diff --git a/dev-lang/mono/mono-9999.ebuild b/dev-lang/mono/mono-9999.ebuild
deleted file mode 100644
index 88b61f6..0000000
--- a/dev-lang/mono/mono-9999.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
-
-inherit linux-info mono-env flag-o-matic pax-utils autotools git-r3
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="https://www.mono-project.com/Main_Page"
-
-EGIT_REPO_URI="https://github.com/mono/${PN}.git"
-
-LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
-SLOT="0"
-KEYWORDS=""
-IUSE="minimal pax_kernel xen doc"
-
-COMMONDEPEND="
- !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
- ia64? ( sys-libs/libunwind )
-"
-RDEPEND="${COMMONDEPEND}
- || ( www-client/links www-client/lynx )
-"
-DEPEND="${COMMONDEPEND}
- sys-devel/bc
- virtual/yacc
- pax_kernel? ( sys-apps/elfix )
-"
-
-pkg_pretend() {
- # If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling.
- # See https://bugs.gentoo.org/261869 for more info."
- CONFIG_CHECK="SYSVIPC"
- use kernel_linux && check_extra_config
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- mono-env_pkg_setup
-}
-
-src_prepare() {
- cat "${S}/mono/mini/Makefile.am.in" > "${S}/mono/mini/Makefile.am" || die
-
- eautoreconf
- # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
- # get killed in the build proces when MPROTECT is enable. #286280
- # RANDMMAP kill the build proces to #347365
- # use paxmark.sh to get PT/XT logic #532244
- if use pax_kernel ; then
- ewarn "We are disabling MPROTECT on the mono binary."
- sed '/exec/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in
- fi
-
- # mono build system can fail otherwise
- strip-flags
-
- # Remove this at your own peril. Mono will barf in unexpected ways.
- append-flags -fno-strict-aliasing
- eautoconf
- eautomake
-}
-
-src_configure() {
- # NOTE: We need the static libs for now so mono-debugger works.
- # See https://bugs.gentoo.org/show_bug.cgi?id=256264 for details
- #
- # --without-moonlight since www-plugins/moonlight is not the only one
- # using mono: https://bugzilla.novell.com/show_bug.cgi?id=641005#c3
- #
- # --with-profile4 needs to be always enabled since it's used by default
- # and, otherwise, problems like bug #340641 appear.
- #
- # sgen fails on ppc, bug #359515
- local myeconfargs=(
- --enable-system-aot=yes
- --enable-static
- --disable-quiet-build
- --without-moonlight
- --with-libgdiplus=$(use minimal && printf "no" || printf "installed" )
- $(use_with xen xen_opt)
- --without-ikvm-native
- --with-jit
- --disable-dtrace
- --with-profile4
- --with-sgen=$(use ppc && printf "no" || printf "yes" )
- $(use_with doc mcs-docs)
- )
-
- econf ${myeconfargs}
-}
-
-src_make() {
- # Doesn't require previous mono to be installed
- emake get-monolite-latest
- emake EXTERNAL_MCS=${PWD}/mcs/class/lib/monolite/gmcs.exe "$@"
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
- # mono.spec and https://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
- # for reference.
- rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
- rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
-}