aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-20 01:52:33 +0000
committerSam James <sam@gentoo.org>2022-07-20 01:52:33 +0000
commit0a21732894eada9662d6b71b7db8675dbad7b11b (patch)
tree8107ddc8259fe296d08a22ec4f296e2753717a7b /dev-util
parentprofiles: mask smuxi[libnotify] (diff)
downloaddotnet-0a21732894eada9662d6b71b7db8675dbad7b11b.tar.gz
dotnet-0a21732894eada9662d6b71b7db8675dbad7b11b.tar.bz2
dotnet-0a21732894eada9662d6b71b7db8675dbad7b11b.zip
*/*: drop broken live ebuilds
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mono-debugger/mono-debugger-9999.ebuild45
-rw-r--r--dev-util/mono-tools/mono-tools-9999.ebuild43
2 files changed, 0 insertions, 88 deletions
diff --git a/dev-util/mono-debugger/mono-debugger-9999.ebuild b/dev-util/mono-debugger/mono-debugger-9999.ebuild
deleted file mode 100644
index 6a242b3..0000000
--- a/dev-util/mono-debugger/mono-debugger-9999.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit dotnet autotools flag-o-matic git-r3
-
-DESCRIPTION="Debugger for .NET managed and unmanaged applications"
-HOMEPAGE="https://www.mono-project.com/"
-
-EGIT_REPO_URI="git://github.com/mono/debugger.git"
-
-LICENSE="GPL-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RESTRICT="test"
-
-# Binutils is needed for libbfd
-RDEPEND="!!=dev-lang/mono-2.2
- sys-devel/binutils:*
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- !dev-lang/mercury"
-
-src_prepare() {
- default
-
- # Allow compilation against system libbfd, bnc#662581
- eapply "${FILESDIR}/${PN}-2.8-system-bfd.patch"
- eautoreconf
-}
-
-src_configure() {
- append-ldflags -Wl,--no-undefined #nowarn
- econf --disable-dependency-tracking \
- --disable-static \
- --with-system-libbfd \
- --disable-static
-}
-
-src_compile() {
- emake -j1 #nowarn
-}
diff --git a/dev-util/mono-tools/mono-tools-9999.ebuild b/dev-util/mono-tools/mono-tools-9999.ebuild
deleted file mode 100644
index 17dc3e6..0000000
--- a/dev-util/mono-tools/mono-tools-9999.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit dotnet autotools git-r3
-
-DESCRIPTION="Set of useful Mono related utilities"
-HOMEPAGE="https://www.mono-project.com/"
-
-EGIT_REPO_URI="git://github.com/mono/${PN}.git"
-
-LICENSE="GPL-2 MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND=">=dev-dotnet/gtk-sharp-2.99
- dev-dotnet/webkit-sharp"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
-PATCHES=(
- "${FILESDIR}/${PN}-2.8-html-renderer-fixes.patch"
-)
-MAKEOPTS="${MAKEOPTS} -j1" #nowarn
-
-src_prepare() {
- default
-
- # Stop getting ACLOCAL_FLAGS command not found problem like bug #298813
- sed -i -e '/ACLOCAL_FLAGS/d' Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- econf --disable-dependency-tracking \
- --disable-gecko \
- --enable-webkit \
- --disable-gtkhtml \
- --disable-monowebbrowser || die
-}