aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Langenmaier <stefan.langenmaier@gmail.com>2016-05-05 21:43:48 -0400
committerStefan Langenmaier <stefan.langenmaier@gmail.com>2016-05-05 21:43:48 -0400
commit436204242684e14b557c43280ba0e8e254454232 (patch)
tree85f2ccb9cf0b28a1179df58ffc0d004d8c011adf /dev-java/lombok-bin/lombok-bin-1.16.8.ebuild
parentadded a binary lombok ebuild (diff)
downloadeclipse-436204242684e14b557c43280ba0e8e254454232.tar.gz
eclipse-436204242684e14b557c43280ba0e8e254454232.tar.bz2
eclipse-436204242684e14b557c43280ba0e8e254454232.zip
included review comments for lombok support
Diffstat (limited to 'dev-java/lombok-bin/lombok-bin-1.16.8.ebuild')
-rw-r--r--dev-java/lombok-bin/lombok-bin-1.16.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-java/lombok-bin/lombok-bin-1.16.8.ebuild b/dev-java/lombok-bin/lombok-bin-1.16.8.ebuild
new file mode 100644
index 0000000..ef9cbb7
--- /dev/null
+++ b/dev-java/lombok-bin/lombok-bin-1.16.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=6
+
+inherit eutils
+
+MY_PN="lombok"
+
+DESCRIPTION="Project Lombok makes java a spicier language by adding 'handlers' that know how to build and compile simple, boilerplate-free, not-quite-java code."
+HOMEPAGE="https://projectlombok.org/"
+SRC_URI="https://projectlombok.org/downloads/${MY_PN}-${PV}.jar"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND=">=virtual/jdk-1.7
+ ${DEPEND}"
+
+src_unpack() {
+ # so prepare is happy about the empty dir
+ mkdir ${P}
+}
+
+src_install() {
+ mkdir -p "${D}/usr/share/lombok"
+ cp "${DISTDIR}/${MY_PN}-${PV}.jar" "${D}/usr/share/lombok/lombok.jar"
+}