summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-02-09 13:14:03 +0100
committerUlrich Müller <ulm@gentoo.org>2015-02-09 13:14:03 +0100
commitd43fe141168cd70cd7c58468e419eb619e73f80d (patch)
tree68c708c44b6aceffebb247b26eb06d8c0b760ff4 /app-emacs
parentapp-xemacs/cc-mode: Pre release version bump. (diff)
downloademacs-d43fe141168cd70cd7c58468e419eb619e73f80d.tar.gz
emacs-d43fe141168cd70cd7c58468e419eb619e73f80d.tar.bz2
emacs-d43fe141168cd70cd7c58468e419eb619e73f80d.zip
app-emacs/emacs-common-gentoo: Use group 'scores' instead of 'games' for shared score files.
Package-Manager: portage-2.2.16
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emacs-common-gentoo/ChangeLog4
-rw-r--r--app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild6
2 files changed, 7 insertions, 3 deletions
diff --git a/app-emacs/emacs-common-gentoo/ChangeLog b/app-emacs/emacs-common-gentoo/ChangeLog
index 01bddd6..e44bb76 100644
--- a/app-emacs/emacs-common-gentoo/ChangeLog
+++ b/app-emacs/emacs-common-gentoo/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 09 Feb 2015; Ulrich Müller <ulm@gentoo.org>
+ emacs-common-gentoo-9999-r1.ebuild:
+ Use group 'scores' instead of 'games' for shared score files.
+
23 Jan 2015; Ulrich Müller <ulm@gentoo.org>
emacs-common-gentoo-9999-r1.ebuild:
Respect GAMES_GROUP variable.
diff --git a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild
index 0710b8c..04dc5ad 100644
--- a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild
+++ b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild
@@ -22,7 +22,7 @@ PDEPEND="virtual/emacs"
S="${WORKDIR}/${PN}"
pkg_setup() {
- use games && enewgroup "${GAMES_GROUP:-games}" 35
+ use games && enewgroup scores 36
}
src_install() {
@@ -36,7 +36,7 @@ src_install() {
if use games; then
keepdir /var/games/emacs
- fowners "root:${GAMES_GROUP:-games}" /var/games/emacs
+ fowners root:scores /var/games/emacs
fperms g+w /var/games/emacs
fi
@@ -107,7 +107,7 @@ pkg_preinst() {
cp "${EROOT}/var/lib${f#/var}" "${ED}${f}" || die
fi
touch "${ED}${f}" || die
- chown "root:${GAMES_GROUP:-games}" "${ED}${f}" || die
+ chown root:scores "${ED}${f}" || die
chmod g+w "${ED}${f}" || die
done
fi