aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-05-11 12:03:53 -0400
committerMike Gilbert <floppym@gentoo.org>2016-05-11 12:03:53 -0400
commitae26ba7756ce0b59712802d65f398d1c113bd49f (patch)
tree9b3606ea9e21390dbd9477266c0011225769d003
parentskel.ebuild: Add a minimal ebuild as a template (diff)
downloadgen-b0rk-ae26ba7756ce0b59712802d65f398d1c113bd49f.tar.gz
gen-b0rk-ae26ba7756ce0b59712802d65f398d1c113bd49f.tar.bz2
gen-b0rk-ae26ba7756ce0b59712802d65f398d1c113bd49f.zip
ebuild-test/variable-usedwithhelpers: new test
-rw-r--r--ebuild-test/variable-usedwithhelpers/metadata.xml26
-rw-r--r--ebuild-test/variable-usedwithhelpers/variable-usedwithhelpers-0.ebuild18
2 files changed, 44 insertions, 0 deletions
diff --git a/ebuild-test/variable-usedwithhelpers/metadata.xml b/ebuild-test/variable-usedwithhelpers/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/variable-usedwithhelpers/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>
diff --git a/ebuild-test/variable-usedwithhelpers/variable-usedwithhelpers-0.ebuild b/ebuild-test/variable-usedwithhelpers/variable-usedwithhelpers-0.ebuild
new file mode 100644
index 0000000..ea0bfa7
--- /dev/null
+++ b/ebuild-test/variable-usedwithhelpers/variable-usedwithhelpers-0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Pass D/ROOT/EPREFIX to helpers"
+HOMEPAGE="http://example.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_install() {
+ into "${D}/usr"
+ insinto "${ED}/usr/lib"
+ docinto "${EROOT}/usr/share/doc"
+}