aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Słomiński <kacper.slominski72@gmail.com>2024-08-18 23:35:26 +0200
committerKacper Słomiński <kacper.slominski72@gmail.com>2024-08-18 23:36:26 +0200
commit2cb45836b98fac6c31cf0118d1643615a3a6dcb6 (patch)
treed451c842110c08882afd9c664b386e7e57a78059
parentdev-python/chevron: 0.14.0, python compat 3_13 (diff)
downloadguru-dev.tar.gz
guru-dev.tar.bz2
guru-dev.zip
sys-boot/limine: add USE flag for UEFI LoongArch64 bootloaderdev
Signed-off-by: Kacper Słomiński <kacper.slominski72@gmail.com>
-rw-r--r--sys-boot/limine/limine-8.0.5.ebuild5
-rw-r--r--sys-boot/limine/metadata.xml3
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-boot/limine/limine-8.0.5.ebuild b/sys-boot/limine/limine-8.0.5.ebuild
index 89044a592c..4758f4e64b 100644
--- a/sys-boot/limine/limine-8.0.5.ebuild
+++ b/sys-boot/limine/limine-8.0.5.ebuild
@@ -10,9 +10,9 @@ SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/li
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64 +uefirv64"
+IUSE="+bios +bios-pxe +bios-cd +cd-efi +uefi32 +uefi64 +uefiaa64 +uefirv64 +uefiloong64"
-MY_LLVM_TARGETS="AArch64 ARM X86 RISCV"
+MY_LLVM_TARGETS="AArch64 ARM X86 RISCV LoongArch"
MY_LLVM_FLAGS="llvm_targets_${MY_LLVM_TARGETS// /(-),llvm_targets_}(-)"
BDEPEND="
@@ -36,6 +36,7 @@ src_configure() {
"$(use_enable uefi64 uefi-x86-64)"
"$(use_enable uefiaa64 uefi-aarch64)"
"$(use_enable uefirv64 uefi-riscv64)"
+ "$(use_enable uefiloong64 uefi-loongarch64)"
"$(use_enable cd-efi uefi-cd)"
)
diff --git a/sys-boot/limine/metadata.xml b/sys-boot/limine/metadata.xml
index f42861f8a9..0a6d23f730 100644
--- a/sys-boot/limine/metadata.xml
+++ b/sys-boot/limine/metadata.xml
@@ -21,6 +21,9 @@
<flag name="uefirv64">
Enable 64-bit RISC-V UEFI support.
</flag>
+ <flag name="uefiloong64">
+ Enable 64-bit LoongArch UEFI support.
+ </flag>
<flag name="cd-efi">
Enable building cd-efi.bin using <pkg>sys-fs/mtools</pkg>.
This flag was previously known as eltorito-efi.