aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Duarte <gonegrier.duarte@gmail.com>2023-08-29 10:49:04 +0100
committerGonçalo Duarte <gonegrier.duarte@gmail.com>2023-08-29 10:52:46 +0100
commit6cdcee796e337d2450a630165b63f634ef43f511 (patch)
treef29f8c0c6f38c48d5f588cb67e335965dc8aa6b8
parentapp-doc/geeknote: new package, add 9999 (diff)
downloadguru-6cdcee796e337d2450a630165b63f634ef43f511.tar.gz
guru-6cdcee796e337d2450a630165b63f634ef43f511.tar.bz2
guru-6cdcee796e337d2450a630165b63f634ef43f511.zip
sys-firmware/lenovolegionlinux: fix python build error (upstream change)
Signed-off-by: Gonçalo Duarte <gonegrier.duarte@gmail.com>
-rw-r--r--sys-firmware/lenovolegionlinux/lenovolegionlinux-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-firmware/lenovolegionlinux/lenovolegionlinux-9999.ebuild b/sys-firmware/lenovolegionlinux/lenovolegionlinux-9999.ebuild
index 4b0098d1d..8eed68df1 100644
--- a/sys-firmware/lenovolegionlinux/lenovolegionlinux-9999.ebuild
+++ b/sys-firmware/lenovolegionlinux/lenovolegionlinux-9999.ebuild
@@ -13,9 +13,13 @@ EGIT_REPO_URI="https://github.com/johnfanv2/LenovoLegionLinux.git"
DESCRIPTION="Lenovo Legion Linux kernel module"
HOMEPAGE="https://github.com/johnfanv2/LenovoLegionLinux"
-RDEPEND="sys-kernel/linux-headers
+BDEPEND="sys-kernel/linux-headers
sys-apps/lm-sensors
sys-apps/dmidecode
+ sys-apps/sed
+"
+
+RDEPEND="
legion-tools? ( dev-python/PyQt5 dev-python/pyyaml dev-python/argcomplete dev-python/darkdetect )
downgrade-nvidia? ( <=x11-drivers/nvidia-drivers-525 )
legion-acpi? ( sys-power/acpid )
@@ -39,6 +43,8 @@ src_compile() {
)
KERNELVERSION=${KV_FULL} linux-mod-r1_src_compile
if use legion-tools; then
+ #fix python package version
+ sed -i "s/version = _VERSION/version = 1.0.0/g" "${WORKDIR}/${P}/python/legion_linux/setup.cfg"
#Define build dir (fix sandboxed)
cd "${WORKDIR}/${P}/python/legion_linux"
distutils-r1_src_compile --build-dir "${WORKDIR}/${P}/python/legion_linux/build"