aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-07-14 18:17:52 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-07-14 18:20:10 +0200
commit8cc9b9f1155a4f3af709606749bf81cc59ef1f4a (patch)
tree081501798e28598354140fdfdcae29acc4351523
parentdev-hare/hare-ssh: add 0.24.2 (diff)
downloadguru-8cc9b9f1155a4f3af709606749bf81cc59ef1f4a.tar.gz
guru-8cc9b9f1155a4f3af709606749bf81cc59ef1f4a.tar.bz2
guru-8cc9b9f1155a4f3af709606749bf81cc59ef1f4a.zip
app-admin/himitsu: add 0.8
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
-rw-r--r--app-admin/himitsu/Manifest1
-rw-r--r--app-admin/himitsu/himitsu-0.8.ebuild34
-rw-r--r--app-admin/himitsu/himitsu-9999.ebuild2
3 files changed, 36 insertions, 1 deletions
diff --git a/app-admin/himitsu/Manifest b/app-admin/himitsu/Manifest
index 44d0520d71..c14a7faccc 100644
--- a/app-admin/himitsu/Manifest
+++ b/app-admin/himitsu/Manifest
@@ -1 +1,2 @@
DIST himitsu-0.7.tar.gz 43447 BLAKE2B 79bf522be00af42506fe020b69013290cda221d7768579d0056fbafaf938c1a6dd61f039d5ca699e54e7292adc728be696b254785d45bed42ad0ee14c017c589 SHA512 5b7136d9145729e1d277f78595c5d2f7d7d73cdad3b46b585c90cc8ae945acdad7761abc14c49d686b0c9ff82183c7c7bae286e4818f08ac50b9cf751502744c
+DIST himitsu-0.8.tar.gz 52331 BLAKE2B 4cdedfbaaf804455f32b8bf63721c92a86ad7818b06ff88c497b8631edf27fc0fdf13ccc6f2ed693368cac6f17212f9c517811f4d66b2ec15a6e8fceeafe0261 SHA512 65947e516b90435d4b9635c6d8762d58c003b4bd3e128499b9f99bc94f6e238e3978f073c0f31c0a863b27026dccc39353fed422db95515610cc288cc65559af
diff --git a/app-admin/himitsu/himitsu-0.8.ebuild b/app-admin/himitsu/himitsu-0.8.ebuild
new file mode 100644
index 0000000000..a739e3bc79
--- /dev/null
+++ b/app-admin/himitsu/himitsu-0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/himitsu"
+ SLOT="0"
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/himitsu/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+ SLOT="0/${PV}"
+fi
+
+DESCRIPTION="Secret storage system for Unix, suitable for storing passwords, keys, ..."
+HOMEPAGE="https://git.sr.ht/~sircmpwn/himitsu"
+LICENSE="GPL-3"
+
+
+DEPEND="
+ >=dev-lang/hare-0.24.2:=
+"
+RDEPEND="
+ gui-apps/hiprompt-gtk-py
+"
+BDEPEND="app-text/scdoc"
+
+# binaries are hare-built
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+src_configure() {
+ sed -i 's;^PREFIX=.*;PREFIX=/usr;' Makefile || die
+}
diff --git a/app-admin/himitsu/himitsu-9999.ebuild b/app-admin/himitsu/himitsu-9999.ebuild
index 2ca5d1712a..a739e3bc79 100644
--- a/app-admin/himitsu/himitsu-9999.ebuild
+++ b/app-admin/himitsu/himitsu-9999.ebuild
@@ -19,7 +19,7 @@ LICENSE="GPL-3"
DEPEND="
- >=dev-lang/hare-0_pre20231127-r1:=
+ >=dev-lang/hare-0.24.2:=
"
RDEPEND="
gui-apps/hiprompt-gtk-py