aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-07-14 18:30:55 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-07-14 18:31:03 +0200
commitb3bf81f98bdcd83144a16194d553e61a231ecca6 (patch)
treee05472419f827b54617af0f76533b7a98311cf03
parentapp-admin/himitsu-ssh: add 0.4 (diff)
downloadguru-b3bf81f98bdcd83144a16194d553e61a231ecca6.tar.gz
guru-b3bf81f98bdcd83144a16194d553e61a231ecca6.tar.bz2
guru-b3bf81f98bdcd83144a16194d553e61a231ecca6.zip
app-admin/himitsu-totp: add 0.2
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
-rw-r--r--app-admin/himitsu-totp/Manifest1
-rw-r--r--app-admin/himitsu-totp/himitsu-totp-0.2.ebuild31
-rw-r--r--app-admin/himitsu-totp/himitsu-totp-9999.ebuild2
3 files changed, 33 insertions, 1 deletions
diff --git a/app-admin/himitsu-totp/Manifest b/app-admin/himitsu-totp/Manifest
index a5701767e4..33eb3b9ef8 100644
--- a/app-admin/himitsu-totp/Manifest
+++ b/app-admin/himitsu-totp/Manifest
@@ -1 +1,2 @@
DIST himitsu-totp-0.1.tar.gz 15188 BLAKE2B c5165556e67440e847f9ee6ab653705f22953b08a678e6a865e9d0fe2946b8ad755e685b62b0bdf5dc9c5f44698d85c8095bd8b2b43f5731721c26e407868955 SHA512 767dbfc0bee2942e4b2a75ea2e76ec39f06bcc979cd6f6f1e63d7e64d4f26c311458f47c282915f0e6f4ea39582510b4f516ac76251acb617105495f9bdfeb30
+DIST himitsu-totp-0.2.tar.gz 15199 BLAKE2B bc6f7c4420956649a44a9c8a2a1315d49dc044f9a5bee72c690bcf3a6f8d9e2f3ab6c592bff40f813d6f76fb89b3a0f6a06003138c9165b46edb19b274a6ae13 SHA512 a6b3958e5b9c6e2e0bf4061ce9b4b5d738cc0635533ae944758630a7e3b6cae3c20e80e9f0078fa63c67965b5b3078b77b15a603d402bce3965cf58441a70781
diff --git a/app-admin/himitsu-totp/himitsu-totp-0.2.ebuild b/app-admin/himitsu-totp/himitsu-totp-0.2.ebuild
new file mode 100644
index 0000000000..68988fc7fc
--- /dev/null
+++ b/app-admin/himitsu-totp/himitsu-totp-0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/himitsu-totp"
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/himitsu-totp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+DESCRIPTION="TOTP support for Himitsu"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/himitsu-totp"
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="app-admin/himitsu:="
+DEPEND="
+ ${RDEPEND}
+ >=dev-lang/hare-0.24.2:=
+"
+BDEPEND="app-text/scdoc"
+
+# hare binary
+QA_FLAGS_IGNORED="usr/bin/hitotp"
+
+src_configure() {
+ sed -i 's;^PREFIX=.*;PREFIX=/usr;' Makefile || die
+}
diff --git a/app-admin/himitsu-totp/himitsu-totp-9999.ebuild b/app-admin/himitsu-totp/himitsu-totp-9999.ebuild
index 7699eec111..68988fc7fc 100644
--- a/app-admin/himitsu-totp/himitsu-totp-9999.ebuild
+++ b/app-admin/himitsu-totp/himitsu-totp-9999.ebuild
@@ -19,7 +19,7 @@ SLOT="0"
RDEPEND="app-admin/himitsu:="
DEPEND="
${RDEPEND}
- dev-lang/hare:=
+ >=dev-lang/hare-0.24.2:=
"
BDEPEND="app-text/scdoc"