aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuincy Fleming <quincyf467@protonmail.com>2024-11-28 03:06:09 -0600
committerQuincy Fleming <quincyf467@protonmail.com>2024-11-28 03:06:09 -0600
commitd1f1cfc8ecd1fbb6490eea0ee892341fd2a0b080 (patch)
treefa8df80a3be585d71045023ffd403fb36f0883d2 /app-admin/hardinfo2
parentdev-python/pytest-click: treeclean, moved to ::gentoo (diff)
downloadguru-d1f1cfc8ecd1fbb6490eea0ee892341fd2a0b080.tar.gz
guru-d1f1cfc8ecd1fbb6490eea0ee892341fd2a0b080.tar.bz2
guru-d1f1cfc8ecd1fbb6490eea0ee892341fd2a0b080.zip
app-admin/hardinfo2: remove optimization flag
Bug: https://bugs.gentoo.org/945174 Signed-off-by: Quincy Fleming <quincyf467@protonmail.com>
Diffstat (limited to 'app-admin/hardinfo2')
-rw-r--r--app-admin/hardinfo2/files/remove-optimization-flag.patch12
-rw-r--r--app-admin/hardinfo2/hardinfo2-2.2.4-r2.ebuild64
2 files changed, 76 insertions, 0 deletions
diff --git a/app-admin/hardinfo2/files/remove-optimization-flag.patch b/app-admin/hardinfo2/files/remove-optimization-flag.patch
new file mode 100644
index 000000000..30d0fb840
--- /dev/null
+++ b/app-admin/hardinfo2/files/remove-optimization-flag.patch
@@ -0,0 +1,12 @@
+diff '--color=auto' -aur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2024-11-28 02:48:17.057740689 -0600
++++ b/CMakeLists.txt 2024-11-28 02:51:56.721795566 -0600
+@@ -495,7 +495,7 @@
+ modules/benchmark/md5.c
+ modules/benchmark/sha1.c
+ PROPERTIES
+- COMPILE_FLAGS "-O0 -Wall -Wextra -Werror=implicit-function-declaration"
++ COMPILE_FLAGS "-Wall -Wextra -Werror=implicit-function-declaration"
+ )
+
+ set_source_files_properties(
diff --git a/app-admin/hardinfo2/hardinfo2-2.2.4-r2.ebuild b/app-admin/hardinfo2/hardinfo2-2.2.4-r2.ebuild
new file mode 100644
index 000000000..8876afe92
--- /dev/null
+++ b/app-admin/hardinfo2/hardinfo2-2.2.4-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg-utils
+
+DESCRIPTION="System Information and Benchmark for Linux Systems"
+HOMEPAGE="https://www.hardinfo2.org"
+SRC_URI="https://github.com/hardinfo2/hardinfo2/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-2+ GPL-3+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="benchmark fwupd +gtk3"
+
+DEPEND="
+ gtk3? ( x11-libs/gtk+:3 ) !gtk3? ( x11-libs/gtk+:2 )
+ >=dev-libs/glib-2.24
+ sys-libs/zlib
+ dev-libs/json-glib
+ net-libs/libsoup:3.0
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/libX11
+ x11-libs/pango
+"
+RDEPEND="
+ ${DEPEND}
+ dev-util/vulkan-tools
+ net-misc/iperf:3
+ sys-apps/dmidecode
+ sys-apps/lm-sensors
+ sys-fs/lsscsi
+ sys-fs/udisks:2
+ x11-apps/mesa-progs
+ x11-apps/xrandr
+ x11-misc/xdg-utils
+ benchmark? ( app-benchmarks/sysbench )
+ fwupd? ( sys-apps/fwupd )
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/remove-optimization-flag.patch" )
+
+src_configure() {
+ filter-flags -O*
+
+ local mycmakeargs=(
+ -DHARDINFO2_GTK3=$(usex gtk3)
+ -DHARDINFO2_QT5=0
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}