aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Eduardo <carana2099@gmail.com>2024-05-19 15:27:26 -0300
committerCarlos Eduardo <carana2099@gmail.com>2024-05-19 15:28:53 -0300
commit99dce31f122a6e6061b313fb46ecc181e97cd7a0 (patch)
treefbdafc6c6de2c8beb8e1d7c5d2ba4b6acaeec3a9 /app-containers
parentapp-text/lchat: new package, add 1.0 (diff)
downloadguru-99dce31f122a6e6061b313fb46ecc181e97cd7a0.tar.gz
guru-99dce31f122a6e6061b313fb46ecc181e97cd7a0.tar.bz2
guru-99dce31f122a6e6061b313fb46ecc181e97cd7a0.zip
app-containers/arachsys-containers: new package, add 1.7
Signed-off-by: Carlos Eduardo <carana2099@gmail.com>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/arachsys-containers/Manifest1
-rw-r--r--app-containers/arachsys-containers/arachsys-containers-1.7.ebuild28
-rw-r--r--app-containers/arachsys-containers/metadata.xml23
3 files changed, 52 insertions, 0 deletions
diff --git a/app-containers/arachsys-containers/Manifest b/app-containers/arachsys-containers/Manifest
new file mode 100644
index 0000000000..72aa2ef7da
--- /dev/null
+++ b/app-containers/arachsys-containers/Manifest
@@ -0,0 +1 @@
+DIST containers-1.7.tar.gz 13703 BLAKE2B c1ed49e4a7201b8f83daad7c9f54ac0532db98362d9f79fc105ee384c18b0c3f775d806337970205e35b08c0377c39f5538550f94f6578cb023b7c832f37d290 SHA512 864255909eab55f698969e48f7150f5005a65401cbd95988f780f309b50116d4a5e1c4aebc706d73b783c3a36b900dab16d8c54c4b2b8c92d977649a4f15ad93
diff --git a/app-containers/arachsys-containers/arachsys-containers-1.7.ebuild b/app-containers/arachsys-containers/arachsys-containers-1.7.ebuild
new file mode 100644
index 0000000000..b266cf5d17
--- /dev/null
+++ b/app-containers/arachsys-containers/arachsys-containers-1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN="${PN#arachsys-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Simple containers using Linux user namespaces"
+HOMEPAGE="https://arachsys.github.io"
+SRC_URI="https://github.com/arachsys/${MY_PN}/archive/refs/tags/${MY_P}.tar.gz"
+# weird tag names
+S="${WORKDIR}/${MY_PN}-${MY_P}"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+suid"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="$CFLAGS"
+}
+
+src_install() {
+ into /
+ dobin inject contain pseudo
+ dodoc README TIPS
+ use suid && fperms u+s /bin/contain /bin/pseudo
+}
diff --git a/app-containers/arachsys-containers/metadata.xml b/app-containers/arachsys-containers/metadata.xml
new file mode 100644
index 0000000000..1810c580ff
--- /dev/null
+++ b/app-containers/arachsys-containers/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>carana2099@gmail.com</email>
+ <description>Carlos E.</description>
+ </maintainer>
+ <longdescription>
+ This package is a minimalist implementation of containers for Linux, making secure
+ containers as easy to create and use as a traditional chroot. It comprises three
+ utilities, contain, inject and pseudo, which use the kernel support for user
+ namespaces merged in Linux 3.8.
+ </longdescription>
+ <use>
+ <flag name="suid">
+ allow unprivileged users to have multiple UIDs/GIDs in the container (see CVE-2014-8989 for implications)
+ </flag>
+ </use>
+ <upstream>
+ <bugs-to>mailto:chris@arachsys.com</bugs-to>
+ <remote-id type="github">arachsys/containers</remote-id>
+ </upstream>
+</pkgmetadata>