aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJhonatan Justin <jhonatan@justin.com.br>2022-07-26 16:44:02 -0300
committerJhonatan Justin <jhonatan@justin.com.br>2022-07-26 16:44:02 -0300
commitf0451148dbf5848709433d7c10e5373922775a12 (patch)
tree257e8eaee63bde3d88b8cb506bcc8948dcb32389 /app-emulation
parentdev-libs/sirit: new ebuild (diff)
downloadguru-f0451148dbf5848709433d7c10e5373922775a12.tar.gz
guru-f0451148dbf5848709433d7c10e5373922775a12.tar.bz2
guru-f0451148dbf5848709433d7c10e5373922775a12.zip
app-emulation/proton-ge-custom-bin: new package
Signed-off-by: Jhonatan Justin <jhonatan@justin.com.br>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/proton-ge-custom-bin/Manifest1
-rw-r--r--app-emulation/proton-ge-custom-bin/metadata.xml11
-rw-r--r--app-emulation/proton-ge-custom-bin/proton-ge-custom-bin-7.27.ebuild25
3 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/proton-ge-custom-bin/Manifest b/app-emulation/proton-ge-custom-bin/Manifest
new file mode 100644
index 000000000..dd06c6418
--- /dev/null
+++ b/app-emulation/proton-ge-custom-bin/Manifest
@@ -0,0 +1 @@
+DIST GE-Proton7-27.tar.gz 415170082 BLAKE2B 1773d34defe483a6c894d55de1089eb831f1d44e92bfae5c46faeec825fa8b2cc7c05ac9ca9a05d6ea0c393aa90fe06334a0c07feef71631e27a7dbf30e3dcda SHA512 b741594fbc062bf7e5b5228273680807fb3eb20cfa04993b2e4ce9442ebed18f3e84ca5d59ee19381165d595932fe54b720526bd1f41b2bf74b13a20308de5ee
diff --git a/app-emulation/proton-ge-custom-bin/metadata.xml b/app-emulation/proton-ge-custom-bin/metadata.xml
new file mode 100644
index 000000000..b5d1811b0
--- /dev/null
+++ b/app-emulation/proton-ge-custom-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jhonatan@justin.com.br</email>
+ <name>Jhonatan Justin</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://discord.com/invite/6y3BdzC</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/proton-ge-custom-bin/proton-ge-custom-bin-7.27.ebuild b/app-emulation/proton-ge-custom-bin/proton-ge-custom-bin-7.27.ebuild
new file mode 100644
index 000000000..569b83a87
--- /dev/null
+++ b/app-emulation/proton-ge-custom-bin/proton-ge-custom-bin-7.27.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+inherit multilib-minimal
+
+DESCRIPTION="A fancy custom distribution of Valves Proton with various patches"
+HOMEPAGE="https://github.com/GloriousEggroll/proton-ge-custom"
+SRC_URI="https://github.com/GloriousEggroll/proton-ge-custom/releases/download/GE-Proton${PV/./-}/GE-Proton${PV/./-}.tar.gz"
+S="${WORKDIR}/GE-Proton${PV/./-}"
+LICENSE="|| ( 0BSD LGPL-2+ ZLIB MIT MPL-2.0 OFL-1.1 proton )"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+RESTRICT="mirror strip"
+QA_PREBUILT={*}
+
+RDEPEND="
+ media-libs/mesa[vulkan,${MULTILIB_USEDEP}]
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]"
+
+src_install() {
+ insinto "/usr/share/Steam/compatibilitytools.d/"
+ doins -r "${S}"
+}