aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzael Reyes <azael.devel@gmail.com>2020-08-11 10:03:55 -0700
committerAzael Reyes <azael.devel@gmail.com>2020-08-11 10:04:40 -0700
commit77468b0bb772de12e9df4cdcd7b176466f7bd9bf (patch)
tree708725842880cbd934dcf07e1c87bef6151b39e9 /app-portage
parentdev-libs/octetos-coreutils: add missing dep (diff)
downloadguru-77468b0bb772de12e9df4cdcd7b176466f7bd9bf.tar.gz
guru-77468b0bb772de12e9df4cdcd7b176466f7bd9bf.tar.bz2
guru-77468b0bb772de12e9df4cdcd7b176466f7bd9bf.zip
app-portage/version: adding package version
Signed-off-by: Azael Reyes <azael.devel@gmail.com> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Azael Reyes <azael.devel@gmail.com>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/version/Manifest2
-rw-r--r--app-portage/version/metadata.xml8
-rw-r--r--app-portage/version/version-0.6.1_alpha.ebuild32
-rw-r--r--app-portage/version/version-0.6.2_alpha.ebuild32
4 files changed, 74 insertions, 0 deletions
diff --git a/app-portage/version/Manifest b/app-portage/version/Manifest
new file mode 100644
index 000000000..e31773631
--- /dev/null
+++ b/app-portage/version/Manifest
@@ -0,0 +1,2 @@
+DIST 0.6.1.tar.gz 24986 BLAKE2B a78b7b1a5a2aec26afba6916483a40ac17c2aafae45511d3ba35bf28ec8466e1b696f235e1d3d54c83bffa5e9f974c7f2cd8f188e637d8b315e876d91741fae2 SHA512 ff68c7cfec5c59a1cfb8a600a1a439e7bdacba464c27e114f6fc0879caaf66cf04447e8dfff5c4afc02808fd19677f979520121b00c2d1f0a4995c5adade728d
+DIST 0.6.2-alpha.tar.gz 35658 BLAKE2B 89be24ecf24ac711045711f65303eb2deae9cccaf8d1fbc28c8f07e4d1fff3234e5ffdb0686de05fa29becca9d4eba2875307a4842f0f1aa66a8910d74f984cc SHA512 1fbb9295209e58babe1039ded6295024db040b4c5775f405be4af5e49035d9d968f322d919b055567340998828d04bafab7a140d98807d4a0d8eeedda7ed2dba
diff --git a/app-portage/version/metadata.xml b/app-portage/version/metadata.xml
new file mode 100644
index 000000000..3a36ca4b7
--- /dev/null
+++ b/app-portage/version/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>azael.devel@gmail.com</email>
+ <name>Azael Reyes</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-portage/version/version-0.6.1_alpha.ebuild b/app-portage/version/version-0.6.1_alpha.ebuild
new file mode 100644
index 000000000..f50ecbdd6
--- /dev/null
+++ b/app-portage/version/version-0.6.1_alpha.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MYPV="${PV/_alpha}"
+
+DESCRIPTION="A command line/operator for package version."
+HOMEPAGE="https://github.com/azaeldevel/octetos-version"
+SRC_URI="https://github.com/azaeldevel/octetos-${PN}/archive/${MYPV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+DEPEND="dev-libs/octetos-core"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/octetos-${PN}-${MYPV}"
+
+src_prepare() {
+ default
+ eautoreconf -fi
+}
+src_configure() {
+ econf --with-portage
+}
diff --git a/app-portage/version/version-0.6.2_alpha.ebuild b/app-portage/version/version-0.6.2_alpha.ebuild
new file mode 100644
index 000000000..75332f76b
--- /dev/null
+++ b/app-portage/version/version-0.6.2_alpha.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MYPV="${PV/_alpha/-alpha}"
+
+DESCRIPTION="A command line/operator for package version."
+HOMEPAGE="https://github.com/azaeldevel/octetos-version"
+SRC_URI="https://github.com/azaeldevel/octetos-${PN}/archive/${MYPV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+DEPEND="dev-libs/octetos-core"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/octetos-${PN}-${MYPV}"
+
+src_prepare() {
+ default
+ eautoreconf -fi
+}
+src_configure() {
+ econf --with-portage
+}