aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrian gloyer <brian.gloyer@gmail.com>2024-06-02 10:12:18 -0700
committerbrian gloyer <brian.gloyer@gmail.com>2024-06-02 10:19:37 -0700
commitae72abc87df06d9db374f56ab490913abb99c649 (patch)
treee8530fa93314a02d670e36933037f6e403da6b2f /app-portage
parentnet-news/gfeeds: python3_12 (diff)
downloadguru-ae72abc87df06d9db374f56ab490913abb99c649.tar.gz
guru-ae72abc87df06d9db374f56ab490913abb99c649.tar.bz2
guru-ae72abc87df06d9db374f56ab490913abb99c649.zip
app-portage/appswipe: edg.utils -> edg
Signed-off-by: brian gloyer <brian.gloyer@gmail.com>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/appswipe/appswipe-1.1.68.ebuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/app-portage/appswipe/appswipe-1.1.68.ebuild b/app-portage/appswipe/appswipe-1.1.68.ebuild
index 70895cbdac..fe657607eb 100644
--- a/app-portage/appswipe/appswipe-1.1.68.ebuild
+++ b/app-portage/appswipe/appswipe-1.1.68.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop qmake-utils xdg-utils
+inherit desktop qmake-utils xdg
DESCRIPTION="Application for browsing your local Portage repository files"
HOMEPAGE="https://github.com/k9spud/appswipe"
@@ -45,19 +45,9 @@ src_compile() {
}
src_install() {
- mv AppSwipe appswipe
- dobin appswipe
+ newbin AppSwipe appswipe
dobin backend/appswipebackend
dobin transport/appswipetransport
- mv "${S}/img/appicon.svg" "${S}/img/appswipe.svg"
- doicon -s scalable "${S}/img/appswipe.svg"
+ newicon -s scalable img/appicon.svg ${PN}.svg
domenu ${PN}.desktop
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}