aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-01-29 20:42:39 +0100
committertastytea <gentoo@tastytea.de>2024-01-29 20:50:16 +0100
commit43ec8073a54032c5852287b7d37a32f06e0508a3 (patch)
tree4c3d224063b44d8b127a060e91c9a2842f6ff787 /app-shells/fzf-tab
parentapp-shells/carapace: drop 0.29.0 (diff)
downloadguru-43ec8073a54032c5852287b7d37a32f06e0508a3.tar.gz
guru-43ec8073a54032c5852287b7d37a32f06e0508a3.tar.bz2
guru-43ec8073a54032c5852287b7d37a32f06e0508a3.zip
app-shells/fzf-tab: add 0_pre20230611
add workaround for >=clang-16 Bug: https://github.com/Aloxaf/fzf-tab/issues/337 Closes: https://bugs.gentoo.org/887281 Closes: https://bugs.gentoo.org/901157 Signed-off-by: tastytea <gentoo@tastytea.de>
Diffstat (limited to 'app-shells/fzf-tab')
-rw-r--r--app-shells/fzf-tab/Manifest1
-rw-r--r--app-shells/fzf-tab/fzf-tab-0_pre20230611.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-shells/fzf-tab/Manifest b/app-shells/fzf-tab/Manifest
index 0a9d2d980..0143c2ab0 100644
--- a/app-shells/fzf-tab/Manifest
+++ b/app-shells/fzf-tab/Manifest
@@ -1,2 +1,3 @@
DIST fzf-tab-0_pre20220815.tar.gz 774621 BLAKE2B d945b8a206505972fe23f9339c470386d8cdd3b71336372ccf5bf0599fc0569813bcd577e290323f803e9d99cbfc0c275941a4710ee8dfe45002271cbee89bf0 SHA512 0fa16dbcc755717ae3f7873b5a62da28d620493eaf679f74e5f77187a5253f7c0dab55fbcdfceb0fd895be5e080a773bc1a75670551fc3ef7755ce976fa94591
DIST fzf-tab-0_pre20221124.tar.gz 774711 BLAKE2B eb2b5ade1bc50f1fe06265084fe5b675fa54e85d0b2590b84bb542217c1cffd1d676bba3e279009614da587a302d017dafbd5ed8f349887d23e5f1e93c68fc84 SHA512 b12e21d1cd5752801aa738b9b8b20c2627f15e1f8d8d1e169e4379ee1de662c62c9c1edb8d7c298d71009c3fd9c10c537dae683b4e087934969e0aa116ec9c72
+DIST fzf-tab-0_pre20230611.tar.gz 774797 BLAKE2B 81c1bdb6d5a6fbb2d8ac686821a5b80e953e4cbf4072853190a9c7bb370edc2e87cff1ce17d632c5554f46906335ed1e6cda8ff8c46cb8fbe2177f6da50afc71 SHA512 091fbc1a185a51ee74025d3b431e225ee0d2ffaa1e8c5a7c45ba4fe629ccc335cab118989f2bfc0e143ce3424cc290f97a78ad3da7ae1ed19500c27b6d4e0267
diff --git a/app-shells/fzf-tab/fzf-tab-0_pre20230611.ebuild b/app-shells/fzf-tab/fzf-tab-0_pre20230611.ebuild
new file mode 100644
index 000000000..5cccc4a22
--- /dev/null
+++ b/app-shells/fzf-tab/fzf-tab-0_pre20230611.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2022,2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic readme.gentoo-r1
+
+MY_COMMIT="c2b4aa5ad2532cca91f23908ac7f00efb7ff09c9"
+DESCRIPTION="Replace zsh's default completion selection menu with fzf"
+HOMEPAGE="https://github.com/Aloxaf/fzf-tab"
+SRC_URI="https://github.com/Aloxaf/fzf-tab/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ app-shells/fzf
+ app-shells/zsh
+"
+BDEPEND="
+ test? (
+ app-shells/zsh
+ dev-vcs/git
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-functions/${PN}.zsh
+to your ~/.zshrc after compinit, but before plugins which will wrap
+widgets, such as zsh-autosuggestions or fast-syntax-highlighting"
+
+src_configure() {
+ # Test fails if we modify FZF_TAB_HOME in place
+ sed -E "s|^(FZF_TAB_HOME=\"[^\"]+)\"$|\1/${PN}\"|" \
+ ${PN}.zsh > ${PN}-patched.zsh || die "Modifying FZF_TAB_HOME failed"
+
+ pushd modules || die "Changing directory failed"
+ append-cflags -Wno-error=implicit-function-declaration -Wno-error=implicit-int
+ default_src_configure
+}
+
+src_compile() {
+ pushd modules || die "Changing directory failed"
+ default_src_compile
+}
+
+src_test() {
+ pushd test || die "Changing directory failed"
+ ZTST_verbose=1 zsh -f ./runtests.zsh fzftab.ztst || die "One or more tests failed"
+}
+
+src_install() {
+ local zsh_libdir="/usr/share/zsh/site-functions"
+
+ insinto ${zsh_libdir}
+ newins ${PN}{-patched,}.zsh
+
+ insinto ${zsh_libdir}/${PN}
+ doins -r lib
+
+ insinto ${zsh_libdir}/${PN}/modules/Src/aloxaf
+ doins modules/Src/aloxaf/fzftab.so
+
+ readme.gentoo_create_doc
+ einstalldocs
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}