aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-09-22 18:59:32 +0200
committerAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-09-22 19:00:23 +0200
commit51c6c2d8ea8f87897e3b4945d45964bde50bc2fa (patch)
treecd445e5deb5c7da0e479b9e9bf4d8038b4f7f611 /app-vim
parentgui-apps/someblocks: respect CFLAGS (diff)
downloadguru-51c6c2d8ea8f87897e3b4945d45964bde50bc2fa.tar.gz
guru-51c6c2d8ea8f87897e3b4945d45964bde50bc2fa.tar.bz2
guru-51c6c2d8ea8f87897e3b4945d45964bde50bc2fa.zip
app-vim/ansible-vim: new package, add 3.2
Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/ansible-vim/Manifest1
-rw-r--r--app-vim/ansible-vim/ansible-vim-3.2.ebuild20
-rw-r--r--app-vim/ansible-vim/metadata.xml8
3 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/ansible-vim/Manifest b/app-vim/ansible-vim/Manifest
new file mode 100644
index 000000000..4a86b00a6
--- /dev/null
+++ b/app-vim/ansible-vim/Manifest
@@ -0,0 +1 @@
+DIST ansible-vim-3.2.tar.gz 12116 BLAKE2B e532b348216f3616060b9e09d177d601534c37eda1305512309954e0480e2827bd6f2d40564151104184a389c495b2442264f34d5b8031a1023ddd093cdd1be6 SHA512 a75e8b149befb001fdb0012ea8219287a6b4c302e2ae2de456835c48e3a516bb99bfb91a21e2d60eff12b5a24d918510dd9302d93e0bf43cb42f025ea0504d1b
diff --git a/app-vim/ansible-vim/ansible-vim-3.2.ebuild b/app-vim/ansible-vim/ansible-vim-3.2.ebuild
new file mode 100644
index 000000000..922948793
--- /dev/null
+++ b/app-vim/ansible-vim/ansible-vim-3.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VIM_PLUGIN_VIM_VERSION="7.0"
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: sytax highlighting for Ansible's common file types"
+HOMEPAGE="https://github.com/pearofducks/ansible-vim"
+SRC_URI="https://github.com/pearofducks/ansible-vim/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT BSD"
+KEYWORDS="~amd64"
+
+src_install() {
+ vim-plugin_src_install
+
+ find "${ED}" -name "*LICENSE" -delete || die
+}
diff --git a/app-vim/ansible-vim/metadata.xml b/app-vim/ansible-vim/metadata.xml
new file mode 100644
index 000000000..f384473e1
--- /dev/null
+++ b/app-vim/ansible-vim/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Adrian Schollmeyer</name>
+ <email>nex+b-g-o@nexadn.de</email>
+ </maintainer>
+</pkgmetadata>