aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-06-13 09:19:39 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-06-13 09:23:39 +0200
commit8e6624e23d862243a50890141ddf61779193de91 (patch)
tree4201d8c7c0df5e84b72ce093ecf262d5b693a8d3 /dev-build
parentdev-util/dmg2img: Fix compile step in ebuild (diff)
downloadguru-8e6624e23d862243a50890141ddf61779193de91.tar.gz
guru-8e6624e23d862243a50890141ddf61779193de91.tar.bz2
guru-8e6624e23d862243a50890141ddf61779193de91.zip
dev-build/pdpmake: Run tests manually
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/pdpmake/pdpmake-1.4.3.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-build/pdpmake/pdpmake-1.4.3.ebuild b/dev-build/pdpmake/pdpmake-1.4.3.ebuild
index e0fba6763..cb0f1475d 100644
--- a/dev-build/pdpmake/pdpmake-1.4.3.ebuild
+++ b/dev-build/pdpmake/pdpmake-1.4.3.ebuild
@@ -11,7 +11,13 @@ SLOT="0"
KEYWORDS="~amd64"
src_test() {
- emake test
+ pushd ./testsuite || die
+
+ # Call manually instead of using `make test`
+ # Seems to run in POSIX mode otherwise, leading to POSIX 202x tests being skipped
+ ./runtest || die
+
+ popd
}
src_install() {