aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortea <gentoo@tastytea.de>2024-06-13 13:47:13 +0200
committertea <gentoo@tastytea.de>2024-06-13 14:53:42 +0200
commit287cf09fb97f547365a9254ffac44828ca99f1a6 (patch)
tree709ee6210f0f7276532a573ec2e7d202e207f0fe /dev-cpp
parentnet-im/nheko: add missing dependency (diff)
downloadguru-287cf09fb97f547365a9254ffac44828ca99f1a6.tar.gz
guru-287cf09fb97f547365a9254ffac44828ca99f1a6.tar.bz2
guru-287cf09fb97f547365a9254ffac44828ca99f1a6.zip
dev-cpp/qt-jdenticon: add 0.3.1
Signed-off-by: tea <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/qt-jdenticon/Manifest1
-rw-r--r--dev-cpp/qt-jdenticon/qt-jdenticon-0.3.1.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-cpp/qt-jdenticon/Manifest b/dev-cpp/qt-jdenticon/Manifest
index aeffc4634a..4f52e0a30d 100644
--- a/dev-cpp/qt-jdenticon/Manifest
+++ b/dev-cpp/qt-jdenticon/Manifest
@@ -1,2 +1,3 @@
DIST qt-jdenticon-0.3.0.tar.gz 11021 BLAKE2B c4cbeba7848791b2386ac474ca7412b361ee949a126f10cdb523210a8415b436c365a3c056ca3fa9c196835f6bfc92b24a01f2906e62897b88af2e80a83d3bb3 SHA512 a3477ce8fd26de563c1397a07895dcd0ec8210c62fe82e808a8c322c298111c48570ce23df639d648d86a0627b455dc7d1772e985197351251d49abd461b8c23
DIST qt-jdenticon-0.3.0_p20240107.tar.gz 12552 BLAKE2B 969d9a43fdadf388074da67d029bd7b71d5e11599d5d4a33e41fa5c9c193d47831e80e6b0d77afdb4791ba5c90c44b50dd088c03d048cecce4f7b8ce24684228 SHA512 034787268cdfe5f89960d93a113ba15f56b6f1abae3581239f3ab16adc48c7822b21baff7017247876d847f562c210d9a08bd484e206af139866a4c3f7790d4e
+DIST qt-jdenticon-0.3.1.tar.gz 12724 BLAKE2B 1556db9843b9f5e06989ac87250ea1812e17f3d1cbf7dcfa8671b0c29712df496fabdf169364c51a261f020aad49c92b9131db872f8918c65987f6202d96e68c SHA512 c9ff2b262aa146bb2d45ba1a58210afb7fbad4550cc69be0317562e1f0d9fbae071c337da9f39fbdc1c24c8bf273cd5baeec66286e0885feca703bfc0189a7bd
diff --git a/dev-cpp/qt-jdenticon/qt-jdenticon-0.3.1.ebuild b/dev-cpp/qt-jdenticon/qt-jdenticon-0.3.1.ebuild
new file mode 100644
index 0000000000..2863440cc8
--- /dev/null
+++ b/dev-cpp/qt-jdenticon/qt-jdenticon-0.3.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt5 / C++14 Port of Jdenticon"
+HOMEPAGE="https://github.com/Nheko-Reborn/qt-jdenticon"
+SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="6"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-qt/qtbase:6[gui]
+"
+DEPEND="${RDEPEND}"