aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortea <gentoo@tastytea.de>2024-06-28 06:34:47 +0200
committertea <gentoo@tastytea.de>2024-06-28 08:17:23 +0200
commit3d5cb6084bda243a842a6ec667af167b862bda39 (patch)
treec6481027729806e580d41e89e0d67cefe4f52266 /dev-cpp
parentdev-cpp/trantor: add 1.5.19 (diff)
downloadguru-3d5cb6084bda243a842a6ec667af167b862bda39.tar.gz
guru-3d5cb6084bda243a842a6ec667af167b862bda39.tar.bz2
guru-3d5cb6084bda243a842a6ec667af167b862bda39.zip
dev-cpp/trantor: drop 1.5.17
Signed-off-by: tea <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/trantor/Manifest1
-rw-r--r--dev-cpp/trantor/trantor-1.5.17.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-cpp/trantor/Manifest b/dev-cpp/trantor/Manifest
index 7fe1b0d4d9..14811ecbe0 100644
--- a/dev-cpp/trantor/Manifest
+++ b/dev-cpp/trantor/Manifest
@@ -1,3 +1,2 @@
-DIST trantor-1.5.17.tar.gz 155603 BLAKE2B 25631b3d8882cec58ff8eea2b449e805f846653d79af41a87b6ead6fff5c32dfc40559cdc734f51505a8ca1100b215cb8d66fa5fc5bf5baa96d6a3e93499a330 SHA512 43202240968b90d0e6d211d3b7a918567587e4ad26c360848efee2661cc1d49d35de408db5e2ff7314be879faac99ffa29ffa1f3735f9606d95874130db05250
DIST trantor-1.5.18.tar.gz 155626 BLAKE2B 7fdd5fdd310b783dbc23be7e3594fe3e4e5135c1fcd7c9c96e153ff28397e543a4be50153e54f4a4f648de21d6c9ca5ffa85518806b7e6d91485956f3b3627b3 SHA512 2dba27efad95155a76968959d9bd2510be8502b9424716493f385aebbce2481553cc8fae283076029aed4bef6f0aadb0bec3f9acb98fbca3ef4d49b936558f8c
DIST trantor-1.5.19.tar.gz 156467 BLAKE2B 9683cc3691389a48be1060e05c96329f826b976b4090b869d5ea097b30b33d22bd1f5373987d5900f5f2f587227eb59c442bbfb0126cce1636887472352af948 SHA512 76264df770b14702cae88bb77c8e863e85eb034fd14bb062d3414f981b759be61bff3ce5aa1c8cca44bf0ca0b3568ed77248c9986eb23b6715631cdae9445a02
diff --git a/dev-cpp/trantor/trantor-1.5.17.ebuild b/dev-cpp/trantor/trantor-1.5.17.ebuild
deleted file mode 100644
index 4a18bcd7bd..0000000000
--- a/dev-cpp/trantor/trantor-1.5.17.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Non-blocking I/O tcp network lib based on c++14/17"
-HOMEPAGE="https://github.com/an-tao/trantor"
-SRC_URI="https://github.com/an-tao/trantor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="adns doc +spdlog +ssl test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- adns? ( net-dns/c-ares:= )
- ssl? ( dev-libs/openssl:= )
- spdlog? (
- dev-libs/spdlog:=
- dev-libs/libfmt:=
- )
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-cpp/gtest )
-"
-BDEPEND="doc? ( app-text/doxygen[dot] )"
-
-src_prepare() {
- sed -i 's/ -Werror)$/)/' CMakeLists.txt || die "could not remove -Werror"
- cmake_src_prepare
-}
-
-src_configure() {
- local -a mycmakeargs=(
- "-DBUILD_SHARED_LIBS=YES"
- "-DBUILD_DOC=$(usex doc)"
- "-DBUILD_TESTING=$(usex test)"
- "-DBUILD_C-ARES=$(usex adns)"
- "-DTRANTOR_USE_TLS=$(usex ssl openssl none)"
- "-DUSE_SPDLOG=$(usex spdlog)"
- )
-
- cmake_src_configure
-}
-
-src_install() {
- use doc && HTML_DOCS="${BUILD_DIR}/docs/trantor/html/*"
-
- cmake_src_install
-}