aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortea <gentoo@tastytea.de>2024-07-21 16:55:13 +0200
committertea <gentoo@tastytea.de>2024-07-21 16:55:51 +0200
commit4a317e5cbdd1a17534d978625de439482d3decc4 (patch)
tree10939e55ecd82177ff0415d5a529656c4ce6ad93 /dev-cpp
parentdev-cpp/trantor: drop 1.5.18 (diff)
downloadguru-4a317e5cbdd1a17534d978625de439482d3decc4.tar.gz
guru-4a317e5cbdd1a17534d978625de439482d3decc4.tar.bz2
guru-4a317e5cbdd1a17534d978625de439482d3decc4.zip
dev-cpp/drogon: add 1.9.6
Signed-off-by: tea <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/drogon/Manifest2
-rw-r--r--dev-cpp/drogon/drogon-1.9.6.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-cpp/drogon/Manifest b/dev-cpp/drogon/Manifest
index 2162b14ff..c6a6a2269 100644
--- a/dev-cpp/drogon/Manifest
+++ b/dev-cpp/drogon/Manifest
@@ -1,4 +1,6 @@
DIST drogon-1.9.4.tar.gz 612364 BLAKE2B d22d594f64423ee2db271f8b0b7242bffb0d9099e0aad9a6806e3d036d89f992da05dc26d3d2652bc5e2838524f031552913a32eb092ea49b4c9c656c687eae2 SHA512 0c58ed45aacbfd1916bbd9c52ecbd203abdc1032c7d6f908750a188443e293d749705d35c2b56eab54e30f36cc606b2437889e11a482ebda34d36035e8221499
DIST drogon-1.9.5.tar.gz 616261 BLAKE2B 0e34398be264d58b90b1e3545aeed0e2aefe17258b7007f69f103ba4b281226c71a6aac2b7f98c8d58603ba896c4ddc31e215cea8d943a88d2bf519d049a03d1 SHA512 453b0d1af2cd7e567539cf8512d87961d9285c3ac1cbeb58d49c27571c7247390b99cc7ea5ddb87c969c5638bcf7a958b9c4a2649c3d89ff7e081e278de33f6f
+DIST drogon-1.9.6.tar.gz 634338 BLAKE2B 29df10fbdf03fe8b6397bc1f05a69126ab249094f00bc0fe038bbb261069aa874e75a342345b0a5c98975cf5b97832bcb42443263cd4bd99930ddc2d92454bcb SHA512 e0a1b4a0f3b9d2804169d050e2038418baf4107f94299e2b969a185f5624f9d4101d1ef24795789c48c8b2ed8dfd5c748d6162eb5ce789cad3b253c7e8692fa9
DIST trantor-1.5.18.tar.gz 155626 BLAKE2B 7fdd5fdd310b783dbc23be7e3594fe3e4e5135c1fcd7c9c96e153ff28397e543a4be50153e54f4a4f648de21d6c9ca5ffa85518806b7e6d91485956f3b3627b3 SHA512 2dba27efad95155a76968959d9bd2510be8502b9424716493f385aebbce2481553cc8fae283076029aed4bef6f0aadb0bec3f9acb98fbca3ef4d49b936558f8c
DIST trantor-1.5.19.tar.gz 156467 BLAKE2B 9683cc3691389a48be1060e05c96329f826b976b4090b869d5ea097b30b33d22bd1f5373987d5900f5f2f587227eb59c442bbfb0126cce1636887472352af948 SHA512 76264df770b14702cae88bb77c8e863e85eb034fd14bb062d3414f981b759be61bff3ce5aa1c8cca44bf0ca0b3568ed77248c9986eb23b6715631cdae9445a02
+DIST trantor-1.5.20.tar.gz 156703 BLAKE2B 628c8ccae86809f0cd547eb991a67456f871d8ad4aa9606933ce91f98744c2faeb83b41d098811757ae6fcb0e221d5fe389d9684d98fa9c40570f8202b0489d3 SHA512 3666a49de1f13f52bac6d11d7c690c1d51b73d6f7e50b2a7591cd590639f88e33282d8b6b422f518ab73b42ba2d69d6db0852338563b366c548daaba09d0b49c
diff --git a/dev-cpp/drogon/drogon-1.9.6.ebuild b/dev-cpp/drogon/drogon-1.9.6.ebuild
new file mode 100644
index 000000000..55435690c
--- /dev/null
+++ b/dev-cpp/drogon/drogon-1.9.6.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_TRANTOR_V="1.5.20" # NOTE: needs to be updated on each bump
+
+DESCRIPTION="C++14/17 based HTTP web application framework"
+HOMEPAGE="https://github.com/drogonframework/drogon"
+SRC_URI="
+ https://github.com/drogonframework/drogon/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/an-tao/trantor/archive/v${MY_TRANTOR_V}.tar.gz -> trantor-${MY_TRANTOR_V}.tar.gz )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+brotli doc examples mariadb postgres redis sqlite spdlog test +yaml"
+# REQUIRED_USE="test? ( postgres sqlite mariadb )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-cpp/trantor-${MY_TRANTOR_V}:=
+ dev-libs/jsoncpp:=
+ sys-libs/zlib
+ brotli? ( app-arch/brotli:= )
+ mariadb? ( dev-db/mariadb:= )
+ postgres? ( dev-db/postgresql:= )
+ redis? ( dev-libs/hiredis:= )
+ sqlite? ( dev-db/sqlite:3 )
+ elibc_Darwin? ( sys-libs/native-uuid )
+ elibc_SunOS? ( sys-libs/libuuid )
+ !elibc_Darwin? ( !elibc_SunOS? (
+ sys-apps/util-linux
+ ) )
+ spdlog? (
+ dev-libs/spdlog:=
+ dev-libs/libfmt:=
+ )
+ yaml? ( dev-cpp/yaml-cpp:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="doc? ( app-text/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.4-fix-test-build.patch )
+
+DOCS=( CONTRIBUTING.md ChangeLog.md README.md README.zh-CN.md README.zh-TW.md )
+
+src_unpack() {
+ default
+
+ # the cert is in the trantor submodule normally, but we unbundle that
+ if use test; then
+ mkdir -p ${P}/trantor/trantor/tests || die
+ cp -v trantor-${MY_TRANTOR_V}/trantor/tests/server.{crt,key} \
+ ${P}/trantor/trantor/tests/ \
+ || die "could not copy test certificate and/or key"
+ fi
+}
+
+src_configure() {
+ use doc && HTML_DOCS=( "${BUILD_DIR}/docs/drogon/html/." )
+
+ local -a mycmakeargs=(
+ -DBUILD_DOC=$(usex doc)
+ -DBUILD_EXAMPLES=NO
+ -DBUILD_POSTGRESQL=$(usex postgres)
+ -DBUILD_MYSQL=$(usex mariadb)
+ -DBUILD_SQLITE=$(usex sqlite)
+ -DBUILD_REDIS=$(usex redis)
+ -DBUILD_TESTING=$(usex test)
+ -DBUILD_BROTLI=$(usex brotli)
+ -DBUILD_YAML_CONFIG=$(usex yaml)
+ -DUSE_SUBMODULE=NO
+ $(cmake_use_find_package doc Doxygen)
+ -DUSE_SPDLOG=$(usex spdlog)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use examples && DOCS+=( "${S}/examples" )
+ docompress -x /usr/share/doc/${PF}/examples
+
+ cmake_src_install
+}