aboutsummaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-04-05 17:41:45 -0400
committerJulien Roy <julien@jroy.ca>2024-04-05 17:57:04 -0400
commitf7b91103a5d41d31e4305c1d70d92c9b41aae4dd (patch)
tree7c92a7f90b55f207c8aea5d9e677643f6375ac5e /dev-db
parentdev-db/libpg_query: new package, add 5.1.0 (diff)
downloadguru-f7b91103a5d41d31e4305c1d70d92c9b41aae4dd.tar.gz
guru-f7b91103a5d41d31e4305c1d70d92c9b41aae4dd.tar.bz2
guru-f7b91103a5d41d31e4305c1d70d92c9b41aae4dd.zip
dev-db/pg_query_vala: new package, add 0.1.0_pre20240326
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pg_query_vala/Manifest2
-rw-r--r--dev-db/pg_query_vala/files/unbundle_libpg_query.patch54
-rw-r--r--dev-db/pg_query_vala/metadata.xml17
-rw-r--r--dev-db/pg_query_vala/pg_query_vala-0.1.0_pre20240326.ebuild43
4 files changed, 116 insertions, 0 deletions
diff --git a/dev-db/pg_query_vala/Manifest b/dev-db/pg_query_vala/Manifest
new file mode 100644
index 0000000000..9f85ac07eb
--- /dev/null
+++ b/dev-db/pg_query_vala/Manifest
@@ -0,0 +1,2 @@
+DIST pg_query_vala-0.1.0_pre20240326.gh.tar.gz 15402 BLAKE2B 1bd2b72d262c4784fc08e17b4f8fd96b9ee8400cbc3e069c7305b013fcfe5a87afd97d62831b81ec1ec5aa9a7ef06ead99cbcba1f07e0a788269146c7e5d8bd1 SHA512 f6d7ebe149f9247d387343ede09d6648db2f547ad257ec0edc0f6f10c13173adc5ec4c4aaebc0faf016542ebd3f8731fe0394f40e32bc636be29863ebe05f7e9
+DIST pg_query_vala-0.1.0_pre20240326.tar.gz 4170981 BLAKE2B 8e348d93d5654853406af113c6195948910e6da9978802f6dbed7be9db4b0f6bc5ab4ee60bc6a956851b824e19c5b33a61752d4765c7349a926852ec489a97cc SHA512 7d5c123159129498488a7482b6fdea2a33d0ffc559781476a3f9339fc00aabbc7b0485f3bd78c73e7d89297ad3e25f60130d80f490c3aeadb6370d401955695c
diff --git a/dev-db/pg_query_vala/files/unbundle_libpg_query.patch b/dev-db/pg_query_vala/files/unbundle_libpg_query.patch
new file mode 100644
index 0000000000..33f8476eb8
--- /dev/null
+++ b/dev-db/pg_query_vala/files/unbundle_libpg_query.patch
@@ -0,0 +1,54 @@
+diff --git a/meson.build b/meson.build
+index e6a3093..fbde456 100644
+--- a/meson.build
++++ b/meson.build
+@@ -4,20 +4,16 @@ project(
+ default_options: ['buildtype=release', 'prefix=/usr'],
+ )
+
++cc = meson.get_compiler('c')
++lib_path = meson.current_source_dir() / 'libpg_query'
++libpg_query = cc.find_library('pg_query', required: true)
++
+ dependencies = [
+ dependency('glib-2.0'),
+ dependency('gobject-2.0'),
++ libpg_query
+ ]
+
+-libpg_query = custom_target(
+- 'libpg_query',
+- input: 'libpg_query/Makefile',
+- output: 'libpg_query.a',
+- command: ['script.sh', meson.current_build_dir(), meson.current_source_dir()],
+- build_always: true,
+- install: false,
+-)
+-
+ # foobar_dep = declare_dependency (sources: lib_target)
+
+ sources = files(
+@@ -28,22 +24,15 @@ vapi_dir = meson.current_source_dir() / 'vapi'
+ add_project_arguments(['--vapidir', vapi_dir], language: 'vala')
+ add_project_arguments(['--pkg', 'libpg_query'], language: 'vala')
+
+-# cc = meson.get_compiler('c')
+-# lib_path = meson.current_source_dir() / 'libpg_query'
+-# libpg_query = cc.find_library('pg_query', required: true, dirs: lib_path)
++dependencies += libpg_query
+
+ pgquery_vala = library('pgquery-vala', sources,
+ dependencies: dependencies,
+ include_directories: include_directories('libpg_query'),
+ install: true,
+- link_with: libpg_query,
+ install_dir: [true, true, true]
+ )
+
+-install_headers(
+- 'libpg_query/pg_query.h',
+-)
+-
+ # pgquery_vala_dep = declare_dependency(
+ # include_directories: include_directories('libpg_query/include'),
+ # link_with: pgquery_vala,
diff --git a/dev-db/pg_query_vala/metadata.xml b/dev-db/pg_query_vala/metadata.xml
new file mode 100644
index 0000000000..0ed8c8a28c
--- /dev/null
+++ b/dev-db/pg_query_vala/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Julien Roy</name>
+ <email>julien@jroy.ca</email>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <name>Pham Văn Phúc</name>
+ <email>phuclaplace@gmail.com</email>
+ </maintainer>
+ <bugs-to>https://github.com/ppvan/pg_query_vala/issues</bugs-to>
+ <remote-id type="github">ppvan/pg_query_vala</remote-id>
+ <remote-id type="github">pganalyze/libpg_query</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/pg_query_vala/pg_query_vala-0.1.0_pre20240326.ebuild b/dev-db/pg_query_vala/pg_query_vala-0.1.0_pre20240326.ebuild
new file mode 100644
index 0000000000..801328044a
--- /dev/null
+++ b/dev-db/pg_query_vala/pg_query_vala-0.1.0_pre20240326.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson vala
+
+COMMIT="1b28752e6697cd83408259b18e3158375ff3c025"
+LIBPG_COMMIT="9b21e3295402a0d0ee9a50c468d426c2dbb73ee6"
+DESCRIPTION="Thin wrapper around libpg_query to use with vala"
+HOMEPAGE="https://github.com/ppvan/pg_query_vala"
+SRC_URI="
+ https://github.com/ppvan/pg_query_vala/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz
+ https://github.com/pganalyze/libpg_query/archive/${LIBPG_COMMIT}.tar.gz -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-db/libpg_query
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/glib-2.0.0:2
+ dev-db/libpg_query
+ dev-libs/protobuf-c:0/1.0.0
+ dev-libs/xxhash
+"
+
+PATCHES=(
+ "${FILESDIR}/unbundle_libpg_query.patch"
+)
+
+src_prepare() {
+ default
+ vala_setup
+
+ rmdir "${S}"/libpg_query || die
+ mv "${WORKDIR}"/libpg_query-"${LIBPG_COMMIT}" "${S}"/libpg_query || die
+}