aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-09-08 11:18:17 +0900
committerWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-09-08 11:28:51 +0900
commitab34406a54287f558bebae70ebbfe9549db97b61 (patch)
treebbab625939e7bac2ab771e46822001016eb5f830 /dev-lang/fbc-bootstrap
parentx11-wm/i3-rounded: Fix fetch url (diff)
downloadguru-ab34406a54287f558bebae70ebbfe9549db97b61.tar.gz
guru-ab34406a54287f558bebae70ebbfe9549db97b61.tar.bz2
guru-ab34406a54287f558bebae70ebbfe9549db97b61.zip
dev-lang/fbc-bootstrap: Version bump to 1.08.1
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Diffstat (limited to 'dev-lang/fbc-bootstrap')
-rw-r--r--dev-lang/fbc-bootstrap/Manifest1
-rw-r--r--dev-lang/fbc-bootstrap/fbc-bootstrap-1.08.1.ebuild29
-rw-r--r--dev-lang/fbc-bootstrap/files/fbc-1.08.1-Pass-ltinfo-to-linker.patch25
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-lang/fbc-bootstrap/Manifest b/dev-lang/fbc-bootstrap/Manifest
index 934b90671..ecdea2877 100644
--- a/dev-lang/fbc-bootstrap/Manifest
+++ b/dev-lang/fbc-bootstrap/Manifest
@@ -1 +1,2 @@
DIST FreeBASIC-1.07.3-source-bootstrap.tar.xz 10702984 BLAKE2B dbf68351c54d9a1ec6f5952e7867bc370fdc36db406c9a76d18f9e85757c26f3c954d91ce56593af9ceacf1e24e8038ba7cfeaa66a988923fd5d57d5f160584d SHA512 59a06e633b2bf5054d2b5f7a9da7e539a51657a20d50ac2e055255dab30acc87e03596a53613e1d7f1ac74798d4919b5d7aa32b20a229c7725ebc1e53460b70e
+DIST FreeBASIC-1.08.1-source-bootstrap.tar.xz 12234408 BLAKE2B 5e10e784843253b15b22103d653a16cbabddd143d5b51990c87d4f1082c4ebed9a704bb50d065103bf3381377850cfa561a7dbbd99d11163b507cfc94c2827c7 SHA512 603ef6389ef6a90894dcca7bb31876dae8d1f4014da2b92f6a89cb23665e36130fdd98ffeed6c2e9fa90e549c2fc54450fa55932d22b6eead453b4aa6d4785c2
diff --git a/dev-lang/fbc-bootstrap/fbc-bootstrap-1.08.1.ebuild b/dev-lang/fbc-bootstrap/fbc-bootstrap-1.08.1.ebuild
new file mode 100644
index 000000000..d713fdb56
--- /dev/null
+++ b/dev-lang/fbc-bootstrap/fbc-bootstrap-1.08.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Bootstrap package for dev-lang/fbc"
+HOMEPAGE="https://www.freebasic.net"
+SRC_URI="https://github.com/freebasic/fbc/releases/download/${PV}/FreeBASIC-${PV}-source-bootstrap.tar.xz"
+
+LICENSE="FDL-1.2 GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/fbc-1.08.1-Pass-ltinfo-to-linker.patch )
+
+S="${WORKDIR}/FreeBASIC-${PV}-source-bootstrap"
+
+src_compile() {
+ emake bootstrap-minimal \
+ AR=$(tc-getAR) AS=$(tc-getAS) CC=$(tc-getCC) CFLAGS="${CFLAGS}" V=1
+}
+
+src_install() {
+ newbin bin/fbc fbc-bootstrap
+ emake DESTDIR="${D}" prefix="/usr/share/freebasic-bootstrap" TARGET=${CHOST} install-includes
+ emake DESTDIR="${D}" prefix="/usr/share/freebasic-bootstrap" TARGET=${CHOST} install-rtlib
+}
diff --git a/dev-lang/fbc-bootstrap/files/fbc-1.08.1-Pass-ltinfo-to-linker.patch b/dev-lang/fbc-bootstrap/files/fbc-1.08.1-Pass-ltinfo-to-linker.patch
new file mode 100644
index 000000000..6a57f34be
--- /dev/null
+++ b/dev-lang/fbc-bootstrap/files/fbc-1.08.1-Pass-ltinfo-to-linker.patch
@@ -0,0 +1,25 @@
+From 5e209af787bf74327c0dcba1d75d6a5477dfb0cb Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Wed, 8 Sep 2021 11:27:39 +0900
+Subject: [PATCH] Pass -ltinfo to linker
+
+---
+ makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/makefile b/makefile
+index 04c5c3976..364dc9a0d 100644
+--- a/makefile
++++ b/makefile
+@@ -1368,7 +1368,7 @@ endif
+ # Use gcc to link fbc from the bootstrap .o's
+ # (assuming the rtlib was built already)
+ ifneq ($(filter darwin freebsd dragonfly linux netbsd openbsd solaris,$(TARGET_OS)),)
+- BOOTSTRAP_LIBS := -lncurses -lm -pthread
++ BOOTSTRAP_LIBS := -ltinfo -lncurses -lm -pthread
+ endif
+ $(BOOTSTRAP_FBC): rtlib $(BOOTSTRAP_OBJ)
+ $(QUIET_LINK)$(CC) -o $@ $(libdir)/fbrt0.o bootstrap/$(FBTARGET)/*.o $(libdir)/libfb.a $(BOOTSTRAP_LIBS)
+--
+2.33.0
+