aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tokunaga <tokusan441@gmail.com>2024-07-27 12:07:48 +0900
committerHiroki Tokunaga <tokusan441@gmail.com>2024-07-27 12:07:48 +0900
commit7fcad03c2254b9a76496ec1ed208809c5a2be863 (patch)
tree785343fd9068f652f2a90eea75dd3b5a186247f0 /dev-ml/ocaml-version
parentsys-power/amdfan: fix wrong src_install (diff)
downloadguru-7fcad03c2254b9a76496ec1ed208809c5a2be863.tar.gz
guru-7fcad03c2254b9a76496ec1ed208809c5a2be863.tar.bz2
guru-7fcad03c2254b9a76496ec1ed208809c5a2be863.zip
dev-ml/ocaml-version: new package, add 3.6.7
Signed-off-by: Hiroki Tokunaga <tokusan441@gmail.com>
Diffstat (limited to 'dev-ml/ocaml-version')
-rw-r--r--dev-ml/ocaml-version/Manifest1
-rw-r--r--dev-ml/ocaml-version/metadata.xml26
-rw-r--r--dev-ml/ocaml-version/ocaml-version-3.6.7.ebuild25
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/ocaml-version/Manifest b/dev-ml/ocaml-version/Manifest
new file mode 100644
index 000000000..c5db5f7a2
--- /dev/null
+++ b/dev-ml/ocaml-version/Manifest
@@ -0,0 +1 @@
+DIST ocaml-version-3.6.7.tar.gz 14315 BLAKE2B 6b6599ad17bbf3f023e809ae522db44d32632c6bcc9e09fcb7515bb9219658b36eb6cc1d9da4beff9d1843b1333642b207331c7c98ac07d81279b73e07a3c726 SHA512 879e0eac5ea672b98dc9ba7f236fc048ed829271fe5d95909f23b64e180d64d407684de83684fc0f07373a25feda3ae679daf005f72421a3f1173aa097be8c03
diff --git a/dev-ml/ocaml-version/metadata.xml b/dev-ml/ocaml-version/metadata.xml
new file mode 100644
index 000000000..ef87a3352
--- /dev/null
+++ b/dev-ml/ocaml-version/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tokusan441@gmail.com</email>
+ <name>Hiroki Tokunaga</name>
+ </maintainer>
+ <longdescription lang="en">This library provides facilities to parse version numbers of the OCaml compiler, and enumerates the various official OCaml releases and configuration variants.
+
+OCaml version numbers are of the form `major.minor.patch+extra`, where the `patch` and `extra` fields are optional. This library offers the following functionality:
+
+- Functions to parse and serialise OCaml compiler version numbers.
+- Enumeration of official OCaml compiler version releases.
+- Test compiler versions for a particular feature (e.g. the `bytes` type)
+- [opam](https://opam.ocaml.org) compiler switch enumeration.
+
+### Further information
+
+- **Discussion:** Post on https://discuss.ocaml.org/ with the `ocaml` tag under the Ecosystem category.
+- **Bugs:** https://github.com/ocurrent/ocaml-version/issues
+- **Docs:** http://docs.mirage.io/ocaml-version</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocurrent/ocaml-version/issues</bugs-to>
+ <remote-id type="github">ocurrent/ocaml-version</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-version/ocaml-version-3.6.7.ebuild b/dev-ml/ocaml-version/ocaml-version-3.6.7.ebuild
new file mode 100644
index 000000000..3a9ae0e4d
--- /dev/null
+++ b/dev-ml/ocaml-version/ocaml-version-3.6.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Library to parse and enumerate releases of the OCaml compiler"
+HOMEPAGE="https://github.com/ocurrent/ocaml-version"
+SRC_URI="https://github.com/ocurrent/ocaml-version/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0/${PV}"
+
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-ml/alcotest:=
+ )
+"