aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorHiroki Tokunaga <tokusan441@gmail.com>2024-07-27 16:00:41 +0900
committerHiroki Tokunaga <tokusan441@gmail.com>2024-07-27 16:01:50 +0900
commit1e05f3f795af21d0478172e604435a2eb169570f (patch)
tree41d42d46ab6ba3194a61798637985107ab134a6e /dev-ml
parentgui-apps/hyprpicker: use default cmake.eclass phase (diff)
downloadguru-1e05f3f795af21d0478172e604435a2eb169570f.tar.gz
guru-1e05f3f795af21d0478172e604435a2eb169570f.tar.bz2
guru-1e05f3f795af21d0478172e604435a2eb169570f.zip
dev-ml/ocamlc-loc: new package, add 3.13.1
Signed-off-by: Hiroki Tokunaga <tokusan441@gmail.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlc-loc/Manifest1
-rw-r--r--dev-ml/ocamlc-loc/metadata.xml12
-rw-r--r--dev-ml/ocamlc-loc/ocamlc-loc-3.13.1.ebuild44
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-ml/ocamlc-loc/Manifest b/dev-ml/ocamlc-loc/Manifest
new file mode 100644
index 000000000..f173e2e8c
--- /dev/null
+++ b/dev-ml/ocamlc-loc/Manifest
@@ -0,0 +1 @@
+DIST ocamlc-loc-3.13.1.tar.gz 2891852 BLAKE2B 88cee2428134ddcd6b929915b6bbeb2d17be8b8190f963919a74c63ffcf80f596fb1556f88c41ee602b2386e02fdf396596a6b2097d67c720bd00e16cdda3a57 SHA512 910d4ddd55a91ee65d8ea35b8915506db74c924eb3b67f7b0715da5599ee5088ea3edec81ce6735addd5b17234e445608e59fa353b83e991c14768d83c97a2b5
diff --git a/dev-ml/ocamlc-loc/metadata.xml b/dev-ml/ocamlc-loc/metadata.xml
new file mode 100644
index 000000000..2131acf3b
--- /dev/null
+++ b/dev-ml/ocamlc-loc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tokusan441@gmail.com</email>
+ <name>Hiroki Tokunaga</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/ocaml/dune/issues</bugs-to>
+ <remote-id type="github">ocaml/dune</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocamlc-loc/ocamlc-loc-3.13.1.ebuild b/dev-ml/ocamlc-loc/ocamlc-loc-3.13.1.ebuild
new file mode 100644
index 000000000..5495cd1de
--- /dev/null
+++ b/dev-ml/ocamlc-loc/ocamlc-loc-3.13.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Parse ocaml compiler output into structured form"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/ocamlc-loc/
+ https://github.com/ocaml/dune
+"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="MIT"
+
+SLOT="0/${PV}"
+
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-ml/dyn-${PV}:=
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile ocamlc-loc
+}
+
+src_install() {
+ dune-install ocamlc-loc
+}