aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorHiroki Tokunaga <tokusan441@gmail.com>2024-07-16 11:58:47 +0900
committerHiroki Tokunaga <tokusan441@gmail.com>2024-07-16 12:04:34 +0900
commita111f23836552f9fe75ad651fe0327ff357722a2 (patch)
tree89155a12340aeead701afcc98a0965d94fe5a8e5 /dev-ml
parentnet-p2p/feather: deleted old files and simplified latest ebuild (diff)
downloadguru-a111f23836552f9fe75ad651fe0327ff357722a2.tar.gz
guru-a111f23836552f9fe75ad651fe0327ff357722a2.tar.bz2
guru-a111f23836552f9fe75ad651fe0327ff357722a2.zip
dev-ml/uri: new package, add 4.4.0
Signed-off-by: Hiroki Tokunaga <tokusan441@gmail.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/uri/Manifest1
-rw-r--r--dev-ml/uri/metadata.xml12
-rw-r--r--dev-ml/uri/uri-4.4.0.ebuild40
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/uri/Manifest b/dev-ml/uri/Manifest
new file mode 100644
index 000000000..a173e6253
--- /dev/null
+++ b/dev-ml/uri/Manifest
@@ -0,0 +1 @@
+DIST uri-4.4.0.tar.gz 233155 BLAKE2B c89158884a529c80b677a1c1bd9e7588e2d99e25a677e33c1c304066f37e95d2348ba0d82389531e38863312bc2ffae345049d368fd96c48e249e4376530df07 SHA512 e9deb58e8813f0a48810dc210b8053abb195453f7de6de22b317822d863b2236624462413c34f67658a40b475db132ad13dd09a76cc30c45f8259f3e9e087358
diff --git a/dev-ml/uri/metadata.xml b/dev-ml/uri/metadata.xml
new file mode 100644
index 000000000..537c41e59
--- /dev/null
+++ b/dev-ml/uri/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tokusan441@gmail.com</email>
+ <description>Hiroki Tokunaga</description>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/mirage/ocaml-uri/issues</bugs-to>
+ <remote-id type="github">mirage/ocaml-uri</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/uri/uri-4.4.0.ebuild b/dev-ml/uri/uri-4.4.0.ebuild
new file mode 100644
index 000000000..47c58829f
--- /dev/null
+++ b/dev-ml/uri/uri-4.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="RFC3986 URI parsing library for OCaml"
+HOMEPAGE="https://github.com/mirage/ocaml-uri"
+SRC_URI="https://github.com/mirage/ocaml-uri/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/ocaml-uri-${PV}"
+
+LICENSE="ISC"
+
+SLOT="0/${PV}"
+
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/angstrom:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/stringext:=
+ dev-ml/core_bench:=
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ test? (
+ dev-ml/ounit2:=
+ dev-ml/crowbar:=
+ dev-ml/core_bench:=
+ )
+"