aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-11-14 14:45:49 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-11-14 14:45:49 +0300
commitbba054d8b12c75a21db0e8421c00eebf0e233df1 (patch)
treec046f4465c5245a105b46340a03b20fe44d3c485 /dev-vcs
parentx11-lib/gtk-fortran: 4.3.0 version bump (diff)
downloadguru-bba054d8b12c75a21db0e8421c00eebf0e233df1.tar.gz
guru-bba054d8b12c75a21db0e8421c00eebf0e233df1.tar.bz2
guru-bba054d8b12c75a21db0e8421c00eebf0e233df1.zip
dev-vcs/lazygit: 0.36 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/lazygit/Manifest1
-rw-r--r--dev-vcs/lazygit/lazygit-0.36.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-vcs/lazygit/Manifest b/dev-vcs/lazygit/Manifest
index 85bb93e6d..3c30b413b 100644
--- a/dev-vcs/lazygit/Manifest
+++ b/dev-vcs/lazygit/Manifest
@@ -1,3 +1,4 @@
DIST lazygit-0.33.tar.gz 3729628 BLAKE2B 1cd9a081e5c0b5bd1248404771ed0d2617ef07ce1257a14ebaa13eab785d70ead908d3151fa6019fbc5149d24f7d69a351e7137c2c3878e38cd0630751197e9d SHA512 e878ef0eb64a8d3fb536767f33787dbf06fd27deb2a292e9658f1c97073b5c30d95f3390215bf973e90acc136bcddb839024fddcd4bf25e6dab5f2762a2db379
DIST lazygit-0.34.tar.gz 3733055 BLAKE2B dd53369181f2abf6d7a4776bc751f39a37eb8184fe3811834ee8a99fdcbd4939b260bd1bb86ed26d54b86f4cd509d065cefddcdc5118c266621dfa697a07e7f8 SHA512 a63dd877220c124282667acaadd2f9c55c47687e0c65caff9f61c5a6a3cecc202501fdbd3a1ee13752c8e68bbbb920b5b198459e71a44c585d594675b931d5c2
DIST lazygit-0.35.tar.gz 3896489 BLAKE2B 686af67f3f90fe3e4817c4a30396902e170b67b2892f2907f87e401495d0d1437d9dad6a7609d49d59632c1575af60a53f24042b74b25d00c567d2f0c7afdd87 SHA512 0a121399070b75cdb9f64fff238866c54684e5989d38cd95a822cccc7d16de44f08bb01e93c546874f0c39ed8198e78e03f5167bb711fce643f6a137e05438b9
+DIST lazygit-0.36.tar.gz 4324585 BLAKE2B f9686703ab520e27f17607210cbc73800755481ba07b65ace33bba841c9b0715e00ff673b05920b850127f7fc49a3ee9cca87801ff551c39b6f02076e2fd2a4f SHA512 bdaaa856fcc7c4e1deb89e495db38852f8b07381de8d478d67e84313c09f9d9498b69426dbf161ad03d9a1ec921bad89b9309e9aef7da3af8192f9cca531a1b9
diff --git a/dev-vcs/lazygit/lazygit-0.36.ebuild b/dev-vcs/lazygit/lazygit-0.36.ebuild
new file mode 100644
index 000000000..5c52d8790
--- /dev/null
+++ b/dev-vcs/lazygit/lazygit-0.36.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Simple terminal UI for git commands"
+HOMEPAGE="https://github.com/jesseduffield/lazygit"
+SRC_URI="https://github.com/jesseduffield/${PN}/archive/v${PV}.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD ISC MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${P}.0"
+
+RDEPEND="dev-vcs/git"
+
+DOCS=( {CODE-OF-CONDUCT,CONTRIBUTING,README}.md docs )
+
+src_compile() {
+ go build -o bin/lazygit || die
+}
+
+src_install() {
+ dobin bin/lazygit
+ einstalldocs
+}