aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2023-08-19 13:18:19 -0400
committerYuan Liao <liaoyuan@gmail.com>2023-08-19 13:18:19 -0400
commit8bd80372a6c1b4b03140b3833976846501e27b57 (patch)
tree99ce3d735dabbe7e8ccaa7a74a3f30ff0fff91ba /games-emulation
parentdev-libs/fortran-stdlib: 0.3.0 version bump (diff)
downloadguru-8bd80372a6c1b4b03140b3833976846501e27b57.tar.gz
guru-8bd80372a6c1b4b03140b3833976846501e27b57.tar.bz2
guru-8bd80372a6c1b4b03140b3833976846501e27b57.zip
games-emulation/dosbox-x: Change `freetype` USE flag to `truetype`
`truetype` is a global USE flag, which is more preferable. Signed-off-by: Yuan Liao <liaoyuan@gmail.com>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dosbox-x/dosbox-x-2023.05.01.ebuild6
-rw-r--r--games-emulation/dosbox-x/dosbox-x-9999.ebuild6
-rw-r--r--games-emulation/dosbox-x/metadata.xml8
3 files changed, 10 insertions, 10 deletions
diff --git a/games-emulation/dosbox-x/dosbox-x-2023.05.01.ebuild b/games-emulation/dosbox-x/dosbox-x-2023.05.01.ebuild
index f5c74e3b75..4c4100a93f 100644
--- a/games-emulation/dosbox-x/dosbox-x-2023.05.01.ebuild
+++ b/games-emulation/dosbox-x/dosbox-x-2023.05.01.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://dosbox-x.com/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="X debug ffmpeg fluidsynth freetype opengl png slirp"
+IUSE="X debug ffmpeg fluidsynth opengl png slirp truetype"
# Unit tests are only available in debug builds
RESTRICT="!debug? ( test )"
@@ -61,10 +61,10 @@ RDEPEND="
debug? ( sys-libs/ncurses:= )
ffmpeg? ( media-video/ffmpeg:= )
fluidsynth? ( media-sound/fluidsynth:= )
- freetype? ( media-libs/freetype )
opengl? ( media-libs/libglvnd[X] )
png? ( media-libs/libpng:= )
slirp? ( net-libs/libslirp )
+ truetype? ( media-libs/freetype )
"
DEPEND="
@@ -118,10 +118,10 @@ src_configure() {
$(use_enable X x11)
$(use_enable ffmpeg avcodec)
$(use_enable fluidsynth libfluidsynth)
- $(use_enable freetype)
$(use_enable opengl)
$(use_enable png screenshots)
$(use_enable slirp libslirp)
+ $(use_enable truetype freetype)
)
econf "${myconf[@]}"
diff --git a/games-emulation/dosbox-x/dosbox-x-9999.ebuild b/games-emulation/dosbox-x/dosbox-x-9999.ebuild
index f5c74e3b75..4c4100a93f 100644
--- a/games-emulation/dosbox-x/dosbox-x-9999.ebuild
+++ b/games-emulation/dosbox-x/dosbox-x-9999.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://dosbox-x.com/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="X debug ffmpeg fluidsynth freetype opengl png slirp"
+IUSE="X debug ffmpeg fluidsynth opengl png slirp truetype"
# Unit tests are only available in debug builds
RESTRICT="!debug? ( test )"
@@ -61,10 +61,10 @@ RDEPEND="
debug? ( sys-libs/ncurses:= )
ffmpeg? ( media-video/ffmpeg:= )
fluidsynth? ( media-sound/fluidsynth:= )
- freetype? ( media-libs/freetype )
opengl? ( media-libs/libglvnd[X] )
png? ( media-libs/libpng:= )
slirp? ( net-libs/libslirp )
+ truetype? ( media-libs/freetype )
"
DEPEND="
@@ -118,10 +118,10 @@ src_configure() {
$(use_enable X x11)
$(use_enable ffmpeg avcodec)
$(use_enable fluidsynth libfluidsynth)
- $(use_enable freetype)
$(use_enable opengl)
$(use_enable png screenshots)
$(use_enable slirp libslirp)
+ $(use_enable truetype freetype)
)
econf "${myconf[@]}"
diff --git a/games-emulation/dosbox-x/metadata.xml b/games-emulation/dosbox-x/metadata.xml
index cdbdb12b16..c13d207aed 100644
--- a/games-emulation/dosbox-x/metadata.xml
+++ b/games-emulation/dosbox-x/metadata.xml
@@ -40,10 +40,6 @@
<flag name="fluidsynth">
Enable FluidSynth to be used as the MIDI synthesizer
</flag>
- <flag name="freetype">
- Enable TrueType font (TTF) output and printing support
- via <pkg>media-libs/freetype</pkg>
- </flag>
<flag name="opengl">
Enable OpenGL as a video system to use for output
</flag>
@@ -54,5 +50,9 @@
<flag name="slirp">
Enable the SLIRP back-end for network adapter emulation
</flag>
+ <flag name="truetype">
+ Enable TrueType font (TTF) output and printing support
+ via <pkg>media-libs/freetype</pkg>
+ </flag>
</use>
</pkgmetadata>