aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <william.gray@linaro.org>2023-04-02 09:33:02 -0400
committerWilliam Breathitt Gray <william.gray@linaro.org>2023-04-02 09:35:22 -0400
commit302a5890e74472f7ff667e14d20ff2e7267e1928 (patch)
tree06f391c20c670ac0d3dd37187a73df70eb12ecea /games-fps
parentapp-misc/nwg-look: fix issues link (diff)
downloadguru-302a5890e74472f7ff667e14d20ff2e7267e1928.tar.gz
guru-302a5890e74472f7ff667e14d20ff2e7267e1928.tar.bz2
guru-302a5890e74472f7ff667e14d20ff2e7267e1928.zip
games-fps/crispy-doom: add 6.0
Signed-off-by: William Breathitt Gray <william.gray@linaro.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/crispy-doom/Manifest1
-rw-r--r--games-fps/crispy-doom/crispy-doom-6.0.ebuild77
-rw-r--r--games-fps/crispy-doom/metadata.xml2
3 files changed, 80 insertions, 0 deletions
diff --git a/games-fps/crispy-doom/Manifest b/games-fps/crispy-doom/Manifest
index 31f927be74..4af287abb5 100644
--- a/games-fps/crispy-doom/Manifest
+++ b/games-fps/crispy-doom/Manifest
@@ -1 +1,2 @@
DIST crispy-doom-5.12.0.tar.gz 2425206 BLAKE2B 18c0bd66dcec7b30404e32aa045d5666b89d68f2b9efb6f83455ab007d78816f72218591e5ddcf6ea68a02588f19e98057545dc27219407e450bf4ce600e3c1f SHA512 eb7b4da44c9b261712da4da1935de747928488571ba2be9f0fa43cedd2a0bab3e0f4e0ce1cec247f44ab1b61fc2aa1f545bb0ef50f5f8ac1d3c564342d992a11
+DIST crispy-doom-6.0.tar.gz 2499918 BLAKE2B fc864ae55100db0d074d14eae795bd603b355fba8eaa783b564b167cf1bf65ff1e97f4640d2b0d56f8c4ec076125fd0f0e2a95bc5eac7251997e9f7757f4d295 SHA512 44ab9ffea1febe7eaab0c28d5dd178df821c200354aa9aeecd0b84dbe98419a037416f8d8e6176611dbd1a2dba8ec050d9e7267c61dcf8640c08c422765b270f
diff --git a/games-fps/crispy-doom/crispy-doom-6.0.ebuild b/games-fps/crispy-doom/crispy-doom-6.0.ebuild
new file mode 100644
index 0000000000..b530cfe12f
--- /dev/null
+++ b/games-fps/crispy-doom/crispy-doom-6.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools prefix python-any-r1 xdg
+
+DESCRIPTION="A limit-removing enhanced-resolution Doom source port based on Chocolate Doom"
+HOMEPAGE="https://github.com/fabiangreffrath/crispy-doom"
+SRC_URI="https://github.com/fabiangreffrath/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fluidsynth libsamplerate +midi png truecolor vorbis zlib"
+REQUIRE_USE="fluidsynth? ( midi )"
+
+DEPEND="
+ media-libs/libsdl2[video]
+ media-libs/sdl2-mixer[fluidsynth?,midi?,vorbis?]
+ media-libs/sdl2-net
+ libsamplerate? ( media-libs/libsamplerate )
+ png? ( media-libs/libpng:= )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+# ${PYTHON_DEPS} for bash-completion
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( ${PYTHON_DEPS} )"
+
+S="${WORKDIR}"/${PN}-${P}
+
+DOCS=(
+ "AUTHORS"
+ "ChangeLog"
+ "NEWS.md"
+ "NOT-BUGS.md"
+ "PHILOSOPHY.md"
+ "README.md"
+ "README.Music.md"
+ "README.Strife.md"
+)
+
+src_prepare() {
+ default
+
+ hprefixify src/d_iwad.c
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-bash-completion \
+ $(use_enable doc) \
+ --disable-fonts \
+ --disable-icons \
+ $(use_with libsamplerate) \
+ $(use_with png libpng) \
+ --enable-sdl2mixer \
+ --enable-sdl2net \
+ $(use_with fluidsynth) \
+ $(use_enable truecolor) \
+ $(use_with zlib) \
+ --disable-zpool
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Remove redundant documentation files
+ rm -r "${ED}/usr/share/doc/"* || die
+
+ einstalldocs
+}
diff --git a/games-fps/crispy-doom/metadata.xml b/games-fps/crispy-doom/metadata.xml
index 5a1acd247c..06a1018720 100644
--- a/games-fps/crispy-doom/metadata.xml
+++ b/games-fps/crispy-doom/metadata.xml
@@ -9,6 +9,8 @@
<name>William Breathitt Gray</name>
</maintainer>
<use>
+ <flag name="fluidsynth">Use <pkg>media-sound/fluidsynth</pkg>
+ for MIDI support</flag>
<flag name="midi">Basic support for MIDI files</flag>
<flag name="truecolor">Enable true-color rendering (experimental)</flag>
</use>