aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-01-02 11:02:27 +0000
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-01-02 11:28:50 +0000
commit9d70430aee4c496fb5cb4f712a9e19b33702b8df (patch)
treed916c6cada54da52bad9920252cbc7879b8256c5 /gui-wm/hyprland-contrib
parentgui-apps/hyprland-split-monitor-workspaces: new package, add 0.31.0, 0.32.3, ... (diff)
downloadguru-9d70430aee4c496fb5cb4f712a9e19b33702b8df.tar.gz
guru-9d70430aee4c496fb5cb4f712a9e19b33702b8df.tar.bz2
guru-9d70430aee4c496fb5cb4f712a9e19b33702b8df.zip
gui-wm/hyprland-contrib: add 9999
* add me as Proxy Mantainer Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'gui-wm/hyprland-contrib')
-rw-r--r--gui-wm/hyprland-contrib/hyprland-contrib-0.1.ebuild10
-rw-r--r--gui-wm/hyprland-contrib/hyprland-contrib-9999.ebuild92
-rw-r--r--gui-wm/hyprland-contrib/metadata.xml1
3 files changed, 101 insertions, 2 deletions
diff --git a/gui-wm/hyprland-contrib/hyprland-contrib-0.1.ebuild b/gui-wm/hyprland-contrib/hyprland-contrib-0.1.ebuild
index 3f381d5a7..687cfd39d 100644
--- a/gui-wm/hyprland-contrib/hyprland-contrib-0.1.ebuild
+++ b/gui-wm/hyprland-contrib/hyprland-contrib-0.1.ebuild
@@ -7,11 +7,17 @@ inherit optfeature
DESCRIPTION="Community-maintained extensions for hyprland"
HOMEPAGE="https://hyprland.org/"
-SRC_URI="https://github.com/hyprwm/contrib/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/contrib.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/contrib/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/contrib-${PV}"
+ KEYWORDS="~amd64"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
IUSE="+grimblast +hyprprop +scratchpad +shellevents +swap"
RDEPEND="
diff --git a/gui-wm/hyprland-contrib/hyprland-contrib-9999.ebuild b/gui-wm/hyprland-contrib/hyprland-contrib-9999.ebuild
new file mode 100644
index 000000000..1634a6bf6
--- /dev/null
+++ b/gui-wm/hyprland-contrib/hyprland-contrib-9999.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Community-maintained extensions for hyprland"
+HOMEPAGE="https://hyprland.org/"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/contrib.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/contrib/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/contrib-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+grimblast +hyprprop +hdrop +scratchpad +shellevents +swap"
+
+RDEPEND="
+ app-shells/bash
+ gui-wm/hyprland
+ grimblast? (
+ gui-apps/wl-clipboard
+ gui-apps/grim
+ app-misc/jq
+ gui-apps/slurp
+ app-misc/jq
+ )
+ hyprprop? (
+ app-misc/jq
+ gui-apps/slurp
+ )
+ scratchpad? (
+ sys-apps/sed
+ app-misc/jq
+ gui-apps/slurp
+ app-misc/jq
+ )
+"
+BDEPEND="
+ grimblast? (
+ app-text/scdoc
+ )
+ hyprprop? (
+ app-text/scdoc
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ if use grimblast; then
+ pushd grimblast || die
+ PREFIX="${D}/usr" emake install
+ popd || die
+ fi
+ if use hyprprop; then
+ pushd hyprprop || die
+ PREFIX="${D}/usr" emake install
+ popd || die
+ fi
+ if use hdrop; then
+ pushd hdrop || die
+ PREFIX="${D}/usr" emake hdrop.1 #PR:80 will fix this
+ PREFIX="${D}/usr" emake install
+ popd || die
+ fi
+ if use scratchpad; then
+ pushd scratchpad || die
+ PREFIX="${D}/usr" emake install
+ popd || die
+ fi
+ if use shellevents; then
+ pushd shellevents || die
+ PREFIX="${D}/usr" emake install
+ popd || die
+ fi
+ if use swap; then
+ pushd try_swap_workspace || die
+ PREFIX="${D}/usr" emake install
+ popd || die
+ fi
+}
+
+pkg_postinst() {
+ if use grimblast || use hyprprop || use hdrop || use scratchpad || use swap; then
+ optfeature "GUI notifications during dependency checks" x11-libs/libnotify
+ fi
+}
diff --git a/gui-wm/hyprland-contrib/metadata.xml b/gui-wm/hyprland-contrib/metadata.xml
index 080d8933c..4bb94f072 100644
--- a/gui-wm/hyprland-contrib/metadata.xml
+++ b/gui-wm/hyprland-contrib/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="grimblast">Install grimblast, a hyprland version of grimshot</flag>
<flag name="hyprprop">Install hyprprop, a xprop replacement for hyprland</flag>
+ <flag name="hdrop">Install hdrop, a tdrop replacement for Hyprland</flag>
<flag name="scratchpad">Install scratchpad script</flag>
<flag name="shellevents">Install shellevents, invoke hell functions in response to Hyprland socket events</flag>
<flag name="swap">Install try_swap_workspace, a script to emulate monitor-workspace agnostic behavior of other window managers</flag>