aboutsummaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-07-30 05:09:13 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-07-30 05:11:29 +0200
commite1d64cc676c1264118777b31de7ce17afabdf43b (patch)
treee33fcc74aaaa152ff1f608841d12677f7c848abe /gui-wm
parentdev-R/RcppArmadillo: treeclean (diff)
downloadguru-e1d64cc676c1264118777b31de7ce17afabdf43b.tar.gz
guru-e1d64cc676c1264118777b31de7ce17afabdf43b.tar.bz2
guru-e1d64cc676c1264118777b31de7ce17afabdf43b.zip
gui-wm/cage: drop 0.1.3, drop 0.1.4, add 0.1.5
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/cage/Manifest3
-rw-r--r--gui-wm/cage/cage-0.1.4.ebuild32
-rw-r--r--gui-wm/cage/cage-0.1.5.ebuild (renamed from gui-wm/cage/cage-0.1.3.ebuild)6
-rw-r--r--gui-wm/cage/cage-9999.ebuild6
4 files changed, 7 insertions, 40 deletions
diff --git a/gui-wm/cage/Manifest b/gui-wm/cage/Manifest
index 450c7c9c6..2c22779cd 100644
--- a/gui-wm/cage/Manifest
+++ b/gui-wm/cage/Manifest
@@ -1,2 +1 @@
-DIST cage-0.1.3.tar.gz 24615 BLAKE2B 6c06cabfd2faca568c7d96095199d42c5798228f44688c285c6300a20e95ab320385513b8081f798b92a70cb7fdfa33cbd0572c4647aa8a2db75e4a50dc638be SHA512 34d2dca963810f6173343ae280e2692645a79e263aa1c01d22730db5cc14e68c0b0ec19dd947134ef27841f2ee28a28d5d71e64c396b81b6230426220517471b
-DIST cage-0.1.4.tar.gz 25430 BLAKE2B a479695cf4f46c6e9fc54934c50c46f50d2f8f7f72d257267003ef4bb79c7f2b3e90232c0d6843164f7873625876cb7665b5f46d42f6b66efa6565cc99ae1a47 SHA512 55773fac44bf9e98086e53cbc20d17e3aad7046bedfe638ef8f896543388481be3989fede6f950d4f8cb0583f701cbf79617dfa011c7777a7c8b22c9bcddd64f
+DIST cage-0.1.5.tar.gz 23179 BLAKE2B ee75b4cc7a550315aec643778aaf61323564f1e4be0c2ca994754123b978859e513a1e11d459b3954cd37f566cf9ec2a96c4e54f141a2337380cf02f64056eb6 SHA512 d50fc5b7efa691e487a05c8e4e573ed441a31840b1742eb1d3b0e827a1da381426f8e9c620de197cf928a99cab57af8a3042f08d5aadd3fc4ddf0c5afadb3231
diff --git a/gui-wm/cage/cage-0.1.4.ebuild b/gui-wm/cage/cage-0.1.4.ebuild
deleted file mode 100644
index b463a1277..000000000
--- a/gui-wm/cage/cage-0.1.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-if [[ "${PV}" == 9999 ]]
-then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Hjdskes/cage"
-else
- SRC_URI="https://github.com/Hjdskes/cage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="A Wayland kiosk"
-HOMEPAGE="https://www.hjdskes.nl/projects/cage/ https://github.com/Hjdskes/cage"
-LICENSE="MIT"
-SLOT="0"
-
-IUSE="X"
-
-RDEPEND="
- >=gui-libs/wlroots-0.14[X?]
- x11-libs/libxkbcommon[X?]
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- meson_src_configure $(meson_use X xwayland)
-}
diff --git a/gui-wm/cage/cage-0.1.3.ebuild b/gui-wm/cage/cage-0.1.5.ebuild
index c5d073332..be36aee28 100644
--- a/gui-wm/cage/cage-0.1.3.ebuild
+++ b/gui-wm/cage/cage-0.1.5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -22,7 +22,7 @@ SLOT="0"
IUSE="X"
RDEPEND="
- >=gui-libs/wlroots-0.13[X?]
+ >=gui-libs/wlroots-0.16[X?]
x11-libs/libxkbcommon[X?]
"
DEPEND="${RDEPEND}"
diff --git a/gui-wm/cage/cage-9999.ebuild b/gui-wm/cage/cage-9999.ebuild
index b463a1277..be36aee28 100644
--- a/gui-wm/cage/cage-9999.ebuild
+++ b/gui-wm/cage/cage-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -22,7 +22,7 @@ SLOT="0"
IUSE="X"
RDEPEND="
- >=gui-libs/wlroots-0.14[X?]
+ >=gui-libs/wlroots-0.16[X?]
x11-libs/libxkbcommon[X?]
"
DEPEND="${RDEPEND}"