aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-10-19 00:32:53 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-10-19 00:32:53 +0900
commit4efdc8bfa98ec62090cfa8885ebb0f1d2f2d85b0 (patch)
tree47c37279a3aced31873d3b54630e22104a083843 /media-plugins
parentprofiles: mask app-admin/enpass-desktop-bin for removal (diff)
downloadguru-4efdc8bfa98ec62090cfa8885ebb0f1d2f2d85b0.tar.gz
guru-4efdc8bfa98ec62090cfa8885ebb0f1d2f2d85b0.tar.bz2
guru-4efdc8bfa98ec62090cfa8885ebb0f1d2f2d85b0.zip
media-plugins/whysynth: fix RDEPEND
Closes: https://bugs.gentoo.org/840380 Closes: https://bugs.gentoo.org/932775 Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/whysynth/metadata.xml2
-rw-r--r--media-plugins/whysynth/whysynth-20170701_p20180323-r1.ebuild (renamed from media-plugins/whysynth/whysynth-20170701_p20180323.ebuild)29
2 files changed, 20 insertions, 11 deletions
diff --git a/media-plugins/whysynth/metadata.xml b/media-plugins/whysynth/metadata.xml
index 9b998aeff..51a12fe5e 100644
--- a/media-plugins/whysynth/metadata.xml
+++ b/media-plugins/whysynth/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>
- <remote-id type="github">smbolton/whysynth</remote-id>
+ <remote-id type="github">theabolton/whysynth</remote-id>
</upstream>
<longdescription lang="en">
WhySynth is a versatile softsynth which operates as a plugin for the DSSI Soft Synth Interface. A brief list of features:
diff --git a/media-plugins/whysynth/whysynth-20170701_p20180323.ebuild b/media-plugins/whysynth/whysynth-20170701_p20180323-r1.ebuild
index 62a8ae840..14be37c3b 100644
--- a/media-plugins/whysynth/whysynth-20170701_p20180323.ebuild
+++ b/media-plugins/whysynth/whysynth-20170701_p20180323-r1.ebuild
@@ -1,32 +1,41 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
DESCRIPTION="A software synthesizer plugin for the DSSI Soft Synth Interface"
-HOMEPAGE="http://smbolton.com/whysynth.html https://github.com/smbolton/whysynth"
+HOMEPAGE="https://smbolton.com/whysynth.html https://github.com/theabolton/whysynth"
WHYSYNTH_COMMIT="32e4bc73baa554bb1844b3165e657911f43f3568"
-SRC_URI="https://github.com/smbolton/${PN}/archive/${WHYSYNTH_COMMIT}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/theabolton/${PN}/archive/${WHYSYNTH_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${WHYSYNTH_COMMIT}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-DEPEND="media-libs/dssi
+DEPEND="
+ dev-libs/glib:2
+ media-libs/alsa-lib
+ media-libs/dssi
+ media-libs/ladspa-sdk
media-libs/liblo
- sci-libs/fftw:3.0
+ sci-libs/fftw:3.0=
+ x11-libs/cairo
x11-libs/gtk+:2
- media-libs/ladspa-sdk
- media-libs/alsa-lib"
+"
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
src_prepare() {
- ./autogen.sh
+ ./autogen.sh || die
default
eautoreconf
}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}