aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Alirzaev <l29ah@riseup.net>2022-11-19 14:54:39 +0100
committerSergey Alirzaev <l29ah@riseup.net>2022-11-19 14:54:39 +0100
commitbec3c0bb5f6ade91dc6ca90954061b06c832101a (patch)
treec32019b22bc5cf25010b7e4b0bc999579054f794 /media-sound
parentdev-util/toml-f: change category to 'dev-libs' (diff)
downloadguru-bec3c0bb5f6ade91dc6ca90954061b06c832101a.tar.gz
guru-bec3c0bb5f6ade91dc6ca90954061b06c832101a.tar.bz2
guru-bec3c0bb5f6ade91dc6ca90954061b06c832101a.zip
media-sound/qloud: new package, add 1.4.2
Signed-off-by: Sergey Alirzaev <l29ah@riseup.net>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qloud/Manifest1
-rw-r--r--media-sound/qloud/metadata.xml7
-rw-r--r--media-sound/qloud/qloud-1.4.2.ebuild69
3 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/qloud/Manifest b/media-sound/qloud/Manifest
new file mode 100644
index 000000000..28b39ac54
--- /dev/null
+++ b/media-sound/qloud/Manifest
@@ -0,0 +1 @@
+DIST qloud-1.4.2.tar.gz 49992 BLAKE2B b8a4b0d27a3b2d2a0037418bf5f8c4dc8cad28c60c4b73dbafee1547ef783bf6eb7bb6c40c0d0b5d8ac03bb4ee45f1fde1845f1bb6036370b970be716c2ebe44 SHA512 6c402f11850a663aed8f9688065d0d42da75774011d34184aa61db40a8d8e173eab99afe179a9860ef35a8d54c1f51ad9db085bf77bee02f9e9538086764be20
diff --git a/media-sound/qloud/metadata.xml b/media-sound/qloud/metadata.xml
new file mode 100644
index 000000000..181e8922d
--- /dev/null
+++ b/media-sound/qloud/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">molke-productions/qloud</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/qloud/qloud-1.4.2.ebuild b/media-sound/qloud/qloud-1.4.2.ebuild
new file mode 100644
index 000000000..db3f39bce
--- /dev/null
+++ b/media-sound/qloud/qloud-1.4.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/molke-productions/${PN}"
+fi
+
+DESCRIPTION="Tool to measure loudspeaker frequency and step responses and distortions"
+HOMEPAGE="https://github.com/molke-productions/qloud"
+
+if [[ "${PV}" != "9999" ]]; then
+ SRC_URI="https://github.com/molke-productions/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+else
+ SRC_URI=""
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+## x11-libs/qwt:6 to be removed in the near future
+RDEPEND="
+ dev-qt/qtcharts:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/libsndfile
+ sci-libs/fftw:3.0
+ virtual/jack
+
+ x11-libs/qwt:6
+"
+DEPEND="${RDEPEND}
+"
+
+src_prepare() {
+ default
+
+ sed -e "s!/usr/local!/usr!" \
+ -i config.pri || die
+
+ sed -e "s!/usr/include/qwt!/usr/include/qwt6!" \
+ -i src/src.pro || die
+
+ sed -e "s!-lqwt!-lqwt6-qt5!" \
+ -i src/src.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}