aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-08-04 17:26:30 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-08-04 17:26:30 +0500
commit3cc6e8a85c3838ab4beaac78f57a5fec14dab027 (patch)
tree55f3a088d49605939bced585a6ccf78b34d98782 /net-client
parentdev-nim/weave: add missing test dep (diff)
downloadguru-3cc6e8a85c3838ab4beaac78f57a5fec14dab027.tar.gz
guru-3cc6e8a85c3838ab4beaac78f57a5fec14dab027.tar.bz2
guru-3cc6e8a85c3838ab4beaac78f57a5fec14dab027.zip
net-client/offpunk: drop 0.3, add 1.5
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'net-client')
-rw-r--r--net-client/offpunk/Manifest2
-rw-r--r--net-client/offpunk/offpunk-0.3.ebuild27
-rw-r--r--net-client/offpunk/offpunk-1.5.ebuild40
3 files changed, 41 insertions, 28 deletions
diff --git a/net-client/offpunk/Manifest b/net-client/offpunk/Manifest
index b3484f689..583d91126 100644
--- a/net-client/offpunk/Manifest
+++ b/net-client/offpunk/Manifest
@@ -1,2 +1,2 @@
-DIST offpunk-0.3.tar.gz 37000 BLAKE2B b47fd241acef4155337a336d5a25b4a727849a28d2b1a9a9f3c2475960f472e238f5bc50ac59f582daf5ed3b1ec69edc1c6b4c6e5eebe64fd2c962eb7dbe00a2 SHA512 1336e7f0aab177a786c114143b5b8fa4eaa3a4b675581d2ec38d55268f8a006158a181b659732a89cf000f8be550ae38e222bbae827abaea2bc7a2875397acc9
DIST offpunk-1.4.tar.gz 206458 BLAKE2B ca13838db2697e336c2e574a4995f55f2026d162679690d7e3fdff998f2b0a4c7e9ad5ee0749c9bfc1edaedba5572f177df6e67684b43fcb355d2cce25366c78 SHA512 929c036cee562c09b4f637e09f51a62a8e8547a4eeaa34bbea4c2ddaf69556a0474e7b0682063842cc0387b0823507fb102dcd1866cad3d39fbd51ff5d2c94c6
+DIST offpunk-1.5.tar.gz 206829 BLAKE2B 976901904e39b3ba76394758b7959c2b344ca1bb8c35b1d900d41092050fbad43833af48d6b3d82aa8542cb9ab1c34b644cc6c56946e2092b38dc7de5606c9b2 SHA512 e28ee7ef49a868b31702bdc7a573c183efcb0f42d3e22f22c32c3fbd37d9b45ccb59bad60dff1be213ac6e04a18e37ab89c5b1abbe4e2bcd75937cf6f4d02191
diff --git a/net-client/offpunk/offpunk-0.3.ebuild b/net-client/offpunk/offpunk-0.3.ebuild
deleted file mode 100644
index 87e9e775a..000000000
--- a/net-client/offpunk/offpunk-0.3.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 optfeature
-
-MY_PN="av-98-offline"
-DESCRIPTION="A command-line, text-based and offline-first Gemini browser"
-HOMEPAGE="https://tildegit.org/ploum/AV-98-offline"
-SRC_URI="https://tildegit.org/ploum/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DOCS=( CHANGELOG README.md )
-
-pkg_postinst() {
- optfeature "better TOFU certificate validation" dev-python/cryptography
- #optfeature "ANSI escape codes support" dev-python/ansiwrap
- optfeature "MIME type detection support" dev-python/python-magic
- optfeature "clipboard support" x11-misc/xsel
-}
diff --git a/net-client/offpunk/offpunk-1.5.ebuild b/net-client/offpunk/offpunk-1.5.ebuild
new file mode 100644
index 000000000..24a0a1972
--- /dev/null
+++ b/net-client/offpunk/offpunk-1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Offline-First Gemini/Web/Gopher/RSS reader and browser"
+HOMEPAGE="https://notabug.org/ploum/offpunk"
+SRC_URI="https://notabug.org/ploum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( doc/. CHANGELOG README.md )
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 0.4; then
+ ewarn 'You should run once the command "list subscribe subscribed".'
+ ewarn 'Without that, the subscribed list will be seen as a normal list by sync.'
+ fi
+
+ optfeature "HTML support" "dev-python/beautifulsoup4 dev-python/readability-lxml"
+ optfeature "HTTP support" dev-python/requests
+ optfeature "RSS/Atom feed support" dev-python/feedparser
+ optfeature "XDG support" x11-misc/xdg-utils
+ optfeature "better TOFU certificate validation" dev-python/cryptography
+ optfeature "clipboard support" x11-misc/xsel
+ optfeature "custom process title support" dev-python/setproctitle
+ optfeature "external MP3 player" media-sound/mpg123
+ optfeature "external OGG player" media-sound/vorbis-tools[ogg123]
+ optfeature "external PDF viewer" app-text/zathura
+ optfeature "external image viewer support" media-gfx/feh
+ optfeature "inline images support" media-gfx/chafa
+}