aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Gireud <agireud@protonmail.com>2024-04-04 10:39:19 -0500
committerAlberto Gireud <agireud@protonmail.com>2024-04-04 10:39:19 -0500
commit55aca3b6cbd1aa6f6ef125e5227bfac8005868c5 (patch)
tree5148baac7571d17c05ba76feea61d76421d3b626 /net-irc
parentdev-python/b2sdk: fix manifest (diff)
downloadguru-55aca3b6cbd1aa6f6ef125e5227bfac8005868c5.tar.gz
guru-55aca3b6cbd1aa6f6ef125e5227bfac8005868c5.tar.bz2
guru-55aca3b6cbd1aa6f6ef125e5227bfac8005868c5.zip
net-irc/halloy: Handle desktop, icon, and mime info database updates
Closes: https://bugs.gentoo.org/928582 Signed-off-by: Alberto Gireud <agireud@protonmail.com>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/halloy/halloy-2024.5.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-irc/halloy/halloy-2024.5.ebuild b/net-irc/halloy/halloy-2024.5.ebuild
index b263d56848..33ace8182a 100644
--- a/net-irc/halloy/halloy-2024.5.ebuild
+++ b/net-irc/halloy/halloy-2024.5.ebuild
@@ -489,7 +489,7 @@ declare -A GIT_CRATES=(
[winit]='https://github.com/iced-rs/winit;b91e39ece2c0d378c3b80da7f3ab50e17bb798a5;winit-%commit%'
)
-inherit cargo desktop
+inherit cargo desktop xdg
DESCRIPTION="IRC application written in Rust"
HOMEPAGE="https://halloy.squidowl.org"
@@ -572,3 +572,11 @@ src_install() {
cargo_src_install
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}