aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-04-05 15:56:05 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-04-05 15:57:18 +0500
commit0f6da0b9717504dd3472e1c5f62962e2079cbaf3 (patch)
tree240c1648f3ddeb6a8383c73c4c03aae6ad17b5d4 /net-misc/gdown
parentapp-misc/nwg-look: add missing dependencies (diff)
downloadguru-0f6da0b9717504dd3472e1c5f62962e2079cbaf3.tar.gz
guru-0f6da0b9717504dd3472e1c5f62962e2079cbaf3.tar.bz2
guru-0f6da0b9717504dd3472e1c5f62962e2079cbaf3.zip
net-misc/gdown: new package, add 4.7.1
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'net-misc/gdown')
-rw-r--r--net-misc/gdown/Manifest1
-rw-r--r--net-misc/gdown/gdown-4.7.1.ebuild32
-rw-r--r--net-misc/gdown/metadata.xml12
3 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/gdown/Manifest b/net-misc/gdown/Manifest
new file mode 100644
index 000000000..6a7b25db6
--- /dev/null
+++ b/net-misc/gdown/Manifest
@@ -0,0 +1 @@
+DIST gdown-4.7.1.gh.tar.gz 238770 BLAKE2B 3a362eaf98bcd006d02edcefb61a9c2722701c3c05f0997ed78216b630698ac1362554d40663ce1833faa66c6c42623cb119271c299a8ba1bddefd958cd4ce15 SHA512 1302fce5c920dc963d0d278c1c295821a30fb5034de3ecd6da8c49871dce85e0d4a2eba00233d3eb5214b49149bd2d5246db1a21aa68241b0ba67fddd2509019
diff --git a/net-misc/gdown/gdown-4.7.1.ebuild b/net-misc/gdown/gdown-4.7.1.ebuild
new file mode 100644
index 000000000..5fa3fe0d0
--- /dev/null
+++ b/net-misc/gdown/gdown-4.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Google Drive direct download of big files"
+HOMEPAGE="
+ https://pypi.org/project/gdown/
+ https://github.com/wkentaro/gdown
+"
+SRC_URI="https://github.com/wkentaro/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/requests[socks5,${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/net-misc/gdown/metadata.xml b/net-misc/gdown/metadata.xml
new file mode 100644
index 000000000..35953b469
--- /dev/null
+++ b/net-misc/gdown/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">wkentaro/gdown</remote-id>
+ <remote-id type="pypi">gdown</remote-id>
+ </upstream>
+</pkgmetadata>