aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-02-04 11:34:25 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-02-04 11:35:44 +0200
commit946c727ad3f0037939cf8a0b45586c955ac186ac (patch)
tree408355ea7f2765312a72b956fd2bc3d24fe9a7fc /net-misc/maestral-qt
parentnet-misc/maestral: drop 1.6.6_rc0 (diff)
downloadguru-946c727ad3f0037939cf8a0b45586c955ac186ac.tar.gz
guru-946c727ad3f0037939cf8a0b45586c955ac186ac.tar.bz2
guru-946c727ad3f0037939cf8a0b45586c955ac186ac.zip
net-misc/maestral-qt: add 1.6.6_rc1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-misc/maestral-qt')
-rw-r--r--net-misc/maestral-qt/Manifest1
-rw-r--r--net-misc/maestral-qt/maestral-qt-1.6.6_rc1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/maestral-qt/Manifest b/net-misc/maestral-qt/Manifest
index 53b2837e5..6d96b9989 100644
--- a/net-misc/maestral-qt/Manifest
+++ b/net-misc/maestral-qt/Manifest
@@ -1,2 +1,3 @@
DIST maestral-qt-1.5.3.gh.tar.gz 1209467 BLAKE2B d810df1f7e21938b81565afb16049e385c5de1e295d64feeaa317966e139ddc76542a747db71ae76dc1c82a11ec7e266b69968cefa2839878941def4af7711f8 SHA512 fbc8723d6751e31504529a62f00f7becd4531d8613559edde2a4725bc0d5ac783e6c817814059489bead87923135462a871cdffd0f8d1f0f06481df20efde4f5
DIST maestral-qt-1.6.5.gh.tar.gz 1217959 BLAKE2B fb57171e3b6ed286e03d143e0fbd7dba0eae69bd4402c271bd9897549d84f3b509f459577f0c44ba252bca6a9b651d70bd825565e2afdb86a97966a728803eaf SHA512 f34ca35fad1b1509a1cea605974c5f0ffb79763c2e6e6dcf68454246dd303d67274e1e46954270cd0d2eb171a427af2ef477cc19d0bb05634a3aeb593f69d7aa
+DIST maestral-qt-1.6.6_rc1.gh.tar.gz 1219500 BLAKE2B 221750f753f1e8dd58365823fb8aedfadf0ef59aadac700712e8637a18878769c90862a8ac406551e695f07dbfe7e212037d2b6ba8674b62e73c6e9d1c45d45d SHA512 adbf4efded4130d7d955409511389608d71b5171d0e5d64e04c391311bf94ff8c1c79e5934cd42d5fab168e081ac85ee8be31a6812c3c4903eb1b8b6bdefd018
diff --git a/net-misc/maestral-qt/maestral-qt-1.6.6_rc1.ebuild b/net-misc/maestral-qt/maestral-qt-1.6.6_rc1.ebuild
new file mode 100644
index 000000000..bae62d984
--- /dev/null
+++ b/net-misc/maestral-qt/maestral-qt-1.6.6_rc1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit desktop distutils-r1
+
+MY_PV=${PV/_rc/.dev}
+DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
+HOMEPAGE="https://maestral.app"
+SRC_URI="https://github.com/samschott/${PN}/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/PyQt6[widgets,gui,svg,${PYTHON_USEDEP}]
+ ~net-misc/maestral-${PV}[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ domenu src/maestral_qt/resources/maestral.desktop
+}