aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <dev@pyl.onl>2024-08-27 21:13:09 -0500
committerZen <dev@pyl.onl>2024-08-27 21:14:13 -0500
commit0e4b0735b043ce45d2d6e6efcc3289927f11ba07 (patch)
tree3ae1108b13a94432eb02e90e8341c4214ac94fb9 /net-misc
parentnet-im/matterhorn-bin: add 90000.0.1 (diff)
downloadguru-0e4b0735b043ce45d2d6e6efcc3289927f11ba07.tar.gz
guru-0e4b0735b043ce45d2d6e6efcc3289927f11ba07.tar.bz2
guru-0e4b0735b043ce45d2d6e6efcc3289927f11ba07.zip
net-misc/mbpoll: add 1.5.2, 9999
please check this Signed-off-by: Zen <dev@pyl.onl>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mbpoll/Manifest1
-rw-r--r--net-misc/mbpoll/mbpoll-1.5.2.ebuild28
-rw-r--r--net-misc/mbpoll/mbpoll-9999.ebuild27
-rw-r--r--net-misc/mbpoll/metadata.xml11
4 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/mbpoll/Manifest b/net-misc/mbpoll/Manifest
new file mode 100644
index 000000000..6a3a77f9c
--- /dev/null
+++ b/net-misc/mbpoll/Manifest
@@ -0,0 +1 @@
+DIST mbpoll-1.5.2.tar.gz 100948 BLAKE2B 043337e7d1aef9f5b274c2da272ce35e175bf9486e3969888c790c11c5c24485b76dd92a60e93ee3aa1b0d2b208d254ff9d36b5706fa8f27a5e810cfaeed9fc2 SHA512 738b1b57002c0920ca574954d02609998d96d8a492a5a2b7178ff95a40442f957fabec88f116d883c5deb7a54bfc414a56583734a5314da4305db819da53b081
diff --git a/net-misc/mbpoll/mbpoll-1.5.2.ebuild b/net-misc/mbpoll/mbpoll-1.5.2.ebuild
new file mode 100644
index 000000000..0d52895fe
--- /dev/null
+++ b/net-misc/mbpoll/mbpoll-1.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="command line utility to communicate with ModBus slave (RTU or TCP) "
+HOMEPAGE="https://github.com/epsilonrt/mbpoll"
+SRC_URI="https://github.com/epsilonrt/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/libmodbus"
+RDEPEND="${DEPEND}"
+
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+}
+
+
diff --git a/net-misc/mbpoll/mbpoll-9999.ebuild b/net-misc/mbpoll/mbpoll-9999.ebuild
new file mode 100644
index 000000000..834c52585
--- /dev/null
+++ b/net-misc/mbpoll/mbpoll-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 cmake
+
+DESCRIPTION="command line utility to communicate with ModBus slave (RTU or TCP) "
+HOMEPAGE="https://github.com/epsilonrt/mbpoll"
+EGIT_REPO_URI="https://github.com/epsilonrt/${PN}"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-libs/libmodbus"
+RDEPEND="${DEPEND}"
+
+
+src_configure() {
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+}
+
+
diff --git a/net-misc/mbpoll/metadata.xml b/net-misc/mbpoll/metadata.xml
new file mode 100644
index 000000000..38c0e395f
--- /dev/null
+++ b/net-misc/mbpoll/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev@pyl.onl</email>
+ <name>Zen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">epsilonrt/mbpoll</remote-id>
+ </upstream>
+</pkgmetadata>