aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-07 08:15:05 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-07 08:15:05 +0300
commit2caf9d4daab44887bbc08a4c07237f133f150b5e (patch)
treeed3a4cc8fcba0b9f9bdebcf9e05841dee6e2f78c /net-misc
parentnet-wireless/sdrpp: Cleanup unused patchfile (diff)
downloadguru-2caf9d4daab44887bbc08a4c07237f133f150b5e.tar.gz
guru-2caf9d4daab44887bbc08a4c07237f133f150b5e.tar.bz2
guru-2caf9d4daab44887bbc08a4c07237f133f150b5e.zip
net-misc/maestral: add 1.9.4_rc1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/maestral/Manifest1
-rw-r--r--net-misc/maestral/maestral-1.9.4_rc1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/maestral/Manifest b/net-misc/maestral/Manifest
index 089c4945e..5248ce0d9 100644
--- a/net-misc/maestral/Manifest
+++ b/net-misc/maestral/Manifest
@@ -1 +1,2 @@
DIST maestral-1.9.3.gh.tar.gz 8126807 BLAKE2B 1e4a4e0d39d31b81d6894b3d46100eaa96e2bb99576f59c4e8a784ade14d09e273e8c16d154bd54d883270e30ec7d7a882307584d3ed1f77e8e1710eb94daae7 SHA512 6d66cc0929dffb8221ef186d9fd7a639725e50782092710fc74b05e5e678055a1fc75da6d0299315ffc6f8107ec24d1039d72973b73da0def41839a35eca1f03
+DIST maestral-1.9.4_rc1.gh.tar.gz 8129805 BLAKE2B ff92fb206928ccafec51cb99570e9d825ead1d1833fb22a587c03f03303ff562c9f55b32cd7aca09e34af7a3648dea05005f134c875229f4c5d803b5f9082d49 SHA512 293bd1b5764f65fef972f9946446a267efba3fa68ff47523f9d72568e55c7e270934803020aa8ec5f3253db3a5646316357f5ab80354db809af3dd8826171ab2
diff --git a/net-misc/maestral/maestral-1.9.4_rc1.ebuild b/net-misc/maestral/maestral-1.9.4_rc1.ebuild
new file mode 100644
index 000000000..249d0019b
--- /dev/null
+++ b/net-misc/maestral/maestral-1.9.4_rc1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 xdg
+
+MY_PV=${PV/_rc/.dev}
+DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
+HOMEPAGE="https://maestral.app"
+SRC_URI="https://github.com/samschott/maestral/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
+ >=dev-python/desktop-notifier-3.3.0[${PYTHON_USEDEP}]
+ dev-python/dropbox[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.15[${PYTHON_USEDEP}]
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ >=dev-python/keyring-22.0.0[${PYTHON_USEDEP}]
+ >=dev-python/keyrings-alt-3.1.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.5.8[${PYTHON_USEDEP}]
+ >=dev-python/Pyro5-5.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/survey[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
+ dev-python/xattr[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+"
+
+EPYTEST_DESELECT=(
+ # requires dev-python/pytest-benchmark not available for py3.11
+ tests/offline/test_clean_local_events.py::test_performance
+
+ # requires systemd
+ tests/offline/test_cli.py::test_autostart
+
+ # requires network
+ tests/offline/test_main.py::test_check_for_updates
+
+ # may fail if the filesystem does not support xattrs
+ # https://bugs.gentoo.org/927982
+ tests/offline/utils/test_path.py::test_move_preserves_xattrs
+)
+
+distutils_enable_tests pytest