aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortea <gentoo@tastytea.de>2024-06-15 16:17:34 +0200
committertea <gentoo@tastytea.de>2024-06-15 17:12:15 +0200
commita5f398e4fce8b9c458bcd89dbc0529e004e11034 (patch)
treedc473425612cac82580af21a24ce03e6975238a7 /net-misc
parentnet-misc/mastorss: drop 0.13.0 (diff)
downloadguru-a5f398e4fce8b9c458bcd89dbc0529e004e11034.tar.gz
guru-a5f398e4fce8b9c458bcd89dbc0529e004e11034.tar.bz2
guru-a5f398e4fce8b9c458bcd89dbc0529e004e11034.zip
net-misc/mastorss: EAPI 7->8
Signed-off-by: tea <gentoo@tastytea.de>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mastorss/mastorss-0.13.1-r1.ebuild32
-rw-r--r--net-misc/mastorss/mastorss-9999.ebuild2
2 files changed, 33 insertions, 1 deletions
diff --git a/net-misc/mastorss/mastorss-0.13.1-r1.ebuild b/net-misc/mastorss/mastorss-0.13.1-r1.ebuild
new file mode 100644
index 000000000..6ecd511c6
--- /dev/null
+++ b/net-misc/mastorss/mastorss-0.13.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020,2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+[[ "${PV}" == "9999" ]] && inherit git-r3
+
+DESCRIPTION="Another RSS to Mastodon bot"
+HOMEPAGE="https://schlomp.space/tastytea/mastorss"
+if [[ "${PV}" != "9999" ]]; then
+ SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+ KEYWORDS="~amd64"
+else
+ EGIT_REPO_URI="https://schlomp.space/tastytea/mastorss.git"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/boost
+ >=dev-cpp/mastodonpp-0.5.6
+ dev-libs/jsoncpp
+ net-misc/curl[ssl]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/asciidoc
+"
diff --git a/net-misc/mastorss/mastorss-9999.ebuild b/net-misc/mastorss/mastorss-9999.ebuild
index 32b428ed3..6ecd511c6 100644
--- a/net-misc/mastorss/mastorss-9999.ebuild
+++ b/net-misc/mastorss/mastorss-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020,2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
[[ "${PV}" == "9999" ]] && inherit git-r3