aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2024-04-03 18:48:25 -0400
committerJoe Kappus <joe@wt.gd>2024-04-03 18:48:30 -0400
commit97b91e01ae220e1e5ccbd5ff4d99c0a76aef8a2c (patch)
tree09b838eed1beeef7bdac761076fd811940f26e1e /net-nntp
parentdev-cpp/simdutf: drop 4.0.9 (diff)
downloadguru-97b91e01ae220e1e5ccbd5ff4d99c0a76aef8a2c.tar.gz
guru-97b91e01ae220e1e5ccbd5ff4d99c0a76aef8a2c.tar.bz2
guru-97b91e01ae220e1e5ccbd5ff4d99c0a76aef8a2c.zip
net-nntp/pan: add 0.157
There will be a -r1 at some point, upstream unfortunately moved to cmake and this is the last release that supports autotools and cmake. I will adapt it soon, but this bump is fully functional. Signed-off-by: Joe Kappus <joe@wt.gd>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/pan/Manifest1
-rw-r--r--net-nntp/pan/pan-0.157.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-nntp/pan/Manifest b/net-nntp/pan/Manifest
index 8f78cccdb4..3ccfa17b97 100644
--- a/net-nntp/pan/Manifest
+++ b/net-nntp/pan/Manifest
@@ -1,2 +1,3 @@
DIST pan-v0.154.tar.bz2 1787849 BLAKE2B fca621408ae0d6720de85e179e840fe445ac4945881e82bf7e2697b39da77ab36ffe990ad8b7887b9fc3a03b5edeee8fa7d6597ae3cf0efb0c35f6e4cfb28242 SHA512 af3fe526d4bc0f0011ec52e32f95bf872925ab81c94f2b742fb192f49a012e495299ab3be4400ce626d81ab6e176c0bd83dfed4037fe9ab7863fa1c4fe3c1bf6
DIST pan-v0.155.tar.bz2 1797355 BLAKE2B 262123f73a79677640c7a98f4917d037fad27a644a5f9f4d63b7460d31f8a68c346da9d5521a3b54ac13df53c99fd97864f7cb2795135f6e675fb74cd8321d47 SHA512 85605a76dad1868926cc021a4642c40dca737b0fb77410c4e82981bf02e8157f8347518fccc82157804e89bd0786863a00bd1cc963637da3a54b82043e9c15f0
+DIST pan-v0.157.tar.bz2 1819034 BLAKE2B 0e28184050ce4e2a62ef6f273ce06ccb25a61bd380a7790a9236aab63b3f4e381fd4d4881c922d0fef4f228cc92a72c868a1ad19fe684a0ab2f02af65ff0e57d SHA512 f15c139756467c4a9b241ad4efab8df611d8a2533597a9b3d275410a7cb6ed4575430ff200be442792fc2170b4580898aed269a26e3d63c109bae62ea2d41978
diff --git a/net-nntp/pan/pan-0.157.ebuild b/net-nntp/pan/pan-0.157.ebuild
new file mode 100644
index 0000000000..f1e8285fee
--- /dev/null
+++ b/net-nntp/pan/pan-0.157.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools gnome2
+
+DESCRIPTION="A newsreader for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/pan/"
+SRC_URI="https://gitlab.gnome.org/GNOME/pan/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="dbus gnome-keyring libnotify nls spell ssl"
+
+DEPEND="
+ >=dev-libs/glib-2.26:2
+ dev-libs/gmime:3.0
+ >=x11-libs/gtk+-3.00:3
+ gnome-keyring? (
+ >=app-crypt/gcr-3.20
+ >=app-crypt/libsecret-0.20
+ )
+ libnotify? ( >=x11-libs/libnotify-0.4.1:0= )
+ spell? (
+ >=app-text/enchant-2.2.3:2
+ >=app-text/gtkspell-3.0.10:3 )
+ ssl? ( >=net-libs/gnutls-3:0= )
+ >=sys-libs/zlib-1.2.0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/pan-v${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with dbus) \
+ $(use_enable gnome-keyring gkr) \
+ $(use_enable nls) \
+ $(use_with spell gtkspell) \
+ $(use_enable libnotify) \
+ $(use_with ssl gnutls)
+ )
+
+ gnome2_src_configure "${myconf[@]}"
+}