aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois-Xavier Carton <fx.carton91@gmail.com>2022-05-24 23:08:26 +0200
committerFrançois-Xavier Carton <fx.carton91@gmail.com>2022-05-24 23:30:01 +0200
commit6f826a3a6d6b7328a362fe4830c0ddb4a0aacbe6 (patch)
tree0b17a3d4562f76812ef6b1dba3d765f1b77cbc43 /sci-mathematics
parentsci-mathematics/frama-c: respect CFLAGS (diff)
downloadguru-6f826a3a6d6b7328a362fe4830c0ddb4a0aacbe6.tar.gz
guru-6f826a3a6d6b7328a362fe4830c0ddb4a0aacbe6.tar.bz2
guru-6f826a3a6d6b7328a362fe4830c0ddb4a0aacbe6.zip
sci-mathematics/frama-c: better fix for flags issue
Signed-off-by: François-Xavier Carton <fx.carton91@gmail.com>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/frama-c/files/frama-c-24.0-fix-bflags.patch12
-rw-r--r--sci-mathematics/frama-c/frama-c-24.0.ebuild6
2 files changed, 15 insertions, 3 deletions
diff --git a/sci-mathematics/frama-c/files/frama-c-24.0-fix-bflags.patch b/sci-mathematics/frama-c/files/frama-c-24.0-fix-bflags.patch
new file mode 100644
index 000000000..b52231fa0
--- /dev/null
+++ b/sci-mathematics/frama-c/files/frama-c-24.0-fix-bflags.patch
@@ -0,0 +1,12 @@
+https://git.frama-c.com/pub/frama-c/-/issues/2593
+
+--- a/Makefile 2021-11-30 01:00:00.000000000 +0100
++++ b/Makefile 2022-01-14 15:19:18.855072759 +0100
+@@ -671,6 +671,7 @@
+
+ NON_OPAQUE_DEPS+= src/kernel_services/plugin_entry_points/dynamic
+
++src/kernel_services/abstract_interp/abstract_memory.cmi: BFLAGS := $(BFLAGS)
+ src/kernel_services/abstract_interp/abstract_memory.cmo: BFLAGS += -rectypes
+ src/kernel_services/abstract_interp/abstract_memory.cmx: OFLAGS += -rectypes
+
diff --git a/sci-mathematics/frama-c/frama-c-24.0.ebuild b/sci-mathematics/frama-c/frama-c-24.0.ebuild
index 59f668c96..6d8212f5a 100644
--- a/sci-mathematics/frama-c/frama-c-24.0.ebuild
+++ b/sci-mathematics/frama-c/frama-c-24.0.ebuild
@@ -27,13 +27,15 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P}-${NAME}"
+PATCHES=( ${FILESDIR}/frama-c-24.0-fix-bflags.patch )
+
src_prepare() {
mv configure.in configure.ac || die
sed -i 's/configure\.in/configure.ac/g' Makefile.generating Makefile || die
touch config_file || die
sed -i '/^\t\$(CC)/s/ -O3 /$(CFLAGS)/' Makefile || die
eautoreconf
- eapply_user
+ default
}
src_configure() {
@@ -45,8 +47,6 @@ src_configure() {
src_compile() {
tc-export AR
- # workaround for https://git.frama-c.com/pub/frama-c/-/issues/2593
- emake VERBOSEMAKE=yes src/kernel_services/abstract_interp/abstract_memory.cmi
emake VERBOSEMAKE=yes
}