aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-04-09 05:54:03 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-04-09 06:21:20 +0500
commit869a6fd8d45b92317d0fb6cd82bbc928e45b020f (patch)
treef15530ebdcc23a435011b003b92e1bd742fe050b /sec-keys/signify-keys-telescope/signify-keys-telescope-0.9.ebuild
parentnet-misc/gmid: add 2.0.2 (diff)
downloadguru-869a6fd8d45b92317d0fb6cd82bbc928e45b020f.tar.gz
guru-869a6fd8d45b92317d0fb6cd82bbc928e45b020f.tar.bz2
guru-869a6fd8d45b92317d0fb6cd82bbc928e45b020f.zip
sec-keys/signify-keys-telescope: add 0.9
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'sec-keys/signify-keys-telescope/signify-keys-telescope-0.9.ebuild')
-rw-r--r--sec-keys/signify-keys-telescope/signify-keys-telescope-0.9.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sec-keys/signify-keys-telescope/signify-keys-telescope-0.9.ebuild b/sec-keys/signify-keys-telescope/signify-keys-telescope-0.9.ebuild
new file mode 100644
index 000000000..4432de27a
--- /dev/null
+++ b/sec-keys/signify-keys-telescope/signify-keys-telescope-0.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN#signify-keys-}-${PV}"
+DESCRIPTION="Signify keys used to sign telescope releases"
+HOMEPAGE="https://telescope.omarpolo.com/"
+SRC_URI="https://ftp.omarpolo.com/${MY_P}.pub"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+src_install() {
+ local files=( ${A} )
+
+ insinto /usr/share/signify-keys
+ newins - ${MY_P}.pub < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}