aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMattéo Rossillol‑‑Laruelle <beatussum@protonmail.com>2024-08-05 20:04:29 +0200
committerMattéo Rossillol‑‑Laruelle <beatussum@protonmail.com>2024-08-05 20:05:24 +0200
commit15e4cd6ecfae5edbf787d1ad843cf81d2d8923fe (patch)
tree4a4ca630419f5703734b6a61c59798ae42f5da85 /sys-apps
parentdev-util/shellspec: new package, add 0.28.1, 9999 (diff)
downloadguru-15e4cd6ecfae5edbf787d1ad843cf81d2d8923fe.tar.gz
guru-15e4cd6ecfae5edbf787d1ad843cf81d2d8923fe.tar.bz2
guru-15e4cd6ecfae5edbf787d1ad843cf81d2d8923fe.zip
sys-apps/save-backlight: new package, add 1.1.2, 9999
Signed-off-by: Mattéo Rossillol‑‑Laruelle <beatussum@protonmail.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/save-backlight/Manifest1
-rw-r--r--sys-apps/save-backlight/metadata.xml17
-rw-r--r--sys-apps/save-backlight/save-backlight-1.1.2.ebuild28
-rw-r--r--sys-apps/save-backlight/save-backlight-9999.ebuild28
4 files changed, 74 insertions, 0 deletions
diff --git a/sys-apps/save-backlight/Manifest b/sys-apps/save-backlight/Manifest
new file mode 100644
index 000000000..896a0815e
--- /dev/null
+++ b/sys-apps/save-backlight/Manifest
@@ -0,0 +1 @@
+DIST save-backlight-1.1.2.tar.gz 13516 BLAKE2B fb8511a6c7e8941cd2eaaa46eb1899ad9e32cd79d9472e60bcc4cc00c2b39fff1569202030077e9fd649c79710b926b4534953d4a945007741d79da4fd4b671f SHA512 a739796560c02e80b9b1a12b12b9ee9f9e2c93ef81ac2c1f07b8b49aa77481843e58379d39f28e644b2be4ec76a36a9578139a617ffa0b536e76133cede1c382
diff --git a/sys-apps/save-backlight/metadata.xml b/sys-apps/save-backlight/metadata.xml
new file mode 100644
index 000000000..f1b46e4cf
--- /dev/null
+++ b/sys-apps/save-backlight/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>beatussum@protonmail.com</email>
+ <name>Mattéo Rossillol‑‑Laruelle</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <maintainer status="active">
+ <name>Mattéo Rossillol‑‑Laruelle</name>
+ <email>beatussum@protonmail.com</email>
+ </maintainer>
+ <bugs-to>https://github.com/beatussum/save-backlight/issues/</bugs-to>
+ <remote-id type="github">beatussum/save-backlight</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/save-backlight/save-backlight-1.1.2.ebuild b/sys-apps/save-backlight/save-backlight-1.1.2.ebuild
new file mode 100644
index 000000000..b7ff9c29b
--- /dev/null
+++ b/sys-apps/save-backlight/save-backlight-1.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="An OpenRC service for restoring the last brightness level on reboot"
+HOMEPAGE="https://github.com/beatussum/save-backlight/"
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/beatussum/save-backlight.git"
+else
+ SRC_URI="https://github.com/beatussum/save-backlight/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="binchecks strip test"
+
+RDEPEND="sys-apps/openrc"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ emake PREFIX="" DESTDIR="${D}" install
+}
diff --git a/sys-apps/save-backlight/save-backlight-9999.ebuild b/sys-apps/save-backlight/save-backlight-9999.ebuild
new file mode 100644
index 000000000..b7ff9c29b
--- /dev/null
+++ b/sys-apps/save-backlight/save-backlight-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="An OpenRC service for restoring the last brightness level on reboot"
+HOMEPAGE="https://github.com/beatussum/save-backlight/"
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/beatussum/save-backlight.git"
+else
+ SRC_URI="https://github.com/beatussum/save-backlight/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="binchecks strip test"
+
+RDEPEND="sys-apps/openrc"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ emake PREFIX="" DESTDIR="${D}" install
+}