aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAda Ahmed <yretenai@gmail.com>2024-07-25 11:57:21 +0100
committerAda Ahmed <yretenai@gmail.com>2024-07-25 12:01:08 +0100
commit721ad5893082c338bb395e244ef42028b0b54dcd (patch)
treeb024057205c43ad894b4b30767a30467ed97796f /sys-apps
parentdev-embedded/esp-idf-kconfig: keyword 2.2.0 for ~amd64 (diff)
downloadguru-721ad5893082c338bb395e244ef42028b0b54dcd.tar.gz
guru-721ad5893082c338bb395e244ef42028b0b54dcd.tar.bz2
guru-721ad5893082c338bb395e244ef42028b0b54dcd.zip
sys-apps/pnpm-bin: bump 9.6.0
sys-apps/pnpm-bin: ~arm64 Signed-off-by: Ada Ahmed <yretenai@gmail.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pnpm-bin/pnpm-bin-9.6.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/pnpm-bin/pnpm-bin-9.6.0.ebuild b/sys-apps/pnpm-bin/pnpm-bin-9.6.0.ebuild
new file mode 100644
index 000000000..10758d811
--- /dev/null
+++ b/sys-apps/pnpm-bin/pnpm-bin-9.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Fast, disk space efficient package manager, alternative to npm and yarn"
+HOMEPAGE="https://pnpm.io"
+SRC_URI="
+ amd64? ( https://github.com/pnpm/pnpm/releases/download/v${PV}/pnpm-linux-x64 -> ${PV}-amd64 )
+ arm64? ( https://github.com/pnpm/pnpm/releases/download/v${PV}/pnpm-linux-arm64 -> ${PV}-arm64 )
+"
+
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 -*"
+
+RESTRICT="strip"
+
+QA_PREBUILT="usr/bin/pnpm"
+
+src_install() {
+ newbin "${DISTDIR}/${PV}-${ARCH}" pnpm
+}